Windows 10 asking for password on network drive


Recommended Posts

What exactly do you mean by the username for your server? The webUI and command line of your server can only be accessed by the "root" user. Shares are accessed by users you create in Unraid, depending on the security settings for each share. "root" only has guest access to shares over the network, the same as any user that does not have a login.

 

Have you created any users in Unraid for accessing shares over the network?

Link to comment

Perhaps the other side of this puzzle is the fact that Windows will only let you log in as one user to another computer on the network, and if you have already established a connection as one user, it won't let you use another user even though it will prompt you to log in. You have to get rid of the login it has already established before Windows will let you use a different one. Control Panel - Credential Manager.

Link to comment
1 minute ago, trurl said:

What exactly do you mean by the username for your server? The webUI and command line of your server can only be accessed by the "root" user. Shares are accessed by users you create in Unraid, depending on the security settings for each share. "root" only has guest access to shares over the network, the same as any user that does not have a login.

 

Have you created any users in Unraid for accessing shares over the network?

Thanks for the reply. I mean when going to my unraid address in a browser 192.168.1.xx I have one user setup "root" and a password. This works. When I go to file explorer> network > unraid network drive it brings up a windows security prompt to enter network credentials... says "enter your credentials to connect to: "Unraid server name" then shows root as the username and asks for a password. Or you can change the username. If I put in the password for root for the unraid server that is not correct. Hope this makes sense.

Link to comment
11 minutes ago, trurl said:

Perhaps the other side of this puzzle is the fact that Windows will only let you log in as one user to another computer on the network, and if you have already established a connection as one user, it won't let you use another user even though it will prompt you to log in. You have to get rid of the login it has already established before Windows will let you use a different one. Control Panel - Credential Manager.

hmm i do see it in windows credentials but I changed the password and that still is not working

Link to comment

Not exactly sure where things are not working from your description. You really shouldn't use the root user for accessing shares over the network anyway, though it should work (as a guest) assuming you are only trying to access a share with Public access.

 

Go to Credential Manager and delete the credential for your server so Windows can renegotiate it.

 

 

Link to comment
19 minutes ago, trurl said:

Not exactly sure where things are not working from your description. You really shouldn't use the root user for accessing shares over the network anyway, though it should work (as a guest) assuming you are only trying to access a share with Public access.

 

Go to Credential Manager and delete the credential for your server so Windows can renegotiate it.

 

 

I don't really think I am using the root user. I'll try to explain better. If I go to a browser and type the ip address of my server it then will bring up a prompt to login and this is my user name "root" and password. I can then access the Unraid GUI. My actual unraid server is called Jakenas I guess (not really sure where I even changed that). So, if I then go into file explorer on my PC and go down to "Network" the server "Jakenas" will then appear under Computers. When I click on this I used to be able to access all my server folders without logging in. Now it is asking for a username and password. It automatically defaults to Root and asks for a password. I went and deleted Jakenas from credential manager and now when clicking on it it just says windows cannot access \\JAKENAS check the spelling of the name, etc.

Link to comment

As mentioned, you shouldn't really be using "root" to access shares on the network anyway. "root" will work, but just the same as "some_random_user" would work, as a guest user that only has access to public shares.

 

What do you get from the Windows Command Prompt with this?

net use

 

Link to comment
8 minutes ago, trurl said:

As mentioned, you shouldn't really be using "root" to access shares on the network anyway. "root" will work, but just the same as "some_random_user" would work, as a guest user that only has access to public shares.

 

What do you get from the Windows Command Prompt with this?


net use

 

SO how do I not use root? I haven't set up any other users in Unraid. Net use gives me "Net connections will be remembered. There are no entries in the list"

Link to comment
  • 4 months later...

Could it be that the current version of windows refuses to connect to anoymous shares? I had to enable insecure guest access in Group Policy settings:

 

Computer configuration\administrative templates\network\Lanman Workstation

"Enable insecure guest logons"

 

https://support.microsoft.com/en-ca/help/4046019/guest-access-in-smb2-disabled-by-default-in-windows-10-and-windows-ser

 

I did this and was happy with the result.

Link to comment
  • 1 year later...

Hey, I know this is a little late but I had this same thing exactly happen to me today, browsed shares last night just fine, woke up to it asking for credentials... tried rebooting, both machines, server and pc, tied restarting smb, tried logging in using root and other created things, then used my windows login and pass and it opened right up... this has to be a bug in windows somewhere, where it's actually asking for admin permission but doesn't use the right form maybe? Idk, bit I know that it worked. Thanks.

Link to comment
  • 1 month later...
6 hours ago, publicENEMY said:

I just reformatted my pc and can confirm none of the fix mentioned here works. https://docs.microsoft.com/en-US/troubleshoot/windows-server/networking/guest-access-in-smb2-is-disabled-by-default

 

On Windows 10 Pro

 

With at least three posts on the same basic topic, I have to ask, "Is there a problem that you need an answer to and what are you trying to do?"  Many Unraid users have been trying to run Unraid SMB with a absolute minimum of security and that has become a whack-a-mole situation as MS continues to increase SMB security.

 

I did put together a paper about Windows SMB access issues in which the premise is not to try to bypass Win10 security features.  You might want to read it and see if that solves your problem.  You can find it here:

 

         https://forums.unraid.net/topic/110580-security-is-not-a-dirty-word-unraid-windows-10-smb-setup/

 

Link to comment
On 9/19/2021 at 8:09 PM, Frank1940 said:

 

With at least three posts on the same basic topic, I have to ask, "Is there a problem that you need an answer to and what are you trying to do?"  Many Unraid users have been trying to run Unraid SMB with a absolute minimum of security and that has become a whack-a-mole situation as MS continues to increase SMB security.

 

I did put together a paper about Windows SMB access issues in which the premise is not to try to bypass Win10 security features.  You might want to read it and see if that solves your problem.  You can find it here:

 

         https://forums.unraid.net/topic/110580-security-is-not-a-dirty-word-unraid-windows-10-smb-setup/

 

Thank you. I am not aware of the pdf guide. After enabling SMBv1 (as per pdf guide), it seems to work fine on my end. Sorry for the question asked. I was really frustrated having to troubleshoot all day.

 

Thanks.

Edited by publicENEMY
Link to comment
  • 3 weeks later...

I recently completed a fresh Windows 11 reinstall on my desktop computer and wasn't able to access my Unraid server from Windows Explorer. It kept popping up with the asking for credentials and it didn't require it on my linux install or my previous windows install.. in the end, I just needed to change my network from Public to Private in Windows Network & Internet settings for my connection. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.