[Support] ich777 - Gameserver Dockers


4202 posts in this topic Last Reply

Recommended Posts

I have issues with the Valheim docker container when starting without the "validate installation" set to true, the container won't start. If I enable "validate installation" it works but it downloads some dependency every time. As far as I can see from the logs the problem is a missing SDL dependency. This is the message I see:

sdl Warning: failed to init SDL thread priority manager: SDL not found

 

I have experimented with the Docker image and the solution I found was to add the following:

RUN dpkg --add-architecture i386

RUN apt-get update && \
	apt-get -y install --no-install-recommends lib32gcc1 screen file libc6-dev unzip libsdl2-2.0 libsdl2-2.0-0:i386 && \
	rm -rf /var/lib/apt/lists/*

Specifically those two: "libsdl2-2.0 libsdl2-2.0-0:i386"

 

Do you think you could add this to the image? This will also make the container start faster since it does not have to resolve those missing dependencies at runtime.

Link to post
  • Replies 4.2k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Summary: Support Thread for ich777 Gameserver Dockers (CounterStrike: Source & ConterStrike: GO, TeamFortress 2, ArmA III,... - complete list in the second post) Application: SteamCMD Do

Just thought I'd share my experience setting up a Valheim server with this docker app from @ich777(thank you!)   You don't need to worry about Steam authentication for Valheim, the default a

Dockers Available so far:   SteamCMD DedicatedServers: CounterStrike: Source CounterStrike: Global Offensive TeamFortress 2 ArmA3 - requested by @MrSage D

Posted Images

Is it possible for Valheim to be put behind a reverse proxy like swag so I can use a domain to join rather then wan ip address? sometimes friends can not join via the community list as it does not show, and i do not want to give out my public ip address to people to add to the steam server list.

Link to post
3 minutes ago, schuu said:

Is it possible for Valheim to be put behind a reverse proxy like swag so I can use a domain to join rather then wan ip address? sometimes friends can not join via the community list as it does not show, and i do not want to give out my public ip address to people to add to the steam server list.

I guess this is not the right thread for questions like this, but as far as I know there is no way to join a Valheim server with a domain. The only way is to add it as a favorite server in steam but then the resolved IP will show anyway.

Link to post
2 minutes ago, Durin said:

I guess this is not the right thread for questions like this, but as far as I know there is no way to join a Valheim server with a domain. The only way is to add it as a favorite server in steam but then the resolved IP will show anyway.

 

yeah i just want something easy to remember, to give to people rather then looking up my ip all the time ( it's dynamic )

Link to post
32 minutes ago, schuu said:

 

yeah i just want something easy to remember, to give to people rather then looking up my ip all the time ( it's dynamic )

Add the server in steam servers with your dyndns:port name. This should work. Unfortunately, they didn't implement this inside the game...

Link to post
3 hours ago, Durin said:

As far as I can see from the logs the problem is a missing SDL dependency.

What is the exact issue, this is nothing to worry about...

As the warning itself says, it's a warning not an error.

 

3 hours ago, Durin said:

the container won't start.

I can not reproduce this issue, a log output would be very helpful, this is the startup of a fresh installed container: valheim.log

 

EDIT: this is the log output after a normal restart of the container (including the above posted log output, can it be that you save is corrupt?): valheim2.log

 

Have you changed anything in the template?

 

2 hours ago, schuu said:

Is it possible for Valheim to be put behind a reverse proxy like swag so I can use a domain to join rather then wan ip address?

As @Durin said no because this is a completely different protocol that Valheim uses than http or https.

Your friends can connect with YOURDOMAINNAME:PORT in the Steam Server browser because your domain would be translated in your public IP so this should not be a problem, all you have to do is set up the DuckDNS container from @linuxserver.io and register a DuckDNS domainname and you should be good to go.

 

Link to post
5 minutes ago, ich777 said:

As @Durin said no because this is a completely different protocol that Valheim uses than http or https.

Your friends can connect with YOURDOMAINNAME:PORT in the Steam Server browser because your domain would be translated in your public IP so this should not be a problem, all you have to do is set up the DuckDNS container from @linuxserver.io and register a DuckDNS domainname and you should be good to go.

thats exactly what i ended up doing, having a cname pointed at duckdns for the ip

Link to post
27 minutes ago, ich777 said:

What is the exact issue, this is nothing to worry about...

As the warning itself says, it's a warning not an error.

 

I can not reproduce this issue, a log output would be very helpful, this is the startup of a fresh installed container:

I tried with a fresh install now and I can no longer reproduce the error, I guess there was something wrong with the other deployment.

 

I still think you should remove the "public" property and clearly state that password is required however! :)

Link to post
38 minutes ago, Durin said:

I still think you should remove the "public" property and clearly state that password is required however! :)

The public property is still in there but if you look at the password I have removed that you can leave it empty (I won't change too much because this game is in pretty early alpha and I don't know what changes next).

 

grafik.thumb.png.97f20f7e5da5d3a26ff13cfbe2a75fb1.png

Link to post

The server works fine but when i enbable valheimplus i get that error:

 

 

Connecting anonymously to Steam Public...Logged in OK
Waiting for user info...OK
Success! App '896660' already up to date.
---Prepare Server---
---ValheimPlus enabled!---
---Can't get latest version of Valheim Plus!---
---Please try to run the Container without ValheimPlus, putting Container into sleep mode!---

 

 

Does anyone know a solution or gets the same problem?

Sometimes i also get this error:

Waiting for user info...OK
Success! App '896660' already up to date.
---Prepare Server---
---ValheimPlus enabled!---
---ValheimPlus Version Check---
---Version missmatch, ValheimPlus v0.8.5 installed, downloading and installing v...---
---Something went wrong, can't download ValheimPlus v, putting container into sleep mode!---

Edited by kol_L
additional info
Link to post
27 minutes ago, kol_L said:

The server works fine but when i enbable valheimplus i get that error:

 

 

Connecting anonymously to Steam Public...Logged in OK
Waiting for user info...OK
Success! App '896660' already up to date.
---Prepare Server---
---ValheimPlus enabled!---
---Can't get latest version of Valheim Plus!---
---Please try to run the Container without ValheimPlus, putting Container into sleep mode!---

 

 

Does anyone know a solution or gets the same problem?

Had the same error. Then started once without Valheim + and then again with. After that I got the following message: 
 

Quote

Connecting anonymously to Steam Public...Logged in OK
Waiting for user info...OK
Update state (0x5) verifying install, progress: 0.20 (2097152 / 1045271601)
Update state (0x5) verifying install, progress: 30.01 (313689057 / 1045271601)
Update state (0x5) verifying install, progress: 73.13 (764420281 / 1045271601)
Success! App '896660' fully installed.
---Prepare Server---
---ValheimPlus enabled!---
---ValheimPlus Version Check---

---ValheimPlus v0.8.5 up-to-date---
sed: can't read /serverdata/serverfiles/run_bepinex.sh: No such file or directory
sed: can't read /serverdata/serverfiles/run_bepinex.sh: No such file or directory
chmod: cannot access '/serverdata/serverfiles/run_bepinex.sh': No such file or directory
---Server ready---
---Starting Backup daemon---
---Start Server---
/opt/scripts/start-server.sh: line 125: /serverdata/serverfiles/run_bepinex.sh: No such file or directory
---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---Update SteamCMD---
---Update SteamCMD---
Redirecting stderr to '/serverdata/serverfiles/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.

Redirecting stderr to '/serverdata/serverfiles/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.

Connecting anonymously to Steam Public...Logged in OK
Waiting for user info...OK
---Update Server---
---Validating installation---
Redirecting stderr to '/serverdata/serverfiles/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.

This runs permanently in a loop

Edited by Racoon1989
Link to post
49 minutes ago, kol_L said:

The server works fine but when i enbable valheimplus i get that error

Are you sure that the container has exclusive access to the internet without PiHole or anything in front of it, it downloads just fine on my end but they've changed something lately.

 

22 minutes ago, Racoon1989 said:

This runs permanently in a loop

Please try to run the server without ValheimPlus for now they changed something that breaks the container.

Link to post
43 minutes ago, Racoon1989 said:

Had the same error. Then started once without Valheim + and then again with. After that I got the following message

Please force an update on the Docker page, the container is now working again with ValheimPlus.

 

 

1 hour ago, kol_L said:

---Can't get latest version of Valheim Plus!---

This seems like you container can't connect to Github.

Anyways, also please try to force an update of the container on the Docker page.

Link to post
32 minutes ago, ich777 said:

Please force an update on the Docker page, the container is now working again with ValheimPlus.

 

 

This seems like you container can't connect to Github.

Anyways, also please try to force an update of the container on the Docker page.

I force updated it and it now seems to work ty 

Link to post
12 hours ago, ich777 said:

You've already posted on the Github of the creator of this Container or am I wrong?

Have you also made a post in the Factorium Forums?

 

This is a question for the creators Github and the main problem is that everything is working in the case you just want to run a simple Factorio server without mods or am I wrong?

 

But even if you create a bigger world it should not take that long I think...

 

Yes, that should be possible. to import the map, the main folders are the Saves folder and the User folder that is located in your 'appdata/7dtd' directory, just be sure to stop the Container before importing the map.

 

 

Posted on the github and on the factorio forums. Github maintainer said they don't provide support or assistance. Game loads as normal. But mods do not work. They used to work. At this point I'm not sure why they maintain it because they won't offer any support for issues.....

Link to post
10 minutes ago, jagr200 said:

Game loads as normal.

Then I guess it works fine...

 

11 minutes ago, jagr200 said:

But mods do not work.

Most developers give no support for mods because this is really difficulty to support...

 

13 minutes ago, jagr200 said:

They used to work.

Eventually they are outdated or not compatible with the game any longer... that is only a guess and I really can't help because I don't know anything about mods for Factorio.

Link to post

I have a question about backups for my Valheim image. 

Currently I'm using the defaults (interval = 62, backups to keep = 24).
For context, my container has been up for approx 3 days. 

I would expect 24 tar.gz files to be in my /Backups/ directory, however I only see 9.

 

Additionally, the modified dates on the containers range from 2-20 (19:19) to 2-21 (03:35).

I have my mover scheduled for 03:40 daily, so I would expect the latest tar.gz file to have a modified date of approx 3:00-ish this morning (2-23).

Am I missing something / misunderstanding how the backup feature works?


 

Link to post
2 minutes ago, codearoni said:

Am I missing something / misunderstanding how the backup feature works?

I will look into this and correct it if it doesn't work like it should, will report back, give me 1-2 days (currently I have no Valheim server running but in theory the backup function should work fine).

I will report back.

Link to post
On 2/9/2021 at 3:21 PM, luckyy said:

Just thought I'd share my experience setting up a Valheim server with this docker app from @ich777(thank you!)

 

You don't need to worry about Steam authentication for Valheim, the default anonymous user can download and host a server (yay!), so no fuss with Steam users or Steam Guard to worry about.

  1. Deploy the docker as provided, leaving username & password blank.
  2. The Server Name field is important, this is how your name will appear in the public server list in Valheim.  (as of this writing there are 7 "Valheim Docker" server names, good luck finding yours!    So choose something unique that you and your friends can find.
  3. World Name is the name of your world, this can be anything, if you wish to import a single-player or self-hosted save file in your docker, this name must be set to the same name/spelling as your save game world.
  4. Save the docker/let it install.
  5. You'll want to make sure your firewall or router has UDP ports 2456-2458 forwarded to your Unraid server's IP so the game can work as intended.

In 10-15 minutes typically you should see your server name in the public server list in Valheim, you're done!

 

 

* if you wish to import a previous save file, you need to make sure the Docker is Stopped first.   Then browse your local computer's profile, typically in "%appdata%\..\LocalLow\IronGate\Valheim\worlds" you will find your save games.

 

You'll want to take a copy of your world files, database, everything named the same as your world name over to your docker data files, by default with this docker settings should be:

\\<your unraid server IP or name>\appdata\valheim\.config\unity3d\IronGate\Valheim\worlds

 

Place your save game files in there, and overwrite any existing newly generated world of the same name with your save game.

 

Start the Docker, wait for it to appear in Valheim, join & play!

 

I hope this was helpful for someone, took a bit to figure out the exact steps to follow :)

 

 

 

Thanks for that.  Just got into this game a little while ago and was hoping there was a Docker for running it.  Now I just need some friends that own the game as well.

 

Quick question concerning the ports;  you need all of those ports listed to be forwarded?  The entire range of 2456-2458 or can you just pick ONE (eg: 2457) and forward it to the UnRaid docker?

Link to post
46 minutes ago, codearoni said:

Am I missing something

Please try to force an update of the container and try it again, now hopefully everything should work.

 

35 minutes ago, CoZ said:

Quick question concerning the ports;

Yes I think so, that's a question that you have to ask on the Valheim Discord/Forums/Steam Community Hub.

 

That's what the developers of the game recommend to use and I don't think it's enough to forward just one port since the 2457 is only the query port and 2456 is the game port, I think 2458 is also needed but for what it's for I can't tell.

Link to post
11 minutes ago, ich777 said:

That's what the developers of the game recommend to use and I don't think it's enough to forward just one port since the 2457 is only the query port and 2456 is the game port, I think 2458 is also needed but for what it's for I can't tell.

 

 

Yup, I tried just using 2457 but it wouldn't connect.  So all the ports need to be forwarded.  Thanks.

Link to post
16 minutes ago, ich777 said:

Please try to force an update of the container and try it again, now hopefully everything should work.


Thanks! Updated and will get back to you on how backups work over the coming day(s).

I just logged in though, and my save wiped on update (i.e. my world is gone). Is this a known issue?

Link to post
5 minutes ago, codearoni said:

I just logged in though, and my save wiped on update (i.e. my world is gone). Is this a known issue?

Yes this is a problem of the game itself and the developers have to fix it, this is why I added this backup function to the container.

Link to post
2 hours ago, ich777 said:

Then I guess it works fine...

 

Most developers give no support for mods because this is really difficulty to support...

 

Eventually they are outdated or not compatible with the game any longer... that is only a guess and I really can't help because I don't know anything about mods for Factorio.

 

It isn't support for mods. It is support for their basic docker that they have created and maintained. It just isn't accessing the mods folder. Why? I don't know. Literally nobody on earth knows. Nobody has tried to figure it out. I can put any mod I want into the local client files. And it just works. Because it is a simple system. But for some reason the docker image isn't pulling those mods from within the mod folder. It is overwritting the mod-settings.json file every time the server is shut down though.....

 

So is it working? To a point. But it isn't working correctly. Because for well over a year it worked. And with the full release of the game it is no longer working. And it is so incredibly frustrating that NOBODY cares.

 

The mod system for factorio is so incredibly simple. It is literally a zipped folder inside of a "mods" folder in the directory. That is it. It should then populate those mods and create a mods-settings.json that tells the client which mods are active and inactive. I can put the correct json in. Start the server and the mods aren't active. But the json is correct. Shut down the server and the json has been overwritten only showing the base game as active and nothing else listed. 

Edited by jagr200
Link to post

Any of you running the Valheim docker, are you able to get a response from the Steam Server Browser?  I've added my IP address in there and I just get a not responding even though I can manually connect to the game with no issue.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.