[Support] ich777 - Gameserver Dockers


Recommended Posts

6 minutes ago, dfox1787 said:

why is valheim killing my server? only just started to happen.

I don't know but it don't have to be Valheim, have you tried to connect to the Valheim Server?

 

Have you noticed that you also running out of RAM and this can cause the problem too? 13,2GB from 13,7GB are used (btw. the 10% for Valheim are just normal should be about 1.4 GB)

 

It's also eating up some resources and  on my system but I have 12 threads instead of your 4 threads.

grafik.png.94e5f4011bcb834514884623eac383fd.png

 

Link to comment
3 minutes ago, ich777 said:

I don't know but it don't have to be Valheim, have you tried to connect to the Valheim Server?

 

Have you noticed that you also running out of RAM and this can cause the problem too? 13,2GB from 13,7GB are used (btw. the 10% for Valheim are just normal should be about 1.4 GB)

 

It's also eating up some resources and  on my system but I have 12 threads instead of your 4 threads.

grafik.png.94e5f4011bcb834514884623eac383fd.png

 

no it wouldnt let me connect. good after a restart. whats the best way to troubleshoot whats using all my system resources next time it happens? did the same last night.  

Capture00.PNG

Link to comment
1 minute ago, dfox1787 said:

no it wouldnt let me connect. good after a restart. whats the best way to troubleshoot whats using all my system resources next time it happens? did the same last night.  

Eventually it's the backup that got stuck but can't really tell if this is the case...

 

From what I've see in the screenshot the Valheim server should not be the problem because it only consumes about 1,4GB of your system memory, eventually it got stuck because it had to less memory left...

 

Have you a VM spun up or something that reserves a lot of memory?

Link to comment
2 minutes ago, ich777 said:

Eventually it's the backup that got stuck but can't really tell if this is the case...

 

From what I've see in the screenshot the Valheim server should not be the problem because it only consumes about 1,4GB of your system memory, eventually it got stuck because it had to less memory left...

 

Have you a VM spun up or something that reserves a lot of memory?

literally just happened again. the htop cpu usage doesnt match the unraid dash. 

no vms running 

 

no idea whats going off atmCapture99.thumb.PNG.45dd536f6f400ddd1d87abbf41dd9ec5.PNG

Link to comment
12 minutes ago, dfox1787 said:

literally just happened again. the htop cpu usage doesnt match the unraid dash. 

no vms running 

Can you try to go to the Docker page and see how much RAM it consumes?

 

I've seen this in the past with thesting the 'amdgpu' drivers with my Jellyfin container that makes use of the iGPU from the APU for transcoding that the Unraid Dashboard doesn't always reflect the usage from htop.

 

This seems like a memory leak of some kind...

Can you try to shutdown the container and set up a fresh install of Valheim for testing purposes (just be sure to give it another Name, path to the Gamefiles and other ports - you don't have to set up the ports completely correctly since it's only for testing).

Link to comment
7 minutes ago, ich777 said:

Can you try to go to the Docker page and see how much RAM it consumes?

 

I've seen this in the past with thesting the 'amdgpu' drivers with my Jellyfin container that makes use of the iGPU from the APU for transcoding that the Unraid Dashboard doesn't always reflect the usage from htop.

 

This seems like a memory leak of some kind...

Can you try to shutdown the container and set up a fresh install of Valheim for testing purposes (just be sure to give it another Name, path to the Gamefiles and other ports - you don't have to set up the ports completely correctly since it's only for testing).

yeah can do, 

 

atm 100% cpu with valheim running. If i turn off plex for example leave valheim off my cpu is still 100%. stopping the valheim container cpu drops. 

 

Captur33e.PNG

Link to comment
5 minutes ago, dfox1787 said:

atm 100% cpu with valheim running.

Can also be that this is a memory leak but not 100% sure.

 

Please report back what the "test" Valheim container does if it has the same issue.

Have you got a older Backup of the world? Eventually something with the world is wrong.

 

You can also try to reboot the entire Unraid server.

Link to comment
56 minutes ago, ich777 said:

Can also be that this is a memory leak but not 100% sure.

 

Please report back what the "test" Valheim container does if it has the same issue.

Have you got a older Backup of the world? Eventually something with the world is wrong.

 

You can also try to reboot the entire Unraid server.

first thing i tried was a reboot. 

 

same issue with a test server image.thumb.png.645f59e2e40aec74237b28d176683e10.png

Edited by dfox1787
Link to comment
2 minutes ago, dfox1787 said:

same issue with a test server

This is really strange, can you post your Diagnostics please (Tools -> Diagnostics -> Download -> drop the downloaded file here in the textbox)?

 

Eventually try to force an update of the container...

I really can't imagine why it's doing that, have you changed anything to your server recently (installed a container or something similar)?

Link to comment
1 minute ago, ich777 said:

This is really strange, can you post your Diagnostics please (Tools -> Diagnostics -> Download -> drop the downloaded file here in the textbox)?

 

Eventually try to force an update of the container...

I really can't imagine why it's doing that, have you changed anything to your server recently (installed a container or something similar)?

the only thing i have is update some containers that needed updates. 

media-diagnostics-20210322-1037.zip

Link to comment
1 minute ago, dfox1787 said:

 

How long do you run the Container now on you server?

Have you enabled anything special? Valheim+ or something like that?

 

I think your appdata directory is set to Use Cache "Only" or "Prefer" in the Shares section?

Link to comment
1 minute ago, ich777 said:

How long do you run the Container now on you server?

Have you enabled anything special? Valheim+ or something like that?

 

I think your appdata directory is set to Use Cache "Only" or "Prefer" in the Shares section?

ran the container for about 10 mins. in general i have been using it for weeks. 

appdata prefer image.thumb.png.16ad9d4404152b5b6bee7f6814e8f039.png

Link to comment
1 minute ago, dfox1787 said:

appdata prefer 

I think the container path is also there... Sorry forgot to ask about that... :/

 

1 minute ago, dfox1787 said:

ran the container for about 10 mins. in general i have been using it for weeks. 

Can you try to shutdown all containers and your VM's and only start the container and see if this happens again?

Link to comment
21 minutes ago, ich777 said:

I think the container path is also there... Sorry forgot to ask about that... :/

 

Can you try to shutdown all containers and your VM's and only start the container and see if this happens again?

ill give it a go. its very difficult because my server isnt responding. i dont have any vms running. 

 

what is loop2? image.png.01040e0bb682e38d89078a0f6fed5597.png

Link to comment

Kind of an "off topic" question since it's not really UnRaid specific.   Concerning the Valheim docker, is there some sort of Windows Program or something that can hook into the server to manage it?  I know you can do admin commands from in game but is there some sort of 3rd party server admin control panel type of thing out there?

Link to comment
7 hours ago, ich777 said:

I'm not completely sure how that works for that "mod" but it should be possible in the container, but as said, haven't got much time these days... :P

I already tried myself, I just don't know how to do it. I event tried the mod Discord server, but it turned into a debate on why I was running it in a docker. So I didn't get far with that.

 

 

3 hours ago, dfox1787 said:

why is valheim killing my server? only just started to happen.

Are you validating the installation on that picture? - Because I'm getting high CPU load when mine does, but afterwards it's running just fine. And your CPU shouldn't be that much worse than mine.

  • Like 1
Link to comment
2 minutes ago, CoZ said:

Kind of an "off topic" question since it's not really UnRaid specific.   Concerning the Valheim docker, is there some sort of Windows Program or something that can hook into the server to manage it?  I know you can do admin commands from in game but is there some sort of 3rd party server admin control panel type of thing out there?

Not yet. I can't remember if it's on their roadmap. There might be a 3rd part tool or something, but I haven't seen one.

  • Like 1
Link to comment
11 minutes ago, CoZ said:

Concerning the Valheim docker, is there some sort of Windows Program or something that can hook into the server to manage it? 

What do you want to do exactly?

 

11 minutes ago, Nanobug said:

I event tried the mod Discord server, but it turned into a debate on why I was running it in a docker.

Omg, that's not good... :D

Ask the question: "Why not... Is saving system resources bad by sharing resources across multiple containers and not waste it like in VM's?" :D

And this is a completely waste if you only set up a VM for this game server in my opinion...

Link to comment
59 minutes ago, Nanobug said:

I already tried myself, I just don't know how to do it. I event tried the mod Discord server, but it turned into a debate on why I was running it in a docker. So I didn't get far with that.

 

 

Are you validating the installation on that picture? - Because I'm getting high CPU load when mine does, but afterwards it's running just fine. And your CPU shouldn't be that much worse than mine.

it wasnt just high cpu it was to the point where nothing worked on my server. im not doing any validation to my knowledge. 

Link to comment
1 hour ago, dfox1787 said:

***update*** ive deleted my docker image and recreated it on a new drive and touch wood so far everything is running ok

You can also set a path/directory instead of a docker.img, in my opinion the better choice... :)

 

Thank you than something messed up your docker.img I think...

Link to comment
2 hours ago, ich777 said:

Omg, that's not good... :D

Ask the question: "Why not... Is saving system resources bad by sharing resources across multiple containers and not waste it like in VM's?" :D

And this is a completely waste if you only set up a VM for this game server in my opinion...

They don't even install it in a VM. They just install the OS, and then the game servers they want on it.
The reason they gave, was performance. You lose performance in a docker or in a VM. According to them.
 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.