[Support] ich777 - Gameserver Dockers


4192 posts in this topic Last Reply

Recommended Posts

21 hours ago, Symon said:

Whats the best way to config settings for the GameUserSettings.ini in Ark?

I've tried to put it into the ini file in \ark-se\ShooterGame\Saved\Config\LinuxServer but unfortunately, every time the game start it gets overwritten. For now I added the settings into the Game Parameters of the docker but I've read somewhere that not all the settings work this way.

 

Another question is how to change the Game.ini in the \ark-se\ShooterGame\Saved\Config\LinuxServer  path but I'm not sure if that's the right way to do it :)

 

I also figured out that you can overwrite the default config files in \ark-se\ShooterGame\Config and it works but I guess that is not the way it was meant to be :D

 

Thanks for your help!

 

 

you should be editing /serverdata/serverfiles/ShooterGame/Saved/Config/LinuxServer/GameUserSettings.ini but

the ShooterGame server does not respect the file permission mask when it writes to the gonfig files. 

So the safest method I have found is to stop the server container then edit /mnt/cache/appdata/ark-se/ShooterGame/Saved/Config/LinuxServer/GameUserSettings.ini from the unraid console, then restart the server container.

Link to post
  • Replies 4.2k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Summary: Support Thread for ich777 Gameserver Dockers (CounterStrike: Source & ConterStrike: GO, TeamFortress 2, ArmA III,... - complete list in the second post) Application: SteamCMD Do

Just thought I'd share my experience setting up a Valheim server with this docker app from @ich777(thank you!)   You don't need to worry about Steam authentication for Valheim, the default a

Dockers Available so far:   SteamCMD DedicatedServers: CounterStrike: Source CounterStrike: Global Offensive TeamFortress 2 ArmA3 - requested by @MrSage D

Posted Images

Thank you @ich777 for your work on docker servers so far. If you're feeling up to the task, there is a game called Space Engineers that's been out for quite a few years now. As it stands, it is a Windows-only game with its own Windows-only server software that runs through steamCMD. Many have tried, and as of this post, I believe there are a couple of working dockers out there for the base SE server.

However, SE is a game like Minecraft; there exists a custom style of server called Torch, which has been challenged by many in getting a working Docker container up and running. Running a non-Torch SE server is like running Skyrim or Minecraft without mods (even OptiFine). Torch has a plugins system with numerous quality of life and functionality-improving features.

There have been a few functional Torch-based dockers in the past, and about a year ago I tried all of them to no success - they had all broken with time.

 

If you could get a linux or unraid-friendly docker for SE working, especially a Torch server, I know it would be greatly appreciated by a community of players. Both SE and the Torch guys have their own Discord servers with linux-specific sections that probably have lots of people eager to help.

Edited by Porkey
Link to post
39 minutes ago, Porkey said:

Many have tried, and as of this post, I believe there are a couple of working dockers out there for the base SE server.

Actually not.

 

I own the game and sometimes the server runs and sometimes not, I can't release such an unstable container...

This game was requested a few times here but I really can't do much about it.

 

39 minutes ago, Porkey said:

There have been a few functional Torch-based dockers in the past, and about a year ago I tried all of them to no success - they had all broken with time.

This is actually the same with the Dockers out there, they where working fine before they broke everything, now not one container is working anymore and they are all depricated because SE uses that much Windows libraries that is not that easy to run it through WINE.

 

As said, from what I know there is not only one Docker container out there that runs on Linux.

Link to post
On 3/31/2021 at 5:10 PM, Jaxs said:

OK..... problem solved i believe. So i got a message from my ISP last week that they were doing maintenance to the entire township and i was included in that. What i didnt know is that my IP address changed 😆.  Steam seems to be able to see it both ways now. I will have a friend try to connect and see what happens

To prevent this in the future you can use a dynamic DNS server to sort of work around changing IPs without paying for a static IP. Spaceinvader One has a good video on how to setup one using Duck DNS here ->

 

Link to post
8 minutes ago, OdinEidolon said:

Thank you!

Have you got a tutorial for me how to set this up since I got the container up and running but ran into some problems or at least point me in the right direction?

Link to post
14 minutes ago, ich777 said:

Have you got a tutorial for me how to set this up since I got the container up and running but ran into some problems or at least point me in the right direction?

I personally have not tested yet...

 

Here is a script to deploy the client and the server:

https://github.com/GrimKriegor/TES3MP-deploy

 

Here is a guide, it says it should be rather simple, but does not mention Linux:

https://steamcommunity.com/groups/mwmulti/discussions/1/133258593388999187/

 

Here an older guide, but specific to Linux:

https://steamcommunity.com/groups/mwmulti/discussions/1/133258092238983950/

 

Hope it helps a little bit. Once again, thank you very much.

Link to post
5 hours ago, OdinEidolon said:

I personally have not tested yet...

The server runs basically but I have some problems connecting to the server through the Server Browser and I've created a issue for that on Github: Click

 

I can connect just fine if I edit the file manually but that's not how I want it... :D

Link to post
1 hour ago, killerbad21 said:

Love All the Support You Are Doing Any way We can do the Xbox Server Version for Ark at all? few of my friends own the xbox copy and love to make a server for them.

I think that is not possible because if you want to use that kind of Crossplay you have to use the Windows 10 version (Microsoft Store) of ARK and not the Steam version.

 

The only Crossplay that the Steam version is capable of, as far as I know, is Crossplay between Epic Client's and Steam Clients.

 

I've done only a quick search about this but I don't think that anything has changed here: Click

Link to post
16 hours ago, ich777 said:

The server runs basically but I have some problems connecting to the server through the Server Browser and I've created a issue for that on Github: Click

 

I can connect just fine if I edit the file manually but that's not how I want it... :D

Was it just a matter of opening more ports?

Link to post
1 hour ago, ich777 said:

I think that is not possible because if you want to use that kind of Crossplay you have to use the Windows 10 version (Microsoft Store) of ARK and not the Steam version.

 

The only Crossplay that the Steam version is capable of, as far as I know, is Crossplay between Epic Client's and Steam Clients.

 

I've done only a quick search about this but I don't think that anything has changed here: Click

well i have the Microsoft Store Copy also was just was wondering if had to download the Microsoft Copy sum how or something. We all Have the Microsoft Version just cant use the Steam Copy You have now with it.

Edited by killerbad21
Link to post
1 hour ago, OdinEidolon said:

Was it just a matter of opening more ports?

It's the matter of opening the right ports with the right protocol and not the wrong ones.

All ports you have to open are in the template, one TCP and one UDP.

 

35 minutes ago, killerbad21 said:

well i have the Microsoft Store Copy also was just was wondering if had to download the Microsoft Copy sum how or something.

Have you read the post that I've linked?

You have to run the Server on a Windows 10 machine because well, it's the Windows version that you only can download throught the Microsoft store and you also need a graphics crad in this machine that meets the minimum requirements for Ark.

Please read the whole linked thread.

 

I can't make a version for the Windows Store version because it's only available on Windows and through the Microsoft Store.

Link to post

Question. Installing Rust docker. It starts and runs. But won't show in their server browser. I believe I forwarded the ports as other dockers such as factorio work. But can't figure this one out. Any ideas?

Capture.PNG

Link to post
1 hour ago, jagr200 said:

Question. Installing Rust docker. It starts and runs. But won't show in their server browser. I believe I forwarded the ports as other dockers such as factorio work. But can't figure this one out. Any ideas?

Capture.PNG

I don't think you need that much ports for Rust or am I wrong, when I created the template only one port (28015 UDP) was enough.

Also please keep in mind that some games don't like it when you open TCP & UDP if they only need one of the two protocols...

 

Have you tried to connect directly through the in game console or the Steam Server Browser?

Link to post
2 hours ago, ich777 said:

I don't think you need that much ports for Rust or am I wrong, when I created the template only one port (28015 UDP) was enough.

Also please keep in mind that some games don't like it when you open TCP & UDP if they only need one of the two protocols...

 

Have you tried to connect directly through the in game console or the Steam Server Browser?

 

So I tried to connect on the LAN via steam server browser and it doesnt show up. So Im not sure what is happening.

Link to post
4 minutes ago, jagr200 said:

 

So I tried to connect on the LAN via steam server browser and it doesnt show up. So Im not sure what is happening.

Have you also tried this: Click

Through the in game console?

Link to post
Just now, jagr200 said:

 

Just tried. No go. Tries to connect twice and fails.

What does the log say?

I will look into this tomorrow, it's getting pretty late here and I also have to install the game.

Link to post
2 minutes ago, ich777 said:

What does the log say?

I will look into this tomorrow, it's getting pretty late here and I also have to install the game.

 

No worries.

 

Nothing abnormal from what I can see. 

 

Spawning 50814 entities
33432 / 50814
done.
Enforcing SpawnPopulation Limits
done.
Initializing 55837 entity links
done.
Initializing 752 stability supports
done.
Initializing 50858 entity save caches
done.
Gamemode Convar :
No Gamemode.
[S_API] SteamAPI_Init(): Loaded local 'steamclient.so' OK.
CAppInfoCacheReadFromDiskThread took 2 milliseconds to initialize
CApplicationManagerPopulateThread took 0 milliseconds to initialize (will have waited on CAppInfoCacheReadFromDiskThread)
RecordSteamInterfaceCreation (PID 105): SteamGameServer013 /
RecordSteamInterfaceCreation (PID 105): SteamUtils010 /
Setting breakpad minidump AppID = 252490
RecordSteamInterfaceCreation (PID 105): SteamGameServer013 /
RecordSteamInterfaceCreation (PID 105): SteamUtils010 /
RecordSteamInterfaceCreation (PID 105): SteamNetworking006 /
RecordSteamInterfaceCreation (PID 105): SteamGameServerStats001 /
RecordSteamInterfaceCreation (PID 105): STEAMINVENTORY_INTERFACE_V003 /
RecordSteamInterfaceCreation (PID 105): STEAMUGC_INTERFACE_VERSION015 /
Missing interface adapter for STEAMUGC_INTERFACE_VERSION015
RecordSteamInterfaceCreation (PID 105): STEAMAPPS_INTERFACE_VERSION008 /
[S_API FAIL] Tried to access Steam interface SteamNetworkingUtils003 before SteamAPI_Init succeeded.
RecordSteamInterfaceCreation (PID 105): SteamNetworkingUtils003 /
RecordSteamInterfaceCreation (PID 105): SteamNetworkingSockets009 /
Warning: failed to init SDL thread priority manager: SDL not found
SteamServer Initialized
IP address from external API: IDELETEDTHISIP
Server startup complete
SteamServer Connected
BradleyAPC Spawned at :(751.9, 36.2, 1076.3)
Checking for new Steam Item Definitions..

Edited by jagr200
Link to post

New update. So going in the Steam Server browser I could find it. I can also add it as a favorite and then go into Rust and find it in my favorite servers and connect that way. The second I delete it from my favorites I can not find it again except for in my History.

 

So it doesn't look to be out on the open server list. Which is what I would like. I would also like to figure out how to add the RCON to be able to see server stats etc.

 

I would also love to get this working with the Rust+ Companion Application.

 

I appreciate your help.

Edited by jagr200
Link to post

If you are connecting via internet ip than it is likely the port forward setting in your router being set to “both” rather than “udp”. If you are connecting using your lan ip it is likely that your routers port forwards are not set at all.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.