[Support] ich777 - Gameserver Dockers


4015 posts in this topic Last Reply

Recommended Posts

  • Replies 4k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Summary: Support Thread for ich777 Gameserver Dockers (CounterStrike: Source & ConterStrike: GO, TeamFortress 2, ArmA III,... - complete list in the second post) Application: SteamCMD Do

Just thought I'd share my experience setting up a Valheim server with this docker app from @ich777(thank you!)   You don't need to worry about Steam authentication for Valheim, the default a

Dockers Available so far:   SteamCMD DedicatedServers: CounterStrike: Source CounterStrike: Global Offensive TeamFortress 2 ArmA3 - requested by @MrSage D

Posted Images

3 hours ago, John2222 said:

If yes, how?

Only from the container console.

 

I usually don't support mods because this can be a real big pain to support and I also don't know nothing about ARMA3 mods.

 

I thought you just add them and implement it to your start parameters and everything is working...

 

3 hours ago, John2222 said:

If not, can you implement Mod Support?

Already answered above, only manually had so many troubles in some containers with mods and it's really not worth the headaches from my perspective...

Link to post
2 hours ago, ich777 said:

Only from the container console.

 

I usually don't support mods because this can be a real big pain to support and I also don't know nothing about ARMA3 mods.

 

I thought you just add them and implement it to your start parameters and everything is working...

 

Already answered above, only manually had so many troubles in some containers with mods and it's really not worth the headaches from my perspective...

Mh. Very sad. Because Arma 3 is not really a game. It is a sandbox and nobody plays Arma after a few hours in vanilla. You can find more than 60 thousand mods in the workshop. So it is a mess, if you would manage this manually. Only to be up to date manually is pain.

Link to post
7 hours ago, John2222 said:

Only to be up to date manually is pain.

You can always write a custom "user.sh" script and mount it to '/opt/scripts/user.sh' inside the container to install all your mods, the user.sh is executed always as root and executed before SteamCMD starts, so it should be theoretically possible to install it like this (keep in mind that the game needs to be first fully installed):

#!/bin/bash
su $USER
${STEAMCMD_DIR}/steamcmd +login ${USERNAME} ${PASSWRD} +@nCSClientRateLimitKbps 50000 +force_install_dir ${SERVER_DIR} +app_update ${GAME_ID} +workshop_download_item YOURWORKSHOPID'S_HERE validate +quit

(Please change the "YOURWORKSHOPID'S_HERE" to your Workshop ID's, that should do the job and check on every start/restart of the container if there is a newer version available)

 

Place the script somewhere on your Unraid server (please note you have to write this script in Notepad and not in Wordpad because it will mess up the format an Linux can't read the file) and mount it like this (in this example I have placed the script in '/mnt/user/scripts/arma3.sh', as long as you name it in your container 'user.sh' everything will be fine) :

grafik.thumb.png.dca3c4959c5a7a0824a55ab7cabbc6a0.png

 

Hope that helps.

Link to post

@ich777  Looks like Emperor Server just released a Server Manager for ACC.  Would you be creating a container for it?  Anyway I can donate for development?  The web interface looks similar to ACSM.

Link to post
41 minutes ago, mikeyvt said:

@ich777  Looks like Emperor Server just released a Server Manager for ACC.  Would you be creating a container for it?  Anyway I can donate for development?  The web interface looks similar to ACSM.

Please give me a few days and I will look into this?

Is there a Github link or something where I can download it?

Link to post

hey,

 

is there any way to add oxide to your rust template?

i mean like you did it in Valheim. If theres an update on rust (what happens quite often latley) Oxide(Umod) everytime gets overritten and you have to manually download and install it again. its pretty tricky if your at work and your friends want to play and you cant to anything.

 

basicly the same you did with Valheim Plus. download the newest version from

https://umod.org/games/rust

and extract it to the gamefolder

 

greets

Link to post

trying to get Arma3 server up, i left the template config stock w/ the exception of steam login and password. i change the server name in the server.cfg file but i still cant connect to it even if i do a direct connection. all i get is a ARMA3 splash screen. Has any one else had this problem and figured it out?

Link to post
7 hours ago, Cornflake said:

is there any way to add oxide to your rust template?

I will look into this ASAP.

 

EDIT: May I ask if you have the variable VALIDATE set to 'true'? This shouldn't happen that Oxide is getting wiped, only if you set VALIDATE to 'true'.

Keep in mind if there is an update you don't have to set VALIDATE to 'true' to apply the update.

 

Also can you eventually give me the link to a tutorial/guide what needs to be changed to run RUST with Oxide?

 

1 hour ago, dollabillz said:

trying to get Arma3 server up, i left the template config stock w/ the exception of steam login and password. i change the server name in the server.cfg file but i still cant connect to it even if i do a direct connection. all i get is a ARMA3 splash screen. Has any one else had this problem and figured it out?

Can you please post some logs if the container is even fully started and waiting for connections?

How did you try to connect?

Link to post
Posted (edited)

No it’s normal, Oxide Needs to overide the Original gamefiles to work. Everything Else like the Plugins you install stays. If Theres an Update These files will be set Original again

 

and no validation is not set to True. 


 

tutorial:

https://clients.mcprohosting.com/knowledgebase/279/How-to-Manually-Install-Oxide-to-your-Rust-Server.html
 

this guy also mention that if you Update the Game you have to reinstall Oxide.

 

this Tutorial is for their Website but you will get it, Its just extracting the zip into your gamefolder and Override the existing files. You start the Game as normal Expect that you can install mods/Plugins 

Edited by Cornflake
Link to post
12 hours ago, Cornflake said:

No it’s normal, Oxide Needs to overide the Original gamefiles to work. Everything Else like the Plugins you install stays. If Theres an Update These files will be set Original again

Done.

 

Please force an update from the container and create a variable like this in the template:

grafik.png.c120d8287f7cb126cb90cc00f4d21a1d.png

 

12 hours ago, Cornflake said:

this guy also mention that if you Update the Game you have to reinstall Oxide.

Currently I'm don't checking if there was an update, but I'm installing the Oxide Mod every time the container is started/restarted so this should be no problem and since the Oxide Mode is not that big and doesn't contain much files there should be no problem.

You can prevent this by creating a variable with the Key: 'FORCE_OXIDE_INSTALLATION' and as Value: 'false' but I don't think this is necessary in your use case.

 

Hope this is what you where after. :)

 

Link to post
8 hours ago, Cornflake said:

i guess i can ignore this file not found message because the installation was successfully anyway ?

Thank you for the heads up, please update the container one more time and the container should now update and find the versions correctly. ;)

Actually had a bug in my container... :D

Link to post
4 minutes ago, Syco54645 said:

So I am using this for  7 days to die and am trying to disable automatic updates to the server. i see mention of doing it but not instructions. can someone please help me out?

Please join @Spectral Force's Discord for support on 7DtD: https://discord.gg/VwwYA5h

 

He is the specialist for this game but I think if you add something like: '-beta stable_u52' (without quotes) to the GAME_ID it should work, of course you have to set the version you want to stay on:

grafik.thumb.png.606a853a1c3666ad32a049a19cd6c1af.png

Link to post
On 3/2/2021 at 5:02 PM, ich777 said:

Yes, but you do this with the Variable in the 'Show More Settings' section of the Template.

 

Keep in mind that for every container the Game Port itself has to be set in the GAME_PORT variable like mentioned above.

 

 

This is the way you would do it (this is tested and working btw):

grafik.thumb.png.a3e4e22653cc2a5543daed533a251f69.png

 

 

I know you're busy answering all sorts of questions and I've honestly stared at this for a good 10 minutes and still just dont' get it. 

 

I was going to backup my 'worlds' since my original friends have lost interest in the game and start fresh and then restore the world at a later point once more content drops.  Then I thought why do that when I can just create another world/container so decided to come here and check before I tried to do something stupid. 

 

Someone already asked the question how to run two instances of a dedicated Valheim server and you referenced this post.  I'm looking at your graphic which probably an idiot would understand but I guess I'm lower than idiot status because I don't understand what I'm supposed to do here to create a "new world" or "new server"......

 

Help?  (and sorry for not understanding this)

 

 

Link to post
6 hours ago, CoZ said:

restore the world at a later point once more content drops

It is very likely to happen that an old work eventually won't work on a newer version of the game if some versions are skipped...

(They also said that no world wipe will need to happen, but you know in a game that is in that early stat of alpha everything can happen... :D )

 

6 hours ago, CoZ said:

Then I thought why do that when I can just create another world/container so decided to come here and check before I tried to do something stupid.

This would also be a possibility, redownload the Container from the CA App and be sure to do this:

  1. Give the Container a new name first (otherwise the old one gets overwritten), something like: Valheim2 or Valheim_the_super_cool_new_world
  2. Change the path also to something else like: valheim2 or valheim_the_super_cool_new_world
  3. Delete the existing entry: "UDP - Game Port Range"
  4. Go down to "Show more..." click on it and change the "GAME_PORT" variable to lets say: 2466
  5. Click on "Add another, Port, Path, Variable,..." change the drop down in the appeared popup to "Port" and enter: "2466-2468" for the Host and Container port and click "Add"
  6. Click on "Apply"
  7. Done

Now you can connect to the server with port 2466 (in Game) or 2467 (Steam Server Browser).

 

Hope that helps and makes sense to you. :)

Link to post

Are we able to add to the arguments for SteamCMD?

 

For example, on windows this is usually the default you use to start an ark server:
steamcmd.exe +login anonymous +app_update 346110 validate +quit

But i'd like to also tell it to do this:

+workshop_download_item 346110 496735411

 

Obviously the docker doesn't use WIndows, this is just an example.

 

Your work is amazing by the way!

Link to post
46 minutes ago, Dendo said:

Are we able to add to the arguments for SteamCMD?

Yes and no, but I think you can't download the game and also workshop content in one line or am I wrong?

 

Please look at the first recommended post from @Cyd here: Click

 

I really don't support installing mods but if you only would install this single mod and it is possible to do this one line that it looks like this: "steamcmd +login anonymous +app_update 346110 +workshop_download_item 346110 496735411 validate +quit" (but I don't think that's possible then simply add it to the GAME_ID:

grafik.png.767e90197d4a9efca5913f593d7b219b.png

 

 

If a one liner like this isn't possible you can also create a ark.sh somewhere on Unraid and put this content in it:

#!/bin/bash
su $USER
${STEAMCMD_DIR}/steamcmd.sh \
  +login anonymous \
  +force_install_dir ${SERVER_DIR} \
  +workshop_download_item 346110 496735411 \
  +quit
exit

 

After you created that file on Unraid go to the template and mount it in the container like (in this example it is located in /mnt/user/appdata/scripts/ark.sh):

grafik.png.3ace51a7c288d8a428f048d42d289ee8.png

 

 

This script will then be executed before the update check of Ark itself is running but it should be also work even when the game is downloaded after the workshop content is downloaded.

 

Hope that helps, but I think the solution from @Cyd is more elegant.

Link to post
Posted (edited)

@Dendo & @ich777 

 

ARK does some post processing of mod, why you ask? <shrug> I do not know.... They built in a function to the server that uses SteamCMD (in a hard coded location of course) to fetch the files and then it does its thing putting them in another location. If all you want to do is add a mod or two to a single server you add mappings so that your SteamCMD shows up in the place that the server binary is expecting it, and  command line arguments to tell the server binary what mods you want installed.

 

In fact there are no modifications to Ich777's arkse container. All you need to do to update the setting then restart it, it will auto update everything.

 

In your edit the container settings and add the paths:(assuming you are using the default paths everywhere else of course)

/serverdata/Steam/steamapps <> /mnt/cache/appdata/steamcmd/steamapps
/serverdata/serverfiles/Engine/Binaries/ThirdParty/SteamCMD/Linux/steamapps <> /mnt/cache/appdata/steamcmd/steamapps
/serverdata/serverfiles/Engine/Binaries/ThirdParty/SteamCMD/Linux <> /mnt/user/appdata/steamcmd

 

 

then in the two Parameters add these flags (

Game Parameters:  ?GameModIds=ModID1,ModID2,ECT...
Extra Game Parameters: -automanagedmods

 

If you want the whole system to check for updates or manage a cluster then I found the best course is to run a separate container that monitors the SteamAPI & arkdedicated.com version numbers then compares that to the local files, if there is a change then it shuts down the ARKs restarts the primary (the first one in the cluster and the one that manages the mods) then restarts the remaining ARKs.

 

Edited by Cyd
Link to post
Posted (edited)

Hey Ich777,

Sorry for posting so often,

 

i am using your Conan Exiles server for a week now,

i installed a few mods and i get out of memory issuses sometimes. do you have any clue what to do? i know the server is running in an emulated windows enviroment. but i dont know what to do. i have 64GB ram and the container is not using all of it. i have to manually restart the server if this happens 

1276472121_conanoutofmemory.JPG.3d77b500115dc84a864698cceefbf519.JPG

 

Edited by Cornflake
Link to post
10 minutes ago, Cornflake said:

Hey Ich777,

Sorry for posting so often,

 

i am using your Conan Exiles server for a week now,

i installed a few mods and i get out of memory issuses sometimes. do you have any clue what to do? i know the server is running in an emulated windows enviroment. but i dont know what to do. i have 64GB ram and the container is not using all of it. i have to manually restart the server if this happens 

1276472121_conanoutofmemory.JPG.3d77b500115dc84a864698cceefbf519.JPG

 

Does it work without the mods?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.