[Support] ich777 - Gameserver Dockers


Recommended Posts

3 hours ago, Simmer said:

Just following up on this :)

I will try it again tomorrow, but like I've said everything seems to work on my end, will post a few screenshots tomorrow too.

 

1 hour ago, Fith said:

EDIT: FOUND IT!

Glad that you've figured it out. :)

Link to comment

@MarioRPGGeno @Kurtchen@Choohoo @Gragorg @Baythar @henkim21  @cwdean

You all have a running Forge Minecraft server. Maybe you can help me. My son asks for a "Minecraft Sky" server. If my research is correct this Client Mod needs the modded Minecraft Server of the Forge Project. So I downloaded "forge-1.17.1-37.0.26-installer.jar".

 

Then I tried two different ways, but both do not work:

 

A) Install Vanilla first:

After installing the MinecraftBasicServer and checking that it runs properly, I copied the "forge-1.17.1-37.0.26-installer.jar" into the server's folder:

image.png.888bfab73f4e05ad1ca9b5ee11b7af00.png

 

In the next step I changed the docker settings accordingly and restarted:

image.thumb.png.d3d2a7d1a363d8a4185745bd2b6186c3.png

 

But by that it reboots forever:

image.png.50e96a02f97500720e6ad1affdb13702.png

 

 

B) Install directly with forge.jar

As the first way wasn't successful I deleted the container and all files again and started the container directly with the changed serverfile name:

image.thumb.png.d3d2a7d1a363d8a4185745bd2b6186c3.png

 

Except of the missing Eula it has the same problem:

image.png.90e63e53ae9259c4a40c6fcceb18c37f.png

 

Any hints?

 

 

Link to comment
24 minutes ago, mgutt said:

But by that it reboots forever

From what I see in the logs it seems to me that something is wrong with the Java version or better speaking it's the wrong version for this Forge version.

Btw, I hate Forge, it runs for a few days/hours and randomly it stops for no reason and won't start up again... :/

 

You can try to change the Java version to something like jre8 "basicjre" in the Advanced Settings in the template:

grafik.thumb.png.ed753afdffa9b46ae32151420ccddef1.png

 

Steps to perform when changing the Java version:

  1. Stop the container
  2. Delete the "runtime" folder from the Minecraft directory
  3. Change the Java version and start the container again

 

EDIT: Or eventually try "jre11", Java 16 is needed for the vanilla Minecraft servers.

  • Thanks 1
Link to comment

I've tried googling around for awhile but I've come up with nothing so far. I have a few of ich777 game servers running with no issue whatsoever but when trying to host an ARK SE server using ich777's template I keep getting an error stating that SteamAPI_IsSteamRunning() failed. I saw mention of deleting a PID file but I can't even find that haha. Tried using different port, that didn't work. Tried a few other things including completely deleting the container and associated files to ARK and I'm still having a tough time. Occasionally the server will pop up on LAN in the Steam Server Browser but it will not let me connect stating that there was an issue connecting to steam for invite query. I do have all required ports forwarded as well. Am I supposed to use the cluster method for a single server?

 

Link to comment
11 minutes ago, drkpu1se said:

SteamAPI_IsSteamRunning()

This is not an error, this is just a normal Warnung and can be safely ignored.

 

12 minutes ago, drkpu1se said:

Am I supposed to use the cluster method for a single server?

No, simply install the default container template.

 

12 minutes ago, drkpu1se said:

Tried using different port, that didn't work. Tried a few other things including completely deleting the container and associated files to ARK and I'm still having a tough time.

I think the best would be to start over again and redownload it from the CA App.

What does the log look like when the container is fully started?

Link to comment
18 hours ago, ich777 said:

Or eventually try "jre11", Java 16 is needed for the vanilla Minecraft servers.

jre11 and jre15 did not work. jre11:

image.png.9534366af8eff0e64ccc5561b010785a.png

 

I did a little bit research and 1.16 needs jre8:

https://forums.minecraftforge.net/topic/101889-can-you-make-a-forge-server-with-java-16/

 

So I tried "basicjre", but still not working:

image.png.90369e6266693c8e867b55ae3f21aeab.png

 

As they were talking about 1.16, I downloaded forge-1.16.5-36.2.0-installer.jar and tried it with "basicjre", but still not working:

image.png.a64463f43abc9401518cfce3c6a2eb04.png

 

As I'm still not sure if I need to install Minecraft Vanilla first, I downloaded and installed 1.16.5 vanilla with "basicjre", which works flawlessly, then I stopped it and changed the server name to "forge-1.16.5-36.2.0-installer", but still no success:

2113099384_2021-08-0713_53_28.png.c91e12684c2b6de5a122664c35499fa9.png

 

🤷‍♂️

Link to comment
14 hours ago, ich777 said:

This is not an error, this is just a normal Warnung and can be safely ignored.

 

No, simply install the default container template.

 

I think the best would be to start over again and redownload it from the CA App.

What does the log look like when the container is fully started?

So as it turns out - I get errors if I try to join from the Steam Server Browser but if I join from within the game there isn't any issues. My apologies for wasting time. Keep up the good work!

  • Like 1
Link to comment

I'm at a loss - I can't figure out how to make myself an admin on the RUST server.

 

There is no user.cfg or server.cfg in the RUST folders. I have Oxide running, but I am not able to issue any commands because it says I am not an admin...

 

I put my Steam ID in the OXIDE config file, but that didn't seem to have an effect.

 

Is there a way I can use the RUST server command line in this docker? I think I could do it that way maybe? 

 

IF anybody else has the RUST server running, are recognized as an admin, and you can use Oxide, could you share your config so I can check it out? Thanks!

Link to comment

Hey guys,

Apologies if this has been asked at some point already however im abit stuck i would like to enable the most recent beta build for avorion but cant find the syntax i assume i need, adding -beta to the Game_params didnt work and gives the following error,

 

Quote

Connecting anonymously to Steam Public...OK
Waiting for client config...OK
Waiting for user info...OK
Success! App '565060' already up to date.
---Prepare Server---
---Server ready---
---Start Server---
An exception occurred: N5boost16exception_detail10clone_implINS0_19error_info_injectorINS_15program_options14unknown_optionEEEEE: unrecognised option '-beta'

 

if anybody knows what command i should be usingf that would be super helpful or even where i should go to find out

Cheers

Link to comment
26 minutes ago, ich777 said:

You have to add it to the GAME_ID and not to the GAME_PARAMS.

You are the Best, knew I was doing something silly!

incase anybody else is struggling i put "565060 -beta beta" onto the Avorion GAME_ID and its now working as expected and loaded up Beta 2.0

 

Cheers

  • Like 1
Link to comment
On 8/6/2021 at 8:29 PM, mgutt said:

forge-1.17.1-37.0.26-installer.jar

Now I get it... :)

 

This is just the installer, but I've tried it now in many different ways and don't get it to work.

 

From my understanding how it works is you run the installer to install the libraries and everything necessary for Forge and then pass this line to the JVM extra parameters: @libraries/net/minecraftforge/forge/1.17.1-37.0.1/unix_args.txt to actually load Forge but when I do this I get a Java error.

 

I've run the installer locally on my Windows machine and copied over the files to the server directory, just be sure to select Install server in the installer, this should basically do the trick.

But as said above can't get it to run because I get another Java error and giving up for now...

 

What is even more funny, the installer needs Java 8 and the game, at least from what I know needs Java 16, only discovered this because I also tried to install it it directly in the container itself... 

 

One little hint if you get it to run you have of course to increase the RAM size because Forge uses a lot of RAM.

Link to comment
On 7/30/2021 at 1:35 PM, ich777 said:

I already had a Enigma-BBS container but had to deprecate it because the developers changed something that completely broke the container.

 

This is still something on my to do list, but please note that I'm currently not having much time and to create such a container could also take some time because I'm not very familiar with the options that are available and out there that are currently working in 2021.

I'm not sure if its relevant or not but when i installed the Enigma-BBS container it would load but would keep closing the connection if i pressed anything. But i was able to get it up and working by running the setup command in a terminal window that went through the settings it needs. after that the container worked great. just can't run door games cause i can't figure out how to get DOSEMU to work inside the container.

Link to comment
On 8/8/2021 at 7:54 AM, ich777 said:

Now I get it... :)

 

This is just the installer, but I've tried it now in many different ways and don't get it to work.

Finally I was able to start the installer (1.17.1) and install the server in a windows environment and extract the server.jar. After pasting forge's "server-1.17.1.jar" (Download) into the basic minecraft docker path, it installed (jre16) and started with an error message, but which could be solved easily:

image.png.a5cb2a76e2c68f1e5cceffc77fd25c19.png

 

I'm not sure if it wouldn't even possible to execute the installer inside a docker as there is with java -jar forge-installer.jar --installServer a terminal command available. But I totally skiped Forge, after I surprisingly found out that my son wasn't talking about the mod Minecraft "Sky". Instead he meant "Skyblock". A simple map 🙈

 

 

If anyone likes to know how this works. Download the map:

https://skyblock.net/downloads/

 

Stop the container, extract the map to the container's path and name the folder for example "skyblock2.1" and inside of the server.properties, rename the world to "skyblock2.1", too:

605273372_2021-08-1008_44_33.png.c0212097068de8db3e13b2e005e3b227.png
 

 

 

  • Thanks 1
Link to comment

Hello, I am trying to resolve a problem with the factorio container,

i've open port udp 34197, nothing else is using this port.

how ever i can not join my game via the lan or public games menus, 

lan and public both set to true in the config

i can see my game in the public games, 

i can not see it in the lan games

my friend can also see the game in the public list and also gets the 

Could not establish network communication with server.

 

we can both connect directly via ip:port.

 

i get these errors/warnings in the log

 

1.539 Error InterruptibleStdioStream.cpp:61: Got EOF on stdin; closing

 

1.742 Warning ServerRouter.cpp:519: Received own address message reply with conflicting address (got IP ADDR:({199.186.5.96:29942}), expected IP ADDR:({199.186.5.96:18489}))
1.742 Warning ServerMultiplayerManager.cpp:628: Determining own address has failed. Best guess: IP ADDR:({199.186.5.96:18489})
1.776 Warning ServerRouter.cpp:519: Received own address message reply with conflicting address (got IP ADDR:({199.186.5.96:32225}), expected IP ADDR:({199.186.5.96:18489}))
1.826 Warning ServerRouter.cpp:519: Received own address message reply with conflicting address (got IP ADDR:({199.186.5.96:44284}), expected IP ADDR:({199.186.5.96:18489}))

 

ip addresses above changed for privacy,

 

any ideas how to fix this please?

 

thanks

 

 

Edited by schuu
Link to comment
42 minutes ago, schuu said:

i can see my game in the public games

Have you also linked your Factorio account to the dedicated server?

 

I'm not to sure how this works because I only made the template for this container and used to play only localy with it.

 

I recommend to create a Github issue.

Link to comment
1 minute ago, ich777 said:

Have you also linked your Factorio account to the dedicated server?

 

I have added my email to the config, and tried with both password and token,

 

1 minute ago, ich777 said:

 

I recommend to create a Github issue.

 

I will have a look thanks.

Link to comment
4 minutes ago, schuu said:

I will have a look thanks.

Sorry that I can't help here since I don't play the game anymore and I'm not the container maintainer... :/

 

If you forwarded the ports correctly it should work is there also a option in the config where you can change the listem address? If yes change it to 0.0.0.0

Link to comment
5 minutes ago, ich777 said:

Sorry that I can't help here since I don't play the game anymore and I'm not the container maintainer... :/

 

If you forwarded the ports correctly it should work is there also a option in the config where you can change the listem address? If yes change it to 0.0.0.0

I do not think there is

Link to comment
52 minutes ago, Cornflake said:

Hey, smb know how i can change the max Ram usage from the minecraft docker?

i set XMX to 12gb but it still uses like ~18gb

Open up the Advanced View in the Docker template and append at "Extra Parameters":

--memory=12G

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.