[Support] ich777 - Gameserver Dockers


Recommended Posts

11 hours ago, ich777 said:

I think this is something for @Cyd?

if the other nine are working and it looks like they are... 

 

https://arkbrowser.com/servers?q=cluster%3AD1R7Y

 

you are going to have to keep digging in your servers file system... there is no way for us to know how your system is behaving... 

 

Are the other containers behaving as you expect? 

What are the permissions of /mnt/cache/appdata/ark-se/ARK6-Valguero_P? Do they match the other ARK* folders?

what are the contents?  Are they layed out the same as the other ARK* folders?

is the .ark file present? (ls -l /mnt/cache/appdata/ark-se/ARK6-Valguero_P/SavedArks/Valguero_P.ark)

does the server container start? 

what do the logs say?

if it does start can you join the game on it? transfer in or out to others in the cluster?

 

You are going to have to do some of the digging leg work before anyone is going to be able to assist.

 

 

  • Thanks 1
Link to comment
22 hours ago, Cyd said:

if the other nine are working and it looks like they are... 

 

https://arkbrowser.com/servers?q=cluster%3AD1R7Y

 

you are going to have to keep digging in your servers file system... there is no way for us to know how your system is behaving... 

 

Are the other containers behaving as you expect? 

What are the permissions of /mnt/cache/appdata/ark-se/ARK6-Valguero_P? Do they match the other ARK* folders?

what are the contents?  Are they layed out the same as the other ARK* folders?

is the .ark file present? (ls -l /mnt/cache/appdata/ark-se/ARK6-Valguero_P/SavedArks/Valguero_P.ark)

does the server container start? 

what do the logs say?

if it does start can you join the game on it? transfer in or out to others in the cluster?

 

You are going to have to do some of the digging leg work before anyone is going to be able to assist.

 

 

 

1. All my other containers are working properly.

2. The permissions match all of the other Ark Dockers and the folders match

3 Contents are the same except for the missing forlder /linuserver

4. .ark files are present

5. Server starts normally, and it even shows up in the cluster, I can transfer there and back but with no config settings, I can't install my mods and settings. 

6. Logs shows the docker starts up normally. 

root@Tower:/mnt/cache/appdata/ark-se# clear
root@Tower:/mnt/cache/appdata/ark-se# ls -al
total 35800
drwxrwx--- 19 nobody users     4096 Sep 15 11:28 ./
drwxrwxrwx 12 nobody users      153 Aug 18 20:57 ../
drwxrwx---  5 nobody users       49 Aug 18 21:18 ARK1-TheIsland/
drwxrwx---  6 nobody users       66 Sep  8 15:25 ARK10-Genesis2/
drwxrwx---  5 nobody users       49 Aug 21 02:29 ARK11-Lost_Island/
drwxrwx---  6 nobody users       66 Sep 13 23:29 ARK2-ScorchedEarth_P/
drwxrwx---  6 nobody users       66 Sep  8 23:29 ARK3-Aberration/
drwxrwx---  5 nobody users       49 Aug 18 22:35 ARK4-TheCenter/
drwxrwx---  6 nobody users       66 Aug 28 21:39 ARK5-Ragnarok/
drwxrwx---  5 nobody users       49 Sep 10 18:08 ARK6-Valguero_P/
drwxrwx---  6 nobody users       66 Sep  9 12:25 ARK7-CrystalIsles/
drwxrwx---  6 nobody users       66 Sep 13 10:36 ARK8-Extinction/
drwxrwx---  6 nobody users       66 Sep  8 14:16 ARK9-Genesis/
drwxrwx---  7 nobody users       80 Aug 18 21:16 Engine/
-rwxrwx---  1 nobody users  5208045 Sep 15 11:27 PackageInfo.bin*
drwxrwx---  6 nobody users      117 Sep 10 23:50 ShooterGame/
-rwxrwx---  1 nobody users      272 Sep 10 20:07 SteamCMDInstall.sh*
drwxrwx---  3 nobody users       22 Aug 23 17:46 clusterfiles/
drwxrwx---  2 nobody users      114 Aug 21 02:31 dynamicconfig/
drwxrwx---  2 nobody users       28 Sep 15 02:47 linux64/
drwxrwx---  5 nobody users       86 Sep 15 11:28 steamapps/
-rwxrwx---  1 nobody users 31433351 Sep 15 02:46 steamclient.so*
-rwxrwx---  1 nobody users        9 Sep 15 11:27 version.txt*
root@Tower:/mnt/cache/appdata/ark-se# cd ARK6-Valguero_P
root@Tower:/mnt/cache/appdata/ark-se/ARK6-Valguero_P# ls -al
total 8
drwxrwx---  5 nobody users   49 Sep 10 18:08 ./
drwxrwx--- 19 nobody users 4096 Sep 15 11:28 ../
drwxrwx---  3 nobody users   32 Sep 10 18:07 Config/
drwxrwx---  2 nobody users   29 Sep 10 18:07 Logs/
drwxrwx---  2 nobody users 4096 Sep 14 15:52 SavedArks/
root@Tower:/mnt/cache/appdata/ark-se/ARK6-Valguero_P# cd SavedArks
root@Tower:/mnt/cache/appdata/ark-se/ARK6-Valguero_P/SavedArks# ls -al
total 939492
drwxrwx--- 2 nobody users     4096 Sep 14 15:52 ./
drwxrwx--- 5 nobody users       49 Sep 10 18:08 ../
-rwxrwx--- 1 nobody users     2055 Sep 11 12:40 76561198038289467.arkprofile*
-rwxrwx--- 1 nobody users 43918337 Sep 14 15:52 Valguero_P.ark*
-rwxrwx--- 1 nobody users 43631870 Sep 12 19:14 Valguero_P_12.09.2021_22.14.02.ark*
-rwxrwx--- 1 nobody users 43633182 Sep 12 21:24 Valguero_P_13.09.2021_00.24.02.ark*
-rwxrwx--- 1 nobody users 43633182 Sep 12 23:34 Valguero_P_13.09.2021_02.34.02.ark*
-rwxrwx--- 1 nobody users 43635900 Sep 13 01:44 Valguero_P_13.09.2021_04.44.02.ark*
-rwxrwx--- 1 nobody users 43657801 Sep 13 09:02 Valguero_P_13.09.2021_12.02.27.ark*
-rwxrwx--- 1 nobody users 43673960 Sep 13 11:12 Valguero_P_13.09.2021_14.12.27.ark*
-rwxrwx--- 1 nobody users 43687464 Sep 13 13:22 Valguero_P_13.09.2021_16.22.27.ark*
-rwxrwx--- 1 nobody users 43698185 Sep 13 15:32 Valguero_P_13.09.2021_18.32.27.ark*
-rwxrwx--- 1 nobody users 43708960 Sep 13 17:42 Valguero_P_13.09.2021_20.42.27.ark*
-rwxrwx--- 1 nobody users 43708960 Sep 13 19:52 Valguero_P_13.09.2021_22.52.27.ark*
-rwxrwx--- 1 nobody users 43715560 Sep 13 22:02 Valguero_P_14.09.2021_01.02.27.ark*
-rwxrwx--- 1 nobody users 43718299 Sep 14 00:12 Valguero_P_14.09.2021_03.12.27.ark*
-rwxrwx--- 1 nobody users 43718299 Sep 14 02:22 Valguero_P_14.09.2021_05.22.27.ark*
-rwxrwx--- 1 nobody users 43720840 Sep 14 04:32 Valguero_P_14.09.2021_07.32.27.ark*
-rwxrwx--- 1 nobody users 43720840 Sep 14 06:42 Valguero_P_14.09.2021_09.42.27.ark*
-rwxrwx--- 1 nobody users 43726243 Sep 14 08:52 Valguero_P_14.09.2021_11.52.27.ark*
-rwxrwx--- 1 nobody users 43964557 Sep 14 11:02 Valguero_P_14.09.2021_14.02.27.ark*
-rwxrwx--- 1 nobody users 43917052 Sep 14 13:12 Valguero_P_14.09.2021_16.12.27.ark*
-rwxrwx--- 1 nobody users 43918338 Sep 14 15:22 Valguero_P_14.09.2021_18.22.27.ark*
-rwxrwx--- 1 nobody users 43635900 Sep 13 06:52 Valguero_P_AntiCorruptionBackup.bak*
-rwxrwx--- 1 nobody users 43635900 Sep 13 07:07 Valguero_P_NewLaunchBackup.bak*
root@Tower:/mnt/cache/appdata/ark-se/ARK6-Valguero_P/SavedArks# cd ..
root@Tower:/mnt/cache/appdata/ark-se/ARK6-Valguero_P# ls -al
total 8
drwxrwx---  5 nobody users   49 Sep 10 18:08 ./
drwxrwx--- 19 nobody users 4096 Sep 15 11:28 ../
drwxrwx---  3 nobody users   32 Sep 10 18:07 Config/
drwxrwx---  2 nobody users   29 Sep 10 18:07 Logs/
drwxrwx---  2 nobody users 4096 Sep 14 15:52 SavedArks/
root@Tower:/mnt/cache/appdata/ark-se/ARK6-Valguero_P# cd Config
root@Tower:/mnt/cache/appdata/ark-se/ARK6-Valguero_P/Config# ls -al
total 0
drwxrwx--- 3 nobody users 32 Sep 10 18:07 ./
drwxrwx--- 5 nobody users 49 Sep 10 18:08 ../
drwxrwx--- 2 nobody users 23 Sep 10 18:07 CleanSourceConfigs/
root@Tower:/mnt/cache/appdata/ark-se/ARK6-Valguero_P/Config# cd ..
root@Tower:/mnt/cache/appdata/ark-se/ARK6-Valguero_P#

 

Link to comment
13 minutes ago, codearoni said:

I was wondering what the right approach would be to get that update in your gameserver docker? 

Restart the container, if it doesn't pick up the update give it a little time please.

On some systems it can take a few hours to actually pick up the update, don't know what's causing that, maybe try to restart your router/firewall and then try to restart the container.

If you run Unbound, PiHole, AdGuard or something like that in your network please try to restart these too.

 

You can also try to set Validat to 'true' but if you affected by this issue that it isn't picking up the update from Steam right away you have to wait... :/

Link to comment

 @deaerator if you enter the containers console and navigate to /serverdata/serverfiles/ShooterGame/Saved/Config are they there? From the containers console run 'ps axfww' to see the whole command line that got passed to ShooterGameServer, maybe there is an alternate dir specified?

Maybe try copying in one of the folders from another ark... then see if it loads settings from them.

Link to comment
On 3/2/2021 at 4:02 PM, ich777 said:

Yes, but you do this with the Variable in the 'Show More Settings' section of the Template.

 

Keep in mind that for every container the Game Port itself has to be set in the GAME_PORT variable like mentioned above.

 

 

This is the way you would do it (this is tested and working btw):

grafik.thumb.png.a3e4e22653cc2a5543daed533a251f69.png

 

I have a question about this process. I'm trying to setup a second Valheim server. I installed a second copy of the Valheim container and set it up with different variables. I tried deleting the value from UDP - Game Port Range and added updated ports to the GAME_PORT section.  However, when the container starts, it's not remapping any ports at all. It's still trying to use the default 2456 range.

 

Next, I tried removing the UDP - Game Port Range section completely and added the ports in the GAME_PORT section. Now, no networking values are created.

 

What is the proper way to add a second server with this container?

Link to comment

Thanks ich777 for all the help you give to this community. I’ve got a question on how updates work. Valheim just received a massive patch this morning. Do you know when this will be reflected in the docket build? Will force update pull a new version? Or are updates handled internally via steam apps in the container? Thanks

Link to comment
2 minutes ago, maxwell said:

Thanks ich777 for all the help you give to this community. I’ve got a question on how updates work. Valheim just received a massive patch this morning. Do you know when this will be reflected in the docket build? Will force update pull a new version? Or are updates handled internally via steam apps in the container? Thanks

Please look two posts above your post:

Link to comment
1 minute ago, ich777 said:

I've now restarted my Valheim server and it picked up the update just fine:

grafik.thumb.png.b7dbc42539fe5fda0a6ce4f1e105cb2a.png

 

If you have any troubles please see here:

 

I can concur - my server updated successfully on its own as well. Now if I could just get the second one running 😃

  • Thanks 1
Link to comment
10 minutes ago, Xardis said:

I have a question about this process. I'm trying to setup a second Valheim server. I installed a second copy of the Valheim container and set it up with different variables. I tried deleting the value from UDP - Game Port Range and added updated ports to the GAME_PORT section.  However, when the container starts, it's not remapping any ports at all. It's still trying to use the default 2456 range.

 

Next, I tried removing the UDP - Game Port Range section completely and added the ports in the GAME_PORT section. Now, no networking values are created.

 

What is the proper way to add a second server with this container?

Can you give me a screenshot from your template please?

Link to comment
16 minutes ago, Cyd said:

 @deaerator if you enter the containers console and navigate to /serverdata/serverfiles/ShooterGame/Saved/Config are they there? From the containers console run 'ps axfww' to see the whole command line that got passed to ShooterGameServer, maybe there is an alternate dir specified?

Maybe try copying in one of the folders from another ark... then see if it loads settings from them.

I tried dropping in the linux folder with settings and it still didn't work

root@bd552e6a9928:/# ls
bin  boot  dev  etc  home  lib  lib32  lib64  media  mnt  opt  proc  root  run  sbin  serverdata  srv  sys  tmp  usr  var
root@bd552e6a9928:/# ls -al
total 0
drwxr-xr-x   1 root  root   182 Sep 10 18:04 .
drwxr-xr-x   1 root  root   182 Sep 10 18:04 ..
drwxr-xr-x   1 root  root   728 Sep 18  2020 bin
drwxr-xr-x   1 root  root     0 Jul 10  2020 boot
drwxr-xr-x   5 root  root   340 Sep 16 13:45 dev
-rwxr-xr-x   1 root  root     0 Sep 10 18:04 .dockerenv
drwxr-xr-x   1 root  root  1314 Sep 10 18:04 etc
drwxr-xr-x   1 root  root     0 Jul 10  2020 home
drwxr-xr-x   1 root  root   110 Sep 18  2020 lib
drwxr-xr-x   1 root  root  1250 Sep 18  2020 lib32
drwxr-xr-x   1 root  root    40 Aug  3  2020 lib64
drwxr-xr-x   1 root  root     0 Aug  3  2020 media
drwxr-xr-x   1 root  root     0 Aug  3  2020 mnt
drwxr-xr-x   1 root  root    14 Sep 18  2020 opt
dr-xr-xr-x 886 root  root     0 Sep 16 13:45 proc
drwx------   1 root  root    30 Aug  3  2020 root
drwxr-xr-x   1 root  root    16 Aug  3  2020 run
drwxr-xr-x   1 root  root  1056 Sep 18  2020 sbin
drwxrwx---   1 steam users   60 Sep 10 18:05 serverdata
drwxr-xr-x   1 root  root     0 Aug  3  2020 srv
dr-xr-xr-x  13 root  root     0 Sep 16 13:45 sys
drwxrwxrwt   1 root  root    10 Sep 10 18:05 tmp
drwxr-xr-x   1 root  root    80 Sep 18  2020 usr
drwxr-xr-x   1 root  root    90 Aug  3  2020 var
root@bd552e6a9928:/# cd serverdata
root@bd552e6a9928:/serverdata# ls
serverfiles  Steam  steamcmd
root@bd552e6a9928:/serverdata# cd serverfiles
root@bd552e6a9928:/serverdata/serverfiles# ls
ARK10-Genesis2     ARK1-TheIsland        ARK3-Aberration  ARK5-Ragnarok    ARK7-CrystalIsles  ARK9-Genesis  dynamicconfig  linux64          ShooterGame  steamclient.so      version.txt
ARK11-Lost_Island  ARK2-ScorchedEarth_P  ARK4-TheCenter   ARK6-Valguero_P  ARK8-Extinction    clusterfiles  Engine         PackageInfo.bin  steamapps    SteamCMDInstall.sh
root@bd552e6a9928:/serverdata/serverfiles# ls -al
total 35800
drwxrwx--- 19 steam users     4096 Sep 15 11:28 .
drwxrwx---  1 steam users       60 Sep 10 18:05 ..
drwxrwx---  6 steam users       66 Sep  8 15:25 ARK10-Genesis2
drwxrwx---  5 steam users       49 Aug 21 02:29 ARK11-Lost_Island
drwxrwx---  5 steam users       49 Aug 18 21:18 ARK1-TheIsland
drwxrwx---  6 steam users       66 Sep 13 23:29 ARK2-ScorchedEarth_P
drwxrwx---  6 steam users       66 Sep  8 23:29 ARK3-Aberration
drwxrwx---  5 steam users       49 Aug 18 22:35 ARK4-TheCenter
drwxrwx---  6 steam users       66 Aug 28 21:39 ARK5-Ragnarok
drwxrwx---  5 steam users       49 Sep 10 18:08 ARK6-Valguero_P
drwxrwx---  6 steam users       66 Sep  9 12:25 ARK7-CrystalIsles
drwxrwx---  6 steam users       66 Sep 13 10:36 ARK8-Extinction
drwxrwx---  6 steam users       66 Sep  8 14:16 ARK9-Genesis
drwxrwx---  3 steam users       22 Aug 23 17:46 clusterfiles
drwxrwx---  2 steam users      114 Aug 21 02:31 dynamicconfig
drwxrwx---  7 steam users       80 Aug 18 21:16 Engine
drwxrwx---  2 steam users       28 Sep 15 02:47 linux64
-rwxrwx---  1 steam users  5208045 Sep 15 11:27 PackageInfo.bin
drwxrwx---  6 steam users      117 Sep 10 23:50 ShooterGame
drwxrwx---  5 steam users       86 Sep 15 11:28 steamapps
-rwxrwx---  1 steam users 31433351 Sep 15 02:46 steamclient.so
-rwxrwx---  1 steam users      272 Sep 10 20:07 SteamCMDInstall.sh
-rwxrwx---  1 steam users        9 Sep 15 11:27 version.txt
root@bd552e6a9928:/serverdata/serverfiles# cd ShooterGame
root@bd552e6a9928:/serverdata/serverfiles/ShooterGame# ls -al
total 16
drwxrwx---  6 steam users  117 Sep 10 23:50 .
drwxrwx--- 19 steam users 4096 Sep 15 11:28 ..
-rwxrwx---  1 steam users    4 Sep 10 23:38 AssetRegistry.bin
drwxrwx---  4 steam users   32 Aug 18 21:16 Binaries
drwxrwx---  5 steam users  252 Sep 10 23:50 Config
drwxrwx--- 31 steam users 4096 Sep 15 11:28 Content
drwxrwx---  5 steam users   49 Sep 10 18:08 Saved
-rwxrwx---  1 steam users  709 Sep 10 20:08 ShooterGame.uproject
root@bd552e6a9928:/serverdata/serverfiles/ShooterGame# cd Config
root@bd552e6a9928:/serverdata/serverfiles/ShooterGame/Config# ls -al
total 300
drwxrwx--- 5 steam users    252 Sep 10 23:50 .
drwxrwx--- 6 steam users    117 Sep 10 23:50 ..
-rwxrwx--- 1 steam users    633 Sep 10 19:55 DefaultDeviceProfiles.ini
-rwxrwx--- 1 steam users   1247 Sep 10 23:37 DefaultEditor.ini
-rwxrwx--- 1 steam users    841 Sep 10 23:37 DefaultEditorUserSettings.ini
-rwxrwx--- 1 steam users 195354 Sep 10 23:37 DefaultEngine.ini
-rwxrwx--- 1 steam users  68841 Sep 10 19:55 DefaultGame.ini
-rwxrwx--- 1 steam users    947 Sep 10 23:37 DefaultGameUserSettings.ini
-rwxrwx--- 1 steam users  22908 Sep 10 23:37 DefaultInput.ini
drwxrwx--- 2 steam users     27 Sep 10 23:50 Linux
drwxrwx--- 2 steam users    100 Sep 10 23:50 Localization
drwxrwx--- 3 steam users     18 Aug 18 21:16 OSS
root@bd552e6a9928:/serverdata/serverfiles/ShooterGame/Config# cd ..
root@bd552e6a9928:/serverdata/serverfiles/ShooterGame# cd /
root@bd552e6a9928:/# ls
bin  boot  dev  etc  home  lib  lib32  lib64  media  mnt  opt  proc  root  run  sbin  serverdata  srv  sys  tmp  usr  var
root@bd552e6a9928:/# ls a-
ls: cannot access 'a-': No such file or directory
root@bd552e6a9928:/# ps axfww
  PID TTY      STAT   TIME COMMAND
   87 pts/0    Ss     0:00 bash
  104 pts/0    R+     0:00  \_ ps axfww
    1 ?        Ss     0:00 /bin/bash /opt/scripts/start.sh
   11 ?        S      0:00 su steam -c /opt/scripts/start-server.sh
   12 ?        Ss     0:00  \_ /bin/bash /opt/scripts/start-server.sh
   58 ?        Sl     4:41      \_ ./ShooterGameServer Valguero_P?listen?SessionName=D1R7YS_Valguero?ServerPassword=XXXX?ServerAdminPassword=XXXXX.?Listen?Port=7787?QueryPort=27020?MaxPlayers=25?RCONEnabled=True?RCONPort=27030?customdynamicconfigurl="http://172.17.0.2/dynamicconfig.ini" -server -log -nowrite -clusterid=D1R7Y -ClusterDirOverride=/serverdata/serverfiles/clusterfiles -UseDynamicConfig -ForceRespawnDinos
root@bd552e6a9928:/#

 

Link to comment
33 minutes ago, ich777 said:

Restart the container, if it doesn't pick up the update give it a little time please.

On some systems it can take a few hours to actually pick up the update, don't know what's causing that, maybe try to restart your router/firewall and then try to restart the container.

If you run Unbound, PiHole, AdGuard or something like that in your network please try to restart these too.

 

You can also try to set Validat to 'true' but if you affected by this issue that it isn't picking up the update from Steam right away you have to wait... :/

Sounds great! Thanks for such a fast reply. I've been using your Valheim container for months and it's been amazing. Ty for all your hard work!

  • Like 1
Link to comment
26 minutes ago, Xardis said:

Next, I tried removing the UDP - Game Port Range section completely and added the ports in the GAME_PORT section. Now, no networking values are created.

Like the post says, you have to click on "Show more settings ..." in the template then change the value from "2456" to something like "2466", then delete the entry "UDP - Game Port Range" entirely, then click on "Add another Path, Port, Variable, Label or Device" from the drop down select "Port" at container port enter "2466-2468", at host port enter "2466-2468", at connection type select "UDP" from the drop down, click on "Add" and "Apply".

 

Now you have a server running on port 2466.

 

This is how the new entry should look like:

grafik.png.484bb15969aff9563c931d1d9f041c53.png

  • Thanks 1
Link to comment

@deaeratortake one more look inside the container, you show /serverdata/serverfiles/ShooterGame/Config

instead of:

/serverdata/serverfiles/ShooterGame/Saved/Config/LinuxServer

 

at this point I would be tempted to nuke it from orbit and spin up a fresh one.

 

rm -rf /mnt/cache/appdata/ark-se/ARK6-Valguero_P

 

then add a space or some other trivial change to the template to force the container to be delete and recreated.

 

 

Link to comment
1 minute ago, Cyd said:

@deaeratortake one more look inside the container, you show /serverdata/serverfiles/ShooterGame/Config

instead of:

/serverdata/serverfiles/ShooterGame/Saved/Config/LinuxServer

 

at this point I would be tempted to nuke it from orbit and spin up a fresh one.

 

rm -rf /mnt/cache/appdata/ark-se/ARK6-Valguero_P

 

then add a space or some other trivial change to the template to force the container to be delete and recreated.

 

 

root@bd552e6a9928:/# cd /serverdata/serverfiles/ShooterGame/Saved/Config/LinuxServer
bash: cd: /serverdata/serverfiles/ShooterGame/Saved/Config/LinuxServer: No such file or directory
root@bd552e6a9928:/#

This is the second attempt with a fresh docker and still get the same results

Link to comment
40 minutes ago, nlash said:

If I wanted to delete the old (pre Home and Hearth update) server world and start fresh, what's the best way to do that?

Stop the container, delete the "valheim" folder that lives in your "appdata" directory and start the container again.

Link to comment
37 minutes ago, deaerator said:
root@bd552e6a9928:/# cd /serverdata/serverfiles/ShooterGame/Saved/Config/LinuxServer
bash: cd: /serverdata/serverfiles/ShooterGame/Saved/Config/LinuxServer: No such file or directory
root@bd552e6a9928:/#

This is the second attempt with a fresh docker and still get the same results

that's the same container as before...bd552e6a9928 & bd552e6a9928, stop the container, rm -rf /mnt/cache/appdata/ark-se/ARK6-Valguero_P, then edit the template and change "Extra Game Parameters:" by adding a space to the end of the line and press apply at the bottom of the page. that will delete the container and spin up a new one, the id at the console prompt should change.

 

If that does not do it see if the volume mappings are working, list the directory from both of its mount points, then touch a new file and list them again, if the new file is missing from the other mount point there might be some masking going on, if it is there then... something else...

 

root@183e58fbd815:/# ls -l serverdata/serverfiles/ShooterGame/Saved/Config/LinuxServer/
-rwxrwx--- 1 steam users 12433 May 19 15:04 GameUserSettings.ini

 

root@183e58fbd815:/# ls -l /serverdata/serverfiles/ARK6-Valguero_P/Config/LinuxServer/
-rwxrwx--- 1 steam users 12433 May 19 15:04 GameUserSettings.ini

 

root@183e58fbd815:/# touch  /serverdata/serverfiles/ARK6-Valguero_P/Config/LinuxServer/here.txt 

 

root@183e58fbd815:/# ls -l serverdata/serverfiles/ShooterGame/Saved/Config/LinuxServer/
-rwxrwx--- 1 steam users 12433 May 19 15:04 GameUserSettings.ini
-rw-r--r-- 1 root  root      0 Sep 16 13:33 here.txt

 

root@183e58fbd815:/# ls -l /serverdata/serverfiles/ARK6-Valguero_P/Config/LinuxServer/
-rwxrwx--- 1 steam users 12433 May 19 15:04 GameUserSettings.ini
-rw-r--r-- 1 root  root      0 Sep 16 13:33 here.txt
 

 

Link to comment
17 minutes ago, Cyd said:

that's the same container as before...bd552e6a9928 & bd552e6a9928, stop the container, rm -rf /mnt/cache/appdata/ark-se/ARK6-Valguero_P, then edit the template and change "Extra Game Parameters:" by adding a space to the end of the line and press apply at the bottom of the page. that will delete the container and spin up a new one, the id at the console prompt should change.

 

If that does not do it see if the volume mappings are working, list the directory from both of its mount points, then touch a new file and list them again, if the new file is missing from the other mount point there might be some masking going on, if it is there then... something else...

 

root@183e58fbd815:/# ls -l serverdata/serverfiles/ShooterGame/Saved/Config/LinuxServer/
-rwxrwx--- 1 steam users 12433 May 19 15:04 GameUserSettings.ini

 

root@183e58fbd815:/# ls -l /serverdata/serverfiles/ARK6-Valguero_P/Config/LinuxServer/
-rwxrwx--- 1 steam users 12433 May 19 15:04 GameUserSettings.ini

 

root@183e58fbd815:/# touch  /serverdata/serverfiles/ARK6-Valguero_P/Config/LinuxServer/here.txt 

 

root@183e58fbd815:/# ls -l serverdata/serverfiles/ShooterGame/Saved/Config/LinuxServer/
-rwxrwx--- 1 steam users 12433 May 19 15:04 GameUserSettings.ini
-rw-r--r-- 1 root  root      0 Sep 16 13:33 here.txt

 

root@183e58fbd815:/# ls -l /serverdata/serverfiles/ARK6-Valguero_P/Config/LinuxServer/
-rwxrwx--- 1 steam users 12433 May 19 15:04 GameUserSettings.ini
-rw-r--r-- 1 root  root      0 Sep 16 13:33 here.txt
 

 

I destroyed the first one long time ago thinking it was an error on my part, but this is the second docker container producing the same results.

Link to comment
2 hours ago, ich777 said:

Can you give me a screenshot from your template please?

I think I fixed this myself, root cause was user error. When I created the new port range, I didn't pick the right option in the drop-down menu - picked variable instead of port. Now the port redirection appears to be working properly.

  • Like 1
Link to comment
2 hours ago, ich777 said:

Like the post says, you have to click on "Show more settings ..." in the template then change the value from "2456" to something like "2466", then delete the entry "UDP - Game Port Range" entirely, then click on "Add another Path, Port, Variable, Label or Device" from the drop down select "Port" at container port enter "2466-2468", at host port enter "2466-2468", at connection type select "UDP" from the drop down, click on "Add" and "Apply".

 

Now you have a server running on port 2466.

 

This is how the new entry should look like:

grafik.png.484bb15969aff9563c931d1d9f041c53.png

Yes, this is exactly the part I missed. I didn't pick the correct Config Type on this step. When I recreated with Port configured, it worked great! Thanks for your response - much appreciated!

  • Like 1
Link to comment
On 9/15/2021 at 2:01 AM, ich777 said:

Please join @Spectral Force's Discord for support for my 7DtD container: https:// discord .gg/VwwYA5h

 

I personally don't own 7DtD and I really can't help with this container.

I ended up getting it working. It was oversight on my part. I didnt realize it installed to /mnt/cache/appdata/7dtd. Whenever i would edit the file it was putting it in /mnt/dockers/appdata/7dtd. All is well. Thanks for all your work on the gaming containers.

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.