[Support] ich777 - Gameserver Dockers


Recommended Posts

8 minutes ago, Maurice97 said:

I did setup a new Ark Server for testing but i cant figure out how to edit the game files at "/mnt/cache/appdata/ark-se" ?

Share the appdata share over SMB and you can navigate to it, would recommend toake the share hidden.

Link to comment

In regards to Valheim; Can someone share what they are port forwarding on their router and what they are forwarding in DNS?

 

I'm able to get Minecraft to work just fine with a CNAME and SRV, but Valheim doesn't seem to work and I'm reading conflicting information on the net about whether or not that should work.
 

Also; an info on how you set it up to use a proxy would be great!

Link to comment
15 hours ago, ich777 said:

Bad news, I've deprecated this game, since they have completely changed the way how it works...

😱 Does this means we not gonna get this docker back? or it's gonna take more time to be sorted?

Link to comment
6 hours ago, aidenpryde said:

Also; an info on how you set it up to use a proxy would be great!

May I ask why do you want to use a proxy?

I'm not a huge fan of proxying a game server.

 

You could always use your domain name without any subdomain to connect to the server if you forwarded the right ports in your router, in case for Valheim.

 

6 hours ago, aidenpryde said:

I'm able to get Minecraft to work just fine with a CNAME and SRV

Minecraft needs only one port, Valheim needs three ports.

 

The ports are in the template itself and also which protocol do you have to use.

Please pook at the second recommended post on top of this thread.

Link to comment
1 hour ago, ich777 said:

May I ask why do you want to use a proxy?

I'm not a huge fan of proxying a game server.

 

You could always use your domain name without any subdomain to connect to the server if you forwarded the right ports in your router, in case for Valheim.

 

Minecraft needs only one port, Valheim needs three ports.

 

The ports are in the template itself and also which protocol do you have to use.

Please pook at the second recommended post on top of this thread.

 

So, okay I won't worry about proxy, but nothing I'm trying works.  I've got a CNAME, and a SRV for each port.  No connection.

Link to comment
4 minutes ago, aidenpryde said:

So, okay I won't worry about proxy, but nothing I'm trying works.  I've got a CNAME, and a SRV for each port.  No connection.

Why do you want to change anything in terms of the cname or srv?

If your domain name eg: "example.org" is resolved correctly you should be able to connect from within the game with "example.org" if the game runs on the default ports.

 

Are you sure you've forwarded the Ports UDP 2456, 2457 & 2458 in your router?

 

Have you already tried to connect from your LAN to the server using the Server IP?

Link to comment
42 minutes ago, ich777 said:

Why do you want to change anything in terms of the cname or srv?

If your domain name eg: "example.org" is resolved correctly you should be able to connect from within the game with "example.org" if the game runs on the default ports.

 

Are you sure you've forwarded the Ports UDP 2456, 2457 & 2458 in your router?

 

Have you already tried to connect from your LAN to the server using the Server IP?

Thanks.  It works with local LAN IP address.

 

Just a thought; should I be port forwarding to the host or the IP address created in the container?  I mean, I'm able to hit it on the LAN IP with that container IP address.  I've always port forwarded to the host and then docker takes care of the rest.

Link to comment
58 minutes ago, aidenpryde said:

Just a thought; should I be port forwarding to the host or the IP address created in the container?

You should use the IP from unRAID and the 3 ports to forwad it.

 

Have you changed anything in the template?

Link to comment
9 hours ago, Val said:

😱 Does this means we not gonna get this docker back? or it's gonna take more time to be sorted?

The container should be available again in the next few hours in the CA App, please note that the save path has now changed slightly and I've updated the description.

Link to comment
12 hours ago, ich777 said:

You should use the IP from unRAID and the 3 ports to forwad it.

 

Have you changed anything in the template?

I added a fixed IP address and changed where the server files are stored as it was trying to store on my cache instead of Appdata directory on my pool.

 

So, I should be using the IP address of the host.

 

Do you have an example of how you're using CNAMEs and SRV to get this to work with a domain?

Link to comment
6 hours ago, aidenpryde said:

So, I should be using the IP address of the host.

If you changed it, yes then you should be using the IP address instead.

 

6 hours ago, aidenpryde said:

Do you have an example of how you're using CNAMEs and SRV to get this to work with a domain?

I don't use a CNAME or SRV entry.

The A record is enough if your public IP is resolved correctly.

 

Simply enter in the games server browser your domainname and you should be good to go eg: "yourdomain.org"

The game will automatically search on the default port so you don't have to enter eg: "youdomain.org:2456"

Link to comment
17 hours ago, ich777 said:

The container should be available again in the next few hours in the CA App, please note that the save path has now changed slightly and I've updated the description.

Great, thanks for the help 😊

Link to comment

Hi @ich777 I asked a while back about the possibility of you creating a container for Survive the Nights - assuming you still don't have it would you be open to seeing if it's possible if I were to gift you the game??

 

The developers have introduced a server option in-game and from a few things I've read I believe it would be Linux based - although I know very little about these things!

 

No problem if not, it's just the type of game I think would be loads better with a dedicated server!

 

Cheers....

  • Like 1
Link to comment
10 hours ago, stevep94 said:

Survive the Nights

Seems like this is possible from what I've read.

 

If you gift me the game I can look into it and create a dedicated server if it's possible but as said above this should be totally doable.

  • Like 1
Link to comment
7 hours ago, ich777 said:

Seems like this is possible from what I've read.

 

If you gift me the game I can look into it and create a dedicated server if it's possible but as said above this should be totally doable.

 

Great stuff - I'll look at this in the next day or so - what is your Steam username?

Link to comment

Hey Ich,

First off, thanks so much for all your work - seems like you're working around the clock.

 

I'm not the best with knowing how all this works, but I can follow instructions/research where needed.

I did try searching through this forum for any info, but wasn't directly related to what I'm having issues with.

The issue I'm having is with FiveM.

Took me a bit to get it up and now I'm able to actually see my server and load into it.

It stated that I'm on an older version and has to revert back.

I restarted the docker multiple times to see if it'll pull a newer version, but it says it's up to date.

I also set the manual update to 'true' and downloaded the latest fx.tar.xz (4675 as of right now), but I don't think it takes it.

According to the other file that's in there, looks like the version is 4394.

Anything I'm missing to get this thing updated?

 

On a different note, I can't get the web console working.

The first time I got your docker, what looks like a separate terminal window opened up, but I can't do anything in it, just a white page, but now, it opens up to a 'page not found' - I do notice it opens up to port 8080, so I force it to 9016, but same thing.

Not sure if this is related if it's out of date or not.

 

Screenshot 2021-09-28 204015.png

Screenshot 2021-09-28 203932.png

Screenshot 2021-09-28 203647.png

Link to comment
5 hours ago, Kishman said:

I also set the manual update to 'true' and downloaded the latest fx.tar.xz (4675 as of right now)

The container will always downloads the "Latest Recommended" build and that is as time of writing 4394 (you can see this here: Click)

 

I found an error in my template, will change that ASAP, please click on "Edit" at the Manual download and change it like this:

grafik.png.1ebe82b7dad0c0dcf9bfa34a93679691.png

 

 

5 hours ago, Kishman said:

I do notice it opens up to port 8080, so I force it to 9016, but same thing.

I don't understand what you mean with that, I've now tried it and it works just fine.

Are you connecting to "YOURunraidIP:9016"?

 

Here is a screenshot from the WebConsole:

grafik.png.53bdb21049097c3a267cde6c8192cd0c.png

Keep in mind the WebConsole is only available if the server is fully started!

 

 

Also attached the log from a full server startup: fivem.log

Link to comment
5 hours ago, ich777 said:

The container will always downloads the "Latest Recommended" build and that is as time of writing 4394 (you can see this here: Click)

Ah, my mistake, ok, that makes sense.

 

5 hours ago, ich777 said:

please click on "Edit" at the Manual download and change it like this:

Did that, getting a 

 e":"No such container: ef1fab5b8f0a"}

Stopped and restarted a few times, just continues 'normally' after - does it delete the fx.tar after it updates?

 

 

 

5 hours ago, ich777 said:

Are you connecting to "YOURunraidIP:9016"?

Yes - the very first time I installed, it did look like it opened up a WebConsole page (with port 9016), but it was blank - then I deleted everything (docker container, folder, verified it was gone, even deleted the entire docker.img), and started from scratch again but for whatever reason, it tries to load up with port 8080.

 

This server that I'm testing on has just been spun up specifically for FiveM - just want to get the feel of it, then once I do, I'll start to put this on my production server (my production server isn't at my house, so I rather quickly do things locally first). So there's nothing else on this server, except FiveM (then I put on Krusader after to help delete things).

 

5 hours ago, ich777 said:

Also attached the log from a full server startup

Does it go through those loads every time?

I thought something was wrong with this loading, but wasn't sure if it was just that simple...

Link to comment
1 hour ago, Kishman said:

Did that, getting a 

Please refresh the page or open up a new log window.

 

1 hour ago, Kishman said:

Stopped and restarted a few times, just continues 'normally' after - does it delete the fx.tar after it updates?

After you've set it to manual it deletes the fx file yes. Btw it is a fx.tar.xz file usually.

 

1 hour ago, Kishman said:

Does it go through those loads every time?

Yes, restarted it a few times because I also tried if it installs it correctly when you change the variable.

 

 

1 hour ago, Kishman said:

I thought something was wrong with this loading, but wasn't sure if it was just that simple...

I don't understand, what should it load else?

Link to comment

Yeah, stopping and starting/refreshing gets rid of that error, but it doesn't seem to take the manual update.

The file is fx.tar.xz, I was just shortening it for no reason.

 

1 hour ago, ich777 said:

I don't understand, what should it load else?

Sorry, I meant what I see in my logs.

What shows up is so short compared to your logs - yet, I am able to host a server and successfully connect to it, so because of that, I assume it's working.

 

Now I'm at a loss, so not sure how much other things I can change really.

This is a fresh install of UnRaid 6.9.2 (on trial version) - not a problem to do a whole fresh install again really...

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.