[Support] ich777 - Gameserver Dockers


Recommended Posts

14 hours ago, ich777 said:

I think the map has to be downloaded forst or am I wrong?

Where did you put the command in in the template?

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker create --name='ARK11-Fjordur' --net='proxynet' -e TZ="America/Halifax" -e HOST_OS="Unraid" -e 'GAME_ID'='376030' -e 'USERNAME'='' -e 'VALIDATE'='' -e 'PASSWRD'='' -e 'MAP'='Viking_P' -e 'SERVER_NAME'='D1R7YS_Fjordur' -e 'SRV_PWD'='XXXXXXXXXXXXXX' -e 'SRV_ADMIN_PWD'='XXXXXXXXXXXX' -e 'GAME_PARAMS'='?Port=7783?QueryPort=27018?MaxPlayers=25?RCONEnabled=True?RCONPort=27036?CustomDynamicConfigUrl="http://172.18.0.2/dynamicconfig.ini"' -e 'GAME_PARAMS_EXTRA'=' -server -log -clusterid=D1R7Y -ClusterDirOverride=/serverdata/serverfiles/clusterfiles -UseDynamicConfig -ForceRespawnDinos' -e 'UID'='99' -e 'GID'='100' -p '7783:7783/udp' -p '7784:7784/udp' -p '27018:27018/udp' -p '27028:27028/tcp' -v '/mnt/user/appdata/steamcmd':'/serverdata/steamcmd':'rw' -v '/mnt/cache/appdata/ark-se':'/serverdata/serverfiles':'rw' -v '/mnt/cache/appdata/ark-se/ARK11-Fjordur':'/serverdata/serverfiles/ShooterGame/Saved':'rw' --restart=unless-stopped 'ich777/steamcmd:arkse'
4df735c7c1c8c1e0ac20bb5435d9e692bd224bf04e60746605c982aa29f0c629

The command finished successfully!

 

or

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker create --name='ARK11-Fjordur' --net='proxynet' -e TZ="America/Halifax" -e HOST_OS="Unraid" -e 'GAME_ID'='376030' -e 'USERNAME'='' -e 'VALIDATE'='' -e 'PASSWRD'='' -e 'MAP'='Viking_P' -e 'SERVER_NAME'='D1R7YS_Fjordur' -e 'SRV_PWD'='XXXXXXXXXXXX' -e 'SRV_ADMIN_PWD'='XXXXX' -e 'GAME_PARAMS'='?Port=7783?QueryPort=27018?MaxPlayers=25?RCONEnabled=True?RCONPort=27036?CustomDynamicConfigUrl="http://172.18.0.2/dynamicconfig.ini"' -e 'GAME_PARAMS_EXTRA'='-MapMODID=1838617463 -server -log -clusterid=D1R7Y -ClusterDirOverride=/serverdata/serverfiles/clusterfiles -UseDynamicConfig -ForceRespawnDinos' -e 'UID'='99' -e 'GID'='100' -p '7783:7783/udp' -p '7784:7784/udp' -p '27018:27018/udp' -p '27028:27028/tcp' -v '/mnt/user/appdata/steamcmd':'/serverdata/steamcmd':'rw' -v '/mnt/cache/appdata/ark-se':'/serverdata/serverfiles':'rw' -v '/mnt/cache/appdata/ark-se/ARK11-Fjordur':'/serverdata/serverfiles/ShooterGame/Saved':'rw' --restart=unless-stopped 'ich777/steamcmd:arkse'
1439b06368266119c6369acb258ae2d1f4ca34028b9510076d213978b72a1913

The command finished successfully!

 

Edited by deaerator
Link to comment
26 minutes ago, deaerator said:

or

I don't understand...

I'm really not familiar with ARK but maybe this helps: Click

 

Form what I've read there:

  1. Edit the file 'GameUserSettings.ini' and append for example this: 'ActiveMapMod=1065443232'
  2. In the Docker template at 'Map' enter the map name, like in this example: 'Panthalassa'
  3. Restart the container

It should then download and install the map.

Link to comment
13 minutes ago, ich777 said:

I don't understand...

I'm really not familiar with ARK but maybe this helps: Click

 

Form what I've read there:

  1. Edit the file 'GameUserSettings.ini' and append for example this: 'ActiveMapMod=1065443232'
  2. In the Docker template at 'Map' enter the map name, like in this example: 'Panthalassa'
  3. Restart the container

It should then download and install the map.

Finally got it working, thank you.

  • Like 1
Link to comment
6 hours ago, DogeKitteh007 said:

Thank you for these great dedicated servers @ich777.

 

I've been playing some Satisfactory lately and found this: https://github.com/wolveix/satisfactory-server

 

Would this (or something similar) be possible in your "collection" as well? 🙂

No, because this is only the main game running with WINE (which can get pretty unstable at times btw) in a container.

 

The dedicated server isn't out yet from what I know, if they release the dedicated server I can look into it and create a container for it but I don't like doing it that way because it's not official, don't get me wrong, it's a good idea to run it like that but if the developers change something and this would break the container, a lot of people that are using this container would be really dissapointed.

Link to comment
On 3/27/2021 at 6:42 AM, ich777 said:

 

The next time the developers of Valheim Plus change anything that breaks the function of the container I will drop it because it's not worth the effort for me to keep it runing with Valheim Plus, the most updates where bacause of Valheim Plus...

I just want to make sure you stopped support Valheim Plus and I can stop banging my head against the wall, right?!?!

 

BTW thank you for the docker

Link to comment
3 hours ago, ich777 said:

Can you please be a bit more specific? What does not work? What does the log say?

 

The container should work right OOB.


Sorry I figured it out, it was a problem with my port forwards. Had to sperate them out into multiple rules.

Follow up question though, how do I change the server name and password? I changed the admin password but I don't see a field to change the server name or non-admin password. 

Link to comment
5 minutes ago, demps said:

Follow up question though, how do I change the server name and password?

You should have a "Server" directory in your projectzomboid folder that lives in your appdata directory and there you should have a file called "server.ini" or something like that and there you can change the server name and other various settings.

 

Please keep in mind the container is not really different from a dedicated server running on bare metal, pretty every dedicated server guide (in terms for configuration) should be appropriate or at least get you through.

Link to comment
On 10/1/2021 at 12:11 PM, ich777 said:

Please try to stop the container, remove the Backup folder, start the container again and see if the backup archives are created properly...

 

Is it possible since the last update that the worlds where reset, I'm not too sure about that but I think I've read that somewhere...

Yea it might be the case.  The cache settings is set to yes.  When i browser the share i see everything no matter where it resides on cache or disk.  They should be identical.  Unless I am missing something about how unraid shares work.

 

image.thumb.png.03d00a7843f7e76f6383a29d712373e4.png

 

image.png.61f0dc24d572641de2b01be3f51a77e4.png

 

Either way we restored and continued our efforts on the Valheim server.  Just curious as to why i dont see more backups when the system is online 24/7.

Edited by TCMapes
Link to comment

I'm having problems updating my Valheim server, it doesn't seem to update and it just keeps saying incompatible version when I try to log on. I saw you said it took a couple of hours for some people but the update rolled out the 2nd of this month. Any thoughts what could cause this?

Link to comment
8 hours ago, ich777 said:

Is something broken again?

Maybe. Maybe just me.

 

Playing Valhiem. Want to give Plus a try. Set it to true for ValheimPlus. Restarted server. Updated config file. Installed the client. Client shows "Version 0.203.11 - Valheim plus 0.9.9" in bottom corner. 

 

Log on the server has "Peer 76561197966542871 has incompatible version, mine:0.203.11 remote 0.203.11@0.9.9"

 

This makes me think the server isn't loading ValhiemPlus

Link to comment
6 hours ago, Koen said:

I'm having problems updating my Valheim server, it doesn't seem to update and it just keeps saying incompatible version when I try to log on. I saw you said it took a couple of hours for some people but the update rolled out the 2nd of this month. Any thoughts what could cause this?

Have you restarted the server? It requires a restart to pick up the new update. 

Link to comment
8 hours ago, TCMapes said:

The cache settings is set to yes.

Can you also post a screenshot from your Docker template?

I think that's the issue.

Since the template uses /mnt/cache/appdata/... it writes it to another directory, I always recommend to set the share where the game files are on to "Only" or "Prefer".

Have you installed another cache that is called "cache"?

Link to comment
8 hours ago, Koen said:

I saw you said it took a couple of hours for some people but the update rolled out the 2nd of this month. Any thoughts what could cause this?

Actually no, what you can do is try to what @demps recommended and reboot the server.

Have you any blocking software installed like PiHole, AdGuard or similar somewhere in your network?

Link to comment
3 hours ago, sem1845 said:

This makes me think the server isn't loading ValhiemPlus

I've tried it now on a new installed instance and it works just fine:

grafik.thumb.png.573fea932f8d67601795d6869233adf0.png

 

I hope this screenshot makes sense to you... :D

As you can see from the game log it says: "Successfully synced VPlus configuration from server" (sorry for the cut off image).

Link to comment
26 minutes ago, Koen said:

I have tried to restart it yes, and also a whole system reboot, also I have removed the port forwarding to see if that works. I do not have any blocking software running and this hasn't been a problem with previous updates from valheim.

Maybe try to set VALIDATE to 'true' and wait for it to finish and then turn off validate again and see if this helps.

Link to comment
3 hours ago, ich777 said:

Maybe try to set VALIDATE to 'true' and wait for it to finish and then turn off validate again and see if this helps.

Thanks, but unfortunately that didn't work either. And whats weird is that my ark server was able to update no problems, also whe nI try to create a new server using the same steamcmd folder it doesn't work and when I try to create a fresh valheim server with a fresh steamcmd folder the steamcmd folder stays empty even after a couple of hours of waiting.

 

Link to comment
9 minutes ago, ich777 said:

Have you put your Steam credentials in the template?

If so, please delete it.

I hadn't no, now I have removed all the files it was using (steamcmd and valheim files) and I removed the container. I made a new container and it is doing something but not alot. I will keep it running through the night and I will update you tommorrow, for now thanks for the help.

  • Like 1
Link to comment
12 hours ago, Koen said:

I will keep it running through the night and I will update you tommorrow, for now thanks for the help.

This is really strange and should definetely not happen because you can updare other games.

Pleas check your config again, is enough space on the drive left?

Link to comment
11 hours ago, ich777 said:

This is really strange and should definetely not happen because you can updare other games.

Pleas check your config again, is enough space on the drive left?

It seems that ark already updated before valheim stopped working, I removed the steamcmd files etc. and now it is not downloading the right files at all anymore. This problem occured after I port forwarded my valheim server. I hadn't changed anything else since. Now I removed all my port forwarding to see if that helped but it didn't. Starting a fresh server downloads a couple of files but it stops everytime these files have been downloaded (gyazo images show files)

https://gyazo.com/9c21916f70907f53ac4cc8863f49ed20

https://gyazo.com/3494896da7c6e8abe5f2f752099f0447

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.