Jump to content
ich777

[Support] ich777 - Gameserver Dockers

2209 posts in this topic Last Reply

Recommended Posts

@Skoden If you want to play on lan you don't have to take any further steps but if you want to play over the internet or make it publicly available you have to take further steps (portforwarding, ddns or static ip from your isp,...).

Please read the minecraft dedicated server docs for portforwarding (this docker sets you up the dedicated server but all further steps like port forwarding are well documented on the forums).

Edited by ich777

Share this post


Link to post

@ich777I tried it again this morning. I put in 1.12.0.28, however when I go into minecraft it tells me it is on v1.11.4 I will attach a screengrab of the settings and then the pic in minecraft. I have another issue apparently where my docker.img is corrupt....(filling up logs) Ill fix that and see if that fixes this.

settings.PNG

IMG_9157.jpg

Share this post


Link to post
23 minutes ago, Skoden said:

@ich777I tried it again this morning. I put in 1.12.0.28, however when I go into minecraft it tells me it is on v1.11.4 I will attach a screengrab of the settings and then the pic in minecraft. I have another issue apparently where my docker.img is corrupt....(filling up logs) Ill fix that and see if that fixes this.

 

Can you post a picture from the docker log after startup?

Share this post


Link to post
1 hour ago, Skoden said:

Yeah. I fixed the docker.img issue and it is still kicking it to 1.11.4 

 

Youve got a [space] in front of the version number.

Share this post


Link to post

@ich777 I dont even know how I didnt see that. Thank you. In the future, when new versions come out, Ill have to go in there and update the settings right? or will it go on its own now?

Share this post


Link to post
12 hours ago, Skoden said:

@ich777 Also, If I do the reverse proxy or other method of getting outside, will this work like a realm? 

No not reverse proxy! Do only a simple port forwarding and that's it, no need for reverse proxy anything. Sorry but i can't tell if it works for a realm but i think so, it should all work like a normal dedicated server.

 

12 hours ago, Skoden said:

@ich777 I dont even know how I didnt see that. Thank you. In the future, when new versions come out, Ill have to go in there and update the settings right? or will it go on its own now?

No you must put in the server version manually.

Edited by ich777

Share this post


Link to post
On 9/3/2019 at 10:22 AM, ich777 said:

No not reverse proxy! Do only a simple port forwarding and that's it, no need for reverse proxy anything. Sorry but i can't tell if it works for a realm but i think so, it should all work like a normal dedicated server.

Why do a port forward instead of a reverse proxy? I use a Nginx Proxy Manager docker for my ombi and Nextcloud access...

Share this post


Link to post
1 hour ago, Skoden said:

Why do a port forward instead of a reverse proxy?

Because it's unlikely the game server talks http or https, which are primarily what a proxy does.

 

It's more complicated than that, but suffice it to say you will probably not have any success trying to use a proxy in front of a game server for the game control portion. If you play the game through a web browser as opposed to a dedicated game program, then yes, you may be able to use a proxy.

Share this post


Link to post

As @jonathanm said, you will have a hard time forwarding it through a nginx reverse proxy server. I don't see why anyone would do that, reverse proxy is primarly for http and https requests and not for game traffic.

 

Don't mind me asking a question @Skoden your proxy manager is also runnting in a docker? If yes you also mapped the port (80 and 443) in router directly to the container... With this container it's the same, also if you got any concerns, all my dockers run with a non root user so that an attack to the unraid server is nearly impossible (nothing is 100% save nowerdays). ;)

Share this post


Link to post

Has anyone gotten mods working on the Java minecraft docker, i have no issues getting the vanille server up but im at my wits end trying to get anything to happen with mods installed.

 

---Checking for 'runtime' folder---
---runtime folder found---
---Checking if Runtime is installed---
---Runtime found---
---Checking for Minecraft Server executable ---
---Minecraft Server executable found---
---Preparing Server---
---Checking for 'server.properties'---
---'server.properties' found...
---Checking for old logs---
---Starting Server---
---Waiting for logs, please stand by...---
[16:15:35] [Server thread/INFO]: Stopping server
[16:15:35] [Server thread/INFO]: Saving players
[16:15:35] [Server thread/INFO]: Saving worlds
[16:15:35] [Server thread/INFO]: Saving chunks for level 'world'/Overworld
[16:15:35] [Server thread/INFO]: Saving chunks for level 'world'/Nether
[16:15:35] [Server thread/INFO]: Saving chunks for level 'world'/The End
[16:15:35] [Server thread/INFO]: Saving chunks for level 'world'/Deep Dark
[16:15:35] [Server thread/INFO]: Saving chunks for level 'world'/ExtraUtils2_Quarry_Dim
[16:15:35] [Server thread/INFO]: Saving chunks for level 'world'/simplevoidworld
[16:15:35] [Server thread/INFO]: Saving chunks for level 'world'/MiningWorld



**Update**

I found something i was doing wrong with the instructions but now i just get a longer log file ending in the same thing.

Also I want to note I'm trying to install FTB 

Edited by slayerbrk

Share this post


Link to post
On 9/7/2019 at 3:18 AM, slayerbrk said:

Has anyone gotten mods working on the Java minecraft docker, i have no issues getting the vanille server up but im at my wits end trying to get anything to happen with mods installed.

 


---Checking for 'runtime' folder---
---runtime folder found---
---Checking if Runtime is installed---
---Runtime found---
---Checking for Minecraft Server executable ---
---Minecraft Server executable found---
---Preparing Server---
---Checking for 'server.properties'---
---'server.properties' found...
---Checking for old logs---
---Starting Server---
---Waiting for logs, please stand by...---
[16:15:35] [Server thread/INFO]: Stopping server
[16:15:35] [Server thread/INFO]: Saving players
[16:15:35] [Server thread/INFO]: Saving worlds
[16:15:35] [Server thread/INFO]: Saving chunks for level 'world'/Overworld
[16:15:35] [Server thread/INFO]: Saving chunks for level 'world'/Nether
[16:15:35] [Server thread/INFO]: Saving chunks for level 'world'/The End
[16:15:35] [Server thread/INFO]: Saving chunks for level 'world'/Deep Dark
[16:15:35] [Server thread/INFO]: Saving chunks for level 'world'/ExtraUtils2_Quarry_Dim
[16:15:35] [Server thread/INFO]: Saving chunks for level 'world'/simplevoidworld
[16:15:35] [Server thread/INFO]: Saving chunks for level 'world'/MiningWorld



**Update**

I found something i was doing wrong with the instructions but now i just get a longer log file ending in the same thing.

Also I want to note I'm trying to install FTB 

This is mostly a problem with FTB, i've given up running this kind of servers because they can also stop working randomly...

I run 2 Spigot servers and never got a problem.

 

The best thing you can do is you set the whole server up on windows and see if everything is working like you want it and then copy everything over to the unraid server.

Also a few post bevore in this thread is a post with a similar problem.

Edited by ich777

Share this post


Link to post
1 hour ago, ich777 said:

This is mostly a problem witg FTB, i've given up running this kind of servers because they can also stop working randomly...

I run 2 Spigot servers and never got a problem.

 

The best thjng you can do is you set the whole server up on windows and see if everything is working like you want it and then copy everything over to the unraid server.

Also a few post bevore in this thread is a post with a similar problem.

Sadly I had it running in windows before I dragged it over, guess I have to go learn how spigot works.

Share this post


Link to post
On 9/7/2019 at 9:29 AM, slayerbrk said:

Sadly I had it running in windows before I dragged it over, guess I have to go learn how spigot works.

Please note that some libraries or even a runtime change can destray a already running FTB server (i don't know if there are different libraries for windows and linux eventually that's the main problem i think) one little misconfiguration and the server won't start...

 

If you change to spigot it's way easier, no need to put the mods on the clients, they need only to run on the server.

Edited by ich777

Share this post


Link to post
7 hours ago, Newtious said:

hey.. not sure if its been asked.. but is there a way to host a "life is feudal - your own" server?

You've allready asked this question and i answered on post below.

 

Share this post


Link to post

I'm trying to spin up a Factorio server docker. I can't wait to get this going, but I've hit a snag. I anticipate this being a noob move, but I was trying to modify the settings.conf file with Notepad++ in Windows and am completely unable to save it. Even being an admin on my box, I can't change the permissions of that file or anything in the Factorio folder to allow my edits. It's how I typically adjust anything from NGINX to subdomains, this is the first time I've had a problem. Any help is appreciated. 

Share this post


Link to post

I'll let someone more knowledgeable answer this, but I just wanted to ask: Have you tried to SSH into server and edit the file with something like nano ?

Share this post


Link to post

Use nano or the config file edigor plugin

Sent via telekinesis

Share this post


Link to post
8 hours ago, Tergo247 said:

I'm trying to spin up a Factorio server docker. I can't wait to get this going, but I've hit a snag. I anticipate this being a noob move, but I was trying to modify the settings.conf file with Notepad++ in Windows and am completely unable to save it. Even being an admin on my box, I can't change the permissions of that file or anything in the Factorio folder to allow my edits. It's how I typically adjust anything from NGINX to subdomains, this is the first time I've had a problem. Any help is appreciated. 

As @Squid said try the CA Config Editor Link to support thread (you find it in the CA Apps) or you can like @Masterism said SSH to Unraid and edit the file with nano.

 

This is technicaly not my docker, i've only created the template for it to be available on Unraid (personally i run also a Factorio Docker and i edited the file with nano).

Edited by ich777

Share this post


Link to post

Thanks gents, I knew there must be a method outside of windows. I couldn't figure out nano, but the Config Editor worked like a champ. The more you know...

Share this post


Link to post

New question, I'm getting an unexpected character error with line 62, the one where admins are listed. I just put my steam username in the brackets, is that not the syntax?

Share this post


Link to post
5 hours ago, Tergo247 said:

New question, I'm getting an unexpected character error with line 62, the one where admins are listed. I just put my steam username in the brackets, is that not the syntax?

This is a game specific question and it should be asked on the factorio forums but i attched a screenshot of my config (i've configured mine only for lan play but it should be mostly the same.

 

Unbenannt.thumb.png.3d47fd2f91476987fafeb6b9519b181b.png

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.