[Support] ich777 - Gameserver Dockers


Recommended Posts

34 minutes ago, Ganster said:

 

Hmmmm interesting. How do you host on a VPN and make sure the ports are open?

The client pc was working over vpn and the V Rising server was being used normally with it's ports (9876-9877)open on the firewall.

Link to comment
6 hours ago, Newtious said:

but it will not change the name of the server..

You have to change the server name in the Docker template because the start parameters (that’s how I use the server name parameter from the template) override the files.

 

  • Like 1
Link to comment
4 hours ago, Bryo said:

So I just figured out if you pass "anonymous" as the steam user id it downloads the game with out having to buy it.

Yes, for the desicated server that‘s true but I need the game too, what if a user has an issue with it? The I have no way of debugging.  Anyways was about only a few Euros.

 

4 hours ago, Bryo said:

I first tried to create an alternate account but the alternate account didn't own the game so steamcmd just failed. I found an article, drat I closed the window but it showed the user passing "anonymous" and it worked in the container you built.

Why would you pass over your Steam credentials, if they are needed thay are marked with a red asterisk in my temlate and they are visible and not hidden under the Show more settings.

 

4 hours ago, Bryo said:

Also, all the properties would be in the file instead of the config. This way we only need one container possibly to run multiple servers instead of having multiple containers.

You don‘t need the sh file.

This sh file is basically the same is if you run multiple Docker containers all from the same directory.

 

Simply take the template from the CA app and set up your first server, after that click on the Add Container from the Docker tab at the bottom and choose your first Docker template again, then (this step is really important) change the name at the top to something different from the first server, change the ports in the Game Parameters Variabel, delete the two port entries and create new ones with the according ones that you‘ve changed in the Game Parameters and of course with the right protocol, change the server identifier and then click apply.


This will start a second instance from the container but from the same directory (I hope I haven‘t forgotten anything but I think you get the point).

 

The container was already created with this in mind.

 

The only thing that I would recommend to is, if you‘ve enabled autostart on all your containers that you delat the start from the first to the second about 60 seconds (or more) to give the first server the chance to pull a update if there os one.

Link to comment
5 hours ago, Mefesto said:

Apparently your server won't list on the master server list if your running a dedicated server AND your playing the game on the same network,.

Please don‘t give advice that‘s not correct.

 

What you are experiencing is that something seems wrong with your hair pin NAT, that‘s why you don‘t see the server on the Server List in game, but you should be able to connect to the game via Direct Connect and your local Unraid IP.

  • Upvote 1
Link to comment
4 hours ago, Ganster said:

Hmmmm interesting. How do you host on a VPN and make sure the ports are open?

See my post above this one.

 

This is theoretically possible when the VPN supports it and you use something like my OpenVPN-Client container in conjunction with the container that you want to route through.

Link to comment
26 minutes ago, ich777 said:

You have to change the server name in the Docker template because the start parameters (that’s how I use the server name parameter from the template) override the files.

 

I feel like an idiot..  I totally looked past that and never checked the docker for the server name..    thank you!

  • Like 1
Link to comment

Thanks @ich777 for another great docker, can I get your input on this small issue I'm getting?

 

Everything is working for the V Rising server, but it's not reading the server name correctly, it's being listed as "V Rising Docker" on the serverlist:

 

{
  "Name": "Project Rising",
  "Description": "Project.R Pandora",
  "Port": 9876,
  "QueryPort": 9877,
  "MaxConnectedUsers": 40,
  "MaxConnectedAdmins": 4,
  "ServerFps": 30,
  "SaveName": "Pandora",
  "Password": "########",
  "Secure": true,
  "ListOnMasterServer": true,
  "AutoSaveCount": 50,
  "AutoSaveInterval": 600,
  "GameSettingsPreset": "",
  "AdminOnlyDebugEvents": true,
  "DisableDebugEvents": false
}

 

It's reading everything else correctly, the description and password is coming up correctly in-game, but not the name. Any suggestions?

Link to comment
1 minute ago, Goldfire said:

Everything is working for the V Rising server, but it's not reading the server name correctly, it's being listed as "V Rising Docker" on the serverlist:

The same as for @Newtious, you have to specify the server name in the Docker container template because the start variables override the config file and that's what the server name in the template refers to.

Link to comment
Posted (edited)
18 minutes ago, ich777 said:

The same as for @Newtious, you have to specify the server name in the Docker container template because the start variables override the config file and that's what the server name in the template refers to.

 

This bit, right?

 

image.thumb.png.4e420c2d13e7d55ce57a9ec06f40cc42.png

 

I double checked that before making the post to save bothering you, I might redo the docker from scratch when I get a chance.

 

Edit: I redid the docker and it's working now, unsure why it hung on to the old server name. Sorry to bother and thanks again.

Edited by Goldfire
Link to comment
8 minutes ago, Goldfire said:

I double checked that before making the post to save bothering you, I might redo the docker from scratch when I get a chance.

This should be correct, but try it again, maybe the old name is cached somewhere, you can always go through the logs and see what name is in there.

  • Thanks 1
Link to comment
Posted (edited)

Hi all,

 

Trying to set up an ARK server but run into issues configuring it. Starting up with the default GameUserSettings.ini works fine, server can be joined remotely so ports are all good and everything.

 

However, changing minor things like a value in the GameUserSettings.ini makes the server reset it to default when the server is started. As an example, just leaving name and password blank in the docker container and adding them in the GameUserSettings.ini does not stick - it will start as ARK #12345 or similar default name.

 

When changing numeric values in GUS.ini, it seems like some stick, some get reset to default. Anyone encountered this before? Im out of ideas. Name and PW can obviously be set in docker config, thats fine - but other game related settings are important in the GUS.ini

 

Docker settings are pretty much default, attached.

 

Thank you for all the server dockers, I appreciate any help on this :) 

 

Screenshot 2022-05-21 at 10.39.12.png

Screenshot 2022-05-21 at 10.39.20.png

Edited by Blacksus
Link to comment

I need some education on how to edit game files for the Ark container. I added mods and made a few changes to the GameUserSettings.ini file however upon restart it seems to not save any of them. I've done some searching but have so far come up short. I don't really know what I'm searching for I guess.

Other relevant info, I'm using the ich777/steamcmd container on the current version, Ark works great, just all on default vanilla settings.

 

Thanks in advance

 

Link to comment
On 5/21/2022 at 11:42 AM, Blacksus said:

However, changing minor things like a value in the GameUserSettings.ini makes the server reset it to default when the server is started.

17 hours ago, Mortalic said:

I need some education on how to edit game files for the Ark container.

Have you stopped the container in the first place, edited the file and then started it back up again?

This is the first time I hear of a issue like this.

 

I'm not really into ARK but I can look into it.

 

Link to comment

Hello thanks for the amazing docker! so I set up my server and its up n running but im having an issue connecting to Rcon 

 

I havent changed anything from the default settings except added my own name to game.ini and added RconSettings.txt to the folder. 

 

Hopefully you can help me out

Untitled3.png.2b23da4dfe79b3c97b43ca9a885a2599.png

 

Kind Regards

Markus

Untitled.png

Untitled1.png

Untitled2.png

Link to comment
2 hours ago, trisse23 said:

I havent changed anything from the default settings except added my own name to game.ini and added RconSettings.txt to the folder. 

You also have to create a port mapping in the container.

 

Click on "Add another Path, Porta, Varaible, Label or Device" from the drop down select "Port" at container and host port enter your RCON port that you've set (in your case I think it's "9100") & make sure that it's the protocol is set to TCP, click on "Add" and "Apply".

 

Otherwise the port can't be reached.

Link to comment
23 minutes ago, ich777 said:

You also have to create a port mapping in the container.

 

Click on "Add another Path, Porta, Varaible, Label or Device" from the drop down select "Port" at container and host port enter your RCON port that you've set (in your case I think it's "9100") & make sure that it's the protocol is set to TCP, click on "Add" and "Apply".

 

Otherwise the port can't be reached.

Added the port as specified but still cant connect

 

Using rcon -H 172.17.0.4 -p 9100 -P 123123

failed to connecto to the given host/service

Untitled.png

Link to comment

Anybody else get the adminauth to work? I've tried putting my steam64 id (and all other formats) in the adminlist.txt files located at both

/save-data/Settings/adminlist.txt

and
 

/VRisingServer_Data/StreamingAssets/Settings/adminlist.txt


but nothing works, adminauth always fails.

Link to comment
6 minutes ago, Shane Israel said:

but nothing works, adminauth always fails.

The adminlist.txt works only from the directory ".../VRisingServer_Data/StreamingAssets/Settings/adminlist.txt".

I and also others on Discord that use my container can confirm that this is working (keep in mind, on a container update this file will be again be empty - this applies also if you have validation in the Docker template set to true).

 

I've already created an issue on GitHub for the devs to fix so that it works at the directory: ".../save-data/Settings/adminlist.txt" where it should need to work here: Click

Link to comment
2 minutes ago, ich777 said:

The adminlist.txt works only from the directory ".../VRisingServer_Data/StreamingAssets/Settings/adminlist.txt".

I and also others on Discord that use my container can confirm that this is working (keep in mind, on a container update this file will be again be empty - this applies also if you have validation in the Docker template set to true).

 

I've already created an issue on GitHub for the devs to fix so that it works at the directory: ".../save-data/Settings/adminlist.txt" where it should need to work here: Click


Okay quick question then. Do I need to restart the docker container after having put my Steam64 id in that file? I haven't tried that yet since there are currently people playing on the server. Somebody mentioned that you didn't need to.

Link to comment
21 minutes ago, trisse23 said:

Using rcon -H 172.17.0.4 -p 9100 -P 123123

failed to connecto to the given host/service

I have now installed the container and looking at the documentation you have created the file in the wrong folder: Click

 

I can connect to RCON but I actually don't can't test it if everything is working because I have to set up my VR and I don't want to anymore because it's almost midnight over here.

But what I can tell is that I don't get an error message like you do.

Link to comment

Hi, is there specific information on how to get conanexiles working?  I installed the docker with all default settings, I didn't change anything and in the logs it has a bunch of errors.  I don't think I got it to work and don't even know what the next steps would be if it was working.  Thanks.

Link to comment
29 minutes ago, ich777 said:

I have now installed the container and looking at the documentation you have created the file in the wrong folder: Click

 

I can connect to RCON but I actually don't can't test it if everything is working because I have to set up my VR and I don't want to anymore because it's almost midnight over here.

But what I can tell is that I don't get an error message like you do.

Thanks for everything I figured out the correct folder, I was going based on my docker experience. Thanks for everything its working now and great work!

 

Kind Regards

Markus

  • Like 1
Link to comment

Okay so I just tried restarting the container with my steam id in both adminlist.txt locations and the adminauth command still fails. I honestly have no idea what I could be doing wrong. This is what I have.
 

image.png.1e819d3bd67963d1ca550adf219c81ed.png

and in the other location

image.png.76cca047e5484ccee8714dec4284b114.png

Any other ideas? The docker container is even up-to-date.

Link to comment
On 5/20/2022 at 9:55 PM, ich777 said:

Yes, for the desicated server that‘s true but I need the game too, what if a user has an issue with it? The I have no way of debugging.  Anyways was about only a few Euros.

Good point!

On 5/20/2022 at 9:55 PM, ich777 said:

You don‘t need the sh file.

This sh file is basically the same is if you run multiple Docker containers all from the same directory.

 

Simply take the template from the CA app and set up your first server, after that click on the Add Container from the Docker tab at the bottom and choose your first Docker template again, then (this step is really important) change the name at the top to something different from the first server, change the ports in the Game Parameters Variabel, delete the two port entries and create new ones with the according ones that you‘ve changed in the Game Parameters and of course with the right protocol, change the server identifier and then click apply.


This will start a second instance from the container but from the same directory (I hope I haven‘t forgotten anything but I think you get the point).

 

The container was already created with this in mind.

 

The only thing that I would recommend to is, if you‘ve enabled autostart on all your containers that you delat the start from the first to the second about 60 seconds (or more) to give the first server the chance to pull a update if there os one.

Oh man, didn't realize I could do that, much easier! Appreciate you taking the time to explain.

  • Like 1
Link to comment
8 hours ago, Mogo said:

Hi, is there specific information on how to get conanexiles working?  I installed the docker with all default settings, I didn't change anything and in the logs it has a bunch of errors.  I don't think I got it to work and don't even know what the next steps would be if it was working.  Thanks.

I've tested the Container a few days ago and it worked perfectly fine.

The errors that you see on screen are usually caused by WINE but the container should run fine anyways.

 

Have you yet tried to connect to it via direct connection?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.