[Support] ich777 - Gameserver Dockers


Recommended Posts

8 hours ago, ich777 said:

@doguitar & @Marcel40625 looks like that this is an issue with the game itself: Click

 

Anyways, please update the container, I've pushed an update which should make it work again.

i am Fire_Fly :) on discord it says it should be fixed even on Linux ... will try your update

 

 

Edit: seems not fixed fully

(does not get stuck anymore)

(cant find the server in browser and buildin brower rcon not working), but i think there are bigger problems with the dedi server for linux from the game itself

Edited by Marcel40625
Link to comment
7 hours ago, ich777 said:

So evrything is working now for you, of course with a different servern name?

Yes indeed, all my buddies were able to connect last night with the new server name and have stopped and started the container a few times with no issues or delay on it appearing.

  • Like 1
Link to comment
1 hour ago, Dreygonx said:

Issues with Satisfactory server -

 

Seeing the below image in the logs

image.thumb.png.7791931978865d4f729bbe301ab41be2.png

I am able to reach https://api.epicgames.dev/sdk/v1/default?platformId=LNX, from a browser with no issues and nothing showing up odd in the firewall logs

 

3 other game servers running perfectly

2 conan and 1 Valheim. 

Satisfactory is using default ports

other servers have been moved to other ports with no issues.

 

unraid 6.10.2

 

looks more like a connection issue on your side, not realy a problem with the docker.

 

my server seems to run fine

Edited by Marcel40625
  • Thanks 1
Link to comment
10 minutes ago, Marcel40625 said:

looks more like a connection issue on your side, not realy a problem with the docker.

 

my server seems to run fine

And the only ports you are forwarding for Satisfactory are UDP 7777, 15777, and 15000 ?

Link to comment

After the Valheim update and after updating the container, all of my worlds are still down :(

 

We have 19 containers. All are throwing a segfault after the game and container was updated.

 

Connecting anonymously to Steam Public...OK
Waiting for client config...OK
Waiting for user info...OK
Update state (0x3) reconfiguring, progress: 0.00 (0 / 0)
Update state (0x61) downloading, progress: 9.97 (16872508 / 169315037)
Update state (0x61) downloading, progress: 61.41 (103971985 / 169315037)
Update state (0x81) verifying update, progress: 95.44 (161595153 / 169315037)
Success! App '896660' fully installed.
---Prepare Server---
---Found old save directory... Moving saves directory to new location...!---
Waiting for user info...OK
Update state (0x3) reconfiguring, progress: 0.00 (0 / 0)
Update state (0x61) downloading, progress: 9.97 (16872508 / 169315037)
Update state (0x61) downloading, progress: 61.41 (103971985 / 169315037)
Update state (0x81) verifying update, progress: 95.44 (161595153 / 169315037)
Success! App '896660' fully installed.
---Prepare Server---
---Found old save directory... Moving saves directory to new location...!---
---ValheimPlus enabled!---
---ValheimPlus Version Check---
---ValheimPlus not found, downloading and installing v0.9.9.8...---
---Successfully downloaded ValheimPlus v0.9.9.8---

 

 

Then it loops and keeps throwing:

 

---Update Check for Valheim enabled, running automatically every 60 minutes.---
/opt/scripts/start-server.sh: line 254: 77 Segmentation fault ${SERVER_DIR}/valheim_server.x86_64 -name "${SRV_NAME}" -port ${GAME_PORT} -world "${WORLD_NAME}" -password "${SRV_PWD}" -public ${PUBLIC} ${GAME_PARAMS} > /dev/null

 

After the first attempt, the worlds directory has been renamed to worlds_local, which tells me the container "patch" is working, but the game is still hosed.

 

-Brian

Edited by TheBrian
Link to comment
5 minutes ago, TheBrian said:
---Successfully downloaded ValheimPlus v0.9.9.8---

Since you are using Valheim Plus there is nothing I can do about, see this post please:

 

 

I think the last update to the game (not the container) messed up a lot of dedicated servers...

The only change to the container was to move the world files to the new location... ;)

Link to comment
Just now, TheBrian said:

Bummer.. this isn't a ValheimPlus issue either.  The problem exists with or without ValheimPlus enabled.  

Can't confirm that...

From my testing if I enable ValheimPlus the container doesn't starts and segfaults. When I disable ValheimPlus lthe container starts just fine.

Link to comment
2 minutes ago, ich777 said:

Can't confirm that...

From my testing if I enable ValheimPlus the container doesn't starts and segfaults. When I disable ValheimPlus lthe container starts just fine.


You're correct. My start scripts were forcing V+ to be installed again.  Thank you.  I guess we wait.

 

-Brian
 

  • Like 1
Link to comment
9 hours ago, ich777 said:

@doguitar & @Marcel40625 looks like that this is an issue with the game itself: Click

 

Anyways, please update the container, I've pushed an update which should make it work again.

 

I ended up fixing it late last night by copying over the contents of BepInEx from here. Apparently the V+ archive doesn't/didn't have the latest of BepInEx in it. It might be worthwhile to apply the BepInEx update routine after the V+ routine.

 

35 minutes ago, TheBrian said:

After the Valheim update and after updating the container, all of my worlds are still down :(

 

We have 19 containers. All are throwing a segfault after the game and container was updated.

 

Connecting anonymously to Steam Public...OK
Waiting for client config...OK
Waiting for user info...OK
Update state (0x3) reconfiguring, progress: 0.00 (0 / 0)
Update state (0x61) downloading, progress: 9.97 (16872508 / 169315037)
Update state (0x61) downloading, progress: 61.41 (103971985 / 169315037)
Update state (0x81) verifying update, progress: 95.44 (161595153 / 169315037)
Success! App '896660' fully installed.
---Prepare Server---
---Found old save directory... Moving saves directory to new location...!---
Waiting for user info...OK
Update state (0x3) reconfiguring, progress: 0.00 (0 / 0)
Update state (0x61) downloading, progress: 9.97 (16872508 / 169315037)
Update state (0x61) downloading, progress: 61.41 (103971985 / 169315037)
Update state (0x81) verifying update, progress: 95.44 (161595153 / 169315037)
Success! App '896660' fully installed.
---Prepare Server---
---Found old save directory... Moving saves directory to new location...!---
---ValheimPlus enabled!---
---ValheimPlus Version Check---
---ValheimPlus not found, downloading and installing v0.9.9.8...---
---Successfully downloaded ValheimPlus v0.9.9.8---

 

 

Then it loops and keeps throwing:

 

---Update Check for Valheim enabled, running automatically every 60 minutes.---
/opt/scripts/start-server.sh: line 254: 77 Segmentation fault ${SERVER_DIR}/valheim_server.x86_64 -name "${SRV_NAME}" -port ${GAME_PORT} -world "${WORLD_NAME}" -password "${SRV_PWD}" -public ${PUBLIC} ${GAME_PARAMS} > /dev/null

 

After the first attempt, the worlds directory has been renamed to worlds_local, which tells me the container "patch" is working, but the game is still hosed.

 

-Brian

 

Try the fix I mentioned above. I was getting segfaults as well before I fixed it.

  • Thanks 1
Link to comment
4 hours ago, doguitar said:

 

I ended up fixing it late last night by copying over the contents of BepInEx from here. Apparently the V+ archive doesn't/didn't have the latest of BepInEx in it. It might be worthwhile to apply the BepInEx update routine after the V+ routine.

 

 

Try the fix I mentioned above. I was getting segfaults as well before I fixed it.

 

I'll give it a shot, but the link you provided goes nowhere.  Some sort of AWS authentication attempt via Github...

 

I've been testing with this: https://valheim.thunderstore.io/package/denikson/BepInExPack_Valheim/

And the latest release for BepInEx's github which is very much behind...

Edited by TheBrian
Link to comment

The latest issues appears to be that BepInEx 5.4.1901 simply doesn't run on Linux.  All 19 containers are in an infinite loop with this error:


symbol lookup error: /serverdata/serverfiles/doorstop_libs/libdoorstop_x64.so: undefined symbol: dlopen
 

This version of BepInEx works fine on Windows clients and servers though.

Link to comment

For those that are having issues with this container and Valheim. 

I punted and gave this container a shot: https://hub.docker.com/r/lloesche/valheim-server

All is well now. This container runs all mods without issues.  I'm not sure why or how ICH777's container behaves differently, but it certainly does.  I suspect it's the BepInEx pack that is being automatically downloaded from Thunderstore (5.4.1901).  The container I linked above that works says "BepInEx.Preloader 5.4.19.0" in the logs.

Link to comment
4 hours ago, TheBrian said:

All is well now. This container runs all mods without issues.  I'm not sure why or how ICH777's container behaves differently, but it certainly does.  I suspect it's the BepInEx pack that is being automatically downloaded from Thunderstore (5.4.1901).  The container I linked above that works says "BepInEx.Preloader 5.4.19.0" in the logs.

Then simply disable Valheim+ and enable BepInEx in the container template.

 

Valheim+ is actually downlaoded from GitHub.

 

BepInEx is downloaded from Thunderstore that‘s correct but it isn‘t downloaded when Valheim+ is enabled because Valheim+ bundles his own version from BepInEx.

Valheim+ has to update his BepInEx version that is bundled, please also create a post on the issue tracker on GitHub, this will hopefully speed things up.

Link to comment
11 hours ago, ich777 said:

BepInEx is downloaded from Thunderstore that‘s correct but it isn‘t downloaded when Valheim+ is enabled because Valheim+ bundles his own version from BepInEx.

Valheim+ has to update his BepInEx version that is bundled, please also create a post on the issue tracker on GitHub, this will hopefully speed things up.

I mentioned it earlier when I mentioned that I fixed my installation by updating BepInEx separately but is there any reason not to download the BepInEx package from github in both modes (and after V+)?


It seems like this course of events will happen everything BIE needs an update because V+ will lag behind so the auto update feature will lag behind and I'll end up doing it manually, defeating the purpose of the feature.

Link to comment
11 hours ago, ich777 said:

Then simply disable Valheim+ and enable BepInEx in the container template.

 

Valheim+ is actually downlaoded from GitHub.

 

BepInEx is downloaded from Thunderstore that‘s correct but it isn‘t downloaded when Valheim+ is enabled because Valheim+ bundles his own version from BepInEx.

Valheim+ has to update his BepInEx version that is bundled, please also create a post on the issue tracker on GitHub, this will hopefully speed things up.

I did this.  Your container downloads and installs BepInEx, but infinite loops and never starts with the error:
symbol lookup error: /serverdata/serverfiles/doorstop_libs/libdoorstop_x64.so: undefined symbol: dlopen

 

This is a vanilla/fresh container with only BepInEx enabled.  It never starts.

Link to comment
1 hour ago, doguitar said:

I mentioned it earlier when I mentioned that I fixed my installation by updating BepInEx separately but is there any reason not to download the BepInEx package from github in both modes (and after V+)?

45 minutes ago, TheBrian said:

I did this.  Your container downloads and installs BepInEx, but infinite loops and never starts with the error:
symbol lookup error: /serverdata/serverfiles/doorstop_libs/libdoorstop_x64.so: undefined symbol: dlopen

I think I will remove BepInEx and Valheim+ from my container in the future because this causes only headaches for me...

 

That's why I usually don't support Modding in my containers and provide only the base functionality.

Link to comment
14 minutes ago, ich777 said:

I think I will remove BepInEx and Valheim+ from my container in the future because this causes only headaches for me...

 

That's why I usually don't support Modding in my containers and provide only the base functionality.

Understood.  V+ is a joke of assumptions and dependencies.  BepInEx is critical though. 

 

I'll say, I'm nearing punting on everyone's containers and spinning my own because of this.  I agree with you, the containers should allow for modding, but not have assumption built-in.

Link to comment
1 hour ago, ich777 said:

I think I will remove BepInEx and Valheim+ from my container in the future because this causes only headaches for me...

 

Not a terrible idea. With the script hooks you have I could write a similar routine and it wouldn't be for you to maintain which is probably how it should be.

Link to comment

Ah, I see this might not be the best time to ask this but...

The container for Terraria-tModloader seems to have an issue with the WebUI, I can't connect to it.

I've tried to change the ports around and even setting the network type to host (and back after it still didn't work).

 

Also, regarding the Valheim container...

I absolutely rely on Valheim+ since it improves the game by several magnitudes. The QoL it adds is off the charts!

V+ have an option to download without BepInEx, you can grab only the ValheimPlus.dll (which is the entire mod) from their GitHub.

Link to comment

Firstly I would like to thank you for your amazing contributions @ich777!

 

I'm here to humbly request a Stormworks: Build and Rescue container please. I recall seeing one in the apps some time ago but it has seemingly disappeared (or I'm mistaken).

 

I did attempt to fork from your containers that use WINE for Windows only binaries, however modifying containers is unfortunately a bit beyond me at this stage.

 

If it's not too much to ask, when you have a moment to spare would you please help a meere mortal by publishing the above container please?

 

App ID for SteamCMD is 1247090

Login can be anonymous

Default ports are UDP 25564 - 25566

Server binary name is server64.exe

 

One slight complication MAY be that Visual C++ Redistributable 2013 is required, otherwise I'm not sure how WINE handles such things.

 

Many thanks in advance and hope others will also appreciate this contribution 😊

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.