[Support] ich777 - Gameserver Dockers


Recommended Posts

14 hours ago, John2222 said:

Yeah i understand. No worries. RL is most important.

Still no dice with the latest version:

10:55:17 MovesType CfgMovesMaleSdr load time 4680.0 ms
10:55:17 BattlEye Server: Initialized (v1.217)
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init(): Sys_LoadModule failed to load: steamclient.so
[S_API FAIL] SteamAPI_Init() failed
10:55:17 Initializing Steam server failed
Arma 3 Console version 2.08.149723 x86 : port 2302
10:55:17 Host identity created.

 

Maybe you can ask where the steamclient.so has to be located and from where it needs to be copied over, I copy it over from the steamcmd/linux32 directory to the main directory.

 

 

However the 64bit version is working fine:

10:56:55 MovesType CfgMovesMaleSdr load time 3365.0 ms
10:56:55 BattlEye Server: Initialized (v1.217)
CAppInfoCacheReadFromDiskThread took 1 milliseconds to initialize
CApplicationManagerPopulateThread took 0 milliseconds to initialize (will have waited on CAppInfoCacheReadFromDiskThread)
RecordSteamInterfaceCreation (PID 333): SteamGameServer012 / GameServer
RecordSteamInterfaceCreation (PID 333): SteamUtils009 / Utils
Setting breakpad minidump AppID = 107410
10:56:55 Game Port: 2302, Steam Query Port: 2303
10:56:55 Initializing Steam server - Game Port: 2302, Steam Query Port: 2303
RecordSteamInterfaceCreation (PID 333): SteamGameServer012 / GameServer
RecordSteamInterfaceCreation (PID 333): SteamUtils009 / Utils
RecordSteamInterfaceCreation (PID 333): SteamNetworking005 / Networking
RecordSteamInterfaceCreation (PID 333): SteamGameServerStats001 / GameServerStats
RecordSteamInterfaceCreation (PID 333): STEAMHTTP_INTERFACE_VERSION002 / HTTP
RecordSteamInterfaceCreation (PID 333): STEAMINVENTORY_INTERFACE_V002 / Inventory
RecordSteamInterfaceCreation (PID 333): STEAMUGC_INTERFACE_VERSION010 / UGC
RecordSteamInterfaceCreation (PID 333): STEAMAPPS_INTERFACE_VERSION008 / Apps
Arma 3 Console version 2.08.149723 x64 : port 2302
10:56:55 Host identity created.
10:56:55 Connected to Steam servers

 

Link to comment
48 minutes ago, ich777 said:

Still no dice with the latest version:

10:55:17 MovesType CfgMovesMaleSdr load time 4680.0 ms
10:55:17 BattlEye Server: Initialized (v1.217)
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init(): Sys_LoadModule failed to load: steamclient.so
[S_API FAIL] SteamAPI_Init() failed
10:55:17 Initializing Steam server failed
Arma 3 Console version 2.08.149723 x86 : port 2302
10:55:17 Host identity created.

 

Maybe you can ask where the steamclient.so has to be located and from where it needs to be copied over, I copy it over from the steamcmd/linux32 directory to the main directory.

 

 

However the 64bit version is working fine:

10:56:55 MovesType CfgMovesMaleSdr load time 3365.0 ms
10:56:55 BattlEye Server: Initialized (v1.217)
CAppInfoCacheReadFromDiskThread took 1 milliseconds to initialize
CApplicationManagerPopulateThread took 0 milliseconds to initialize (will have waited on CAppInfoCacheReadFromDiskThread)
RecordSteamInterfaceCreation (PID 333): SteamGameServer012 / GameServer
RecordSteamInterfaceCreation (PID 333): SteamUtils009 / Utils
Setting breakpad minidump AppID = 107410
10:56:55 Game Port: 2302, Steam Query Port: 2303
10:56:55 Initializing Steam server - Game Port: 2302, Steam Query Port: 2303
RecordSteamInterfaceCreation (PID 333): SteamGameServer012 / GameServer
RecordSteamInterfaceCreation (PID 333): SteamUtils009 / Utils
RecordSteamInterfaceCreation (PID 333): SteamNetworking005 / Networking
RecordSteamInterfaceCreation (PID 333): SteamGameServerStats001 / GameServerStats
RecordSteamInterfaceCreation (PID 333): STEAMHTTP_INTERFACE_VERSION002 / HTTP
RecordSteamInterfaceCreation (PID 333): STEAMINVENTORY_INTERFACE_V002 / Inventory
RecordSteamInterfaceCreation (PID 333): STEAMUGC_INTERFACE_VERSION010 / UGC
RecordSteamInterfaceCreation (PID 333): STEAMAPPS_INTERFACE_VERSION008 / Apps
Arma 3 Console version 2.08.149723 x64 : port 2302
10:56:55 Host identity created.
10:56:55 Connected to Steam servers

 

Hi,

 

some suggestions from the discord:

* Use the steamclient.so that is shipped with the arma directory (no copying over from the steamcmd folder). Someone use this (version from 2020) and said it work with 32bit version.
* rights problem or steamclient.so is not flagged as executable
 

In general he said, that the steamclient.so has to be right next to be the arma executable. no special folder is needed.

 

Greetings

Edited by John2222
Link to comment
18 minutes ago, John2222 said:

* Use the steamclient.so that is shipped with the arma directory (no copying over from the steamcmd folder). Someone use this (version from 2020) and said it work with 32bit version.

Already tried.

 

18 minutes ago, John2222 said:

* rights problem or steamclient.so is not flagged as executable

Permissions are set to 770 and to the corresponding user.

 

19 minutes ago, John2222 said:

In general he said, that the steamclient.so has to be right next to be the arma executable. no special folder is needed.

By default it is but it doesn't work, will investigate further.

It's kind of funny because the current version works on both 32bit and 64bit with my container but the beta branch doesn't... :D

 

So from my side it seems that something else in terms of the application or the way how ArmA3 works must have changed but if they say it's an issue from the container I must be missing something...

Link to comment
7 hours ago, ich777 said:

Already tried.

 

Permissions are set to 770 and to the corresponding user.

 

By default it is but it doesn't work, will investigate further.

It's kind of funny because the current version works on both 32bit and 64bit with my container but the beta branch doesn't... :D

 

So from my side it seems that something else in terms of the application or the way how ArmA3 works must have changed but if they say it's an issue from the container I must be missing something...

Maybe some 32bit libraries are missing?

Yeah it is interresting. But if we can fix it in advance, then maybe on the next normal update it would be running out of the box.

Edited by John2222
Link to comment
8 hours ago, ich777 said:

Already tried.

 

Permissions are set to 770 and to the corresponding user.

 

By default it is but it doesn't work, will investigate further.

It's kind of funny because the current version works on both 32bit and 64bit with my container but the beta branch doesn't... :D

 

So from my side it seems that something else in terms of the application or the way how ArmA3 works must have changed but if they say it's an issue from the container I must be missing something...

On the discord there are some one that can reproduce this problem. This seems not an issue from your docker. We will see.

  • Thanks 1
Link to comment
8 minutes ago, John2222 said:

On the discord there are some one that can reproduce this problem. This seems not an issue from your docker. We will see.

Jup, I think they are missing something. Nothing has changed in my container.

 

If you know somehing let me know.

  • Like 1
Link to comment
3 hours ago, Duckers said:

Vrsising server just randomly decided to stop itself? Was in the middle of a grind, and then the container just decided to stop itself.

Never experienced anything like that.


Does it really stop or does it restart?

Link to comment
11 hours ago, ich777 said:

Jup, I think they are missing something. Nothing has changed in my container.

 

If you know somehing let me know.

Good news. The devs have found the issue. It was (as i understand) a using of RUNPATH instead of RPATH. They posted a hotfix but there will be next week shipped a fixed version anyhow. So It would say let's wait till next week. :)

Link to comment
14 minutes ago, John2222 said:

Good news. The devs have found the issue. It was (as i understand) a using of RUNPATH instead of RPATH. They posted a hotfix but there will be next week shipped a fixed version anyhow. So It would say let's wait till next week. :)

Please keep me updated when the new version is released so that I can test it on my own, I think/hope it should work with the existing container as it is currently implemented.

  • Like 1
Link to comment
On 7/21/2022 at 5:41 AM, ich777 said:

This container is not created by me nor is it supported by me and so you are basically in the wrong support thread.

 

@fiR3W4LL is the maintainer of that template, but he dosn't have a support thread here? May I ask why @fiR3W4LL?

Hi @ich777
Good question
I have not yet dealt with this topic and thought that if there are problems, you can also write to me.
Otherwise, I will take care of getting my own support thread.

Link to comment
4 hours ago, fiR3W4LL said:

Otherwise, I will take care of getting my own support thread.

I think it would be better that there is a dedicated support thread and that it is linked in the CA App and in the Docker too.

Link to comment

Hi. I have unreliable power at my house and when the power goes out, the server comes back up before the internet does. In that scenario, my Minecraft server doesn't start up. When it can't reach the download servers for the latest version, it tries to fallback to a specific old version of Minecraft and when it can't download that either, it gives up on starting altogether.

In that case I think it should start with whichever version is currently installed. Here are the logs from the startup:
 

---Starting...---
---Trying to get latest version from Minecraft Bedrock Edition from alternative source---

---Can't get latest version from Minecraft Bedrock falling back to v 1.16.20.03---

---Version missmatch Installed: v1.19.11.01 - Prefered:1.16.20.03, downloading v1.16.20.03---

---Something went wrong, can't download Minecraft Bedrock Edition, putting server in sleep mode---

 

Link to comment
5 hours ago, MrGr8 said:

When it can't reach the download servers for the latest version, it tries to fallback to a specific old version of Minecraft and when it can't download that either, it gives up on starting altogether.

It should do that but it seems like that something went wrong at the version detection first, I will look into this ASAP.

 

What you can also do is to set a Docker start up delay.

Link to comment
5 hours ago, maereax said:

How do i manually set the version for your minecraft server?

 

I'd like the server to remain on 1.19.1 indefinitely rather than updating every time it starts up

Minecraft Java or Minecraft Bedrock edition?

Link to comment

i see and understand, Tmod loader seems to be patched or updated like every month so i understand how that would be annoying. In that case, is there a way through unraid (ive just recently started using it) to use like external github sources, then maybe i could find a github source for calamity or such

 

Link to comment
31 minutes ago, RightKnee said:

i see and understand, Tmod loader seems to be patched or updated like every month so i understand how that would be annoying.

The updates wouldn't be the issue... The way the updates are handled are the issue. They changed the archive file name now 3 times and the file structure inside the archive file too and they changed multiple times how tmodloader is working and this should have broken installations for people that are not using my container too.

 

33 minutes ago, RightKnee said:

to use like external github sources, then maybe i could find a github source for calamity or such

I would rather search on DockerHub then on GitHub.

You can install almost everything from DockerHub on Unraid:

 

Link to comment
On 7/27/2022 at 9:28 AM, ich777 said:

Please keep me updated when the new version is released so that I can test it on my own, I think/hope it should work with the existing container as it is currently implemented.

Surprisingly a new arma 3 profiling branch executable was released today. First users reported that it worked.

Edited by John2222
Link to comment
5 hours ago, maereax said:

Java, MinecraftBasicServer

That's actually pretty easy, let it pull the latest version and then change the game version to custom and make sure that the jar file in the main directory for the container is in there and named "server.jar", if you wan't to switch over to another version simply download the according server .jar file and name it "server.jar" and put it in the main directory by replacing the existing one.

image.thumb.png.4f89d4b62fed86e1a0f6409415fe091d.png

 

You can of course name it differently but then you have to change the Serverfile name in the Docker template eg: if you name the file "mycoolminecraftserver.jar" you have to change the Serverfile name in the template to "mycoolminecraftserver".

 

 

Hope that helps.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.