[Support] ich777 - Gameserver Dockers


Recommended Posts

20 hours ago, ich777 said:

Because the Linux server is only available for experimental or did it already made it to the stable branch?

Honestly have no idea, I wasn't even aware it only supported Windows OS for server hosting until recently. I really hope it is on stable now for Linux as that would be amazing! Been waiting for something like that for a very long time.

Edited by Sporical
Link to comment

Does anyone know how to use the dayz server with mods.
I copied the mods in the main directory and copied the key files in the keys folder.

1691456990_Screenshot2022-08-01104345.thumb.png.23971e8d3b1e673b93b90a91f30b69d3.png
But unfortunately after starting the server no folder is created where the files to configure the plugins are.
I am not quite sure if I have entered the variable here correctly or if it must be done differently.

259764108_Screenshot2022-08-01104042.thumb.png.cadd288ac6a54d5f00d5eac181cd91a8.png

 

Edited by BuTscH
Link to comment
9 hours ago, BuTscH said:

But unfortunately after starting the server no folder is created where the files to configure the plugins are.
I am not quite sure if I have entered the variable here correctly or if it must be done differently.

If it's the same as for ArmA3 you have to do it like:

-mod=@CF;@VPPAdminTools

 

But keep in mind I'm not an expert when it comes to modding...

  • Thanks 1
Link to comment

I have tried it with

29 minutes ago, ich777 said:
-mod=@CF;@VPPAdminTools


I think it is the same as in arma.

Under windows works so at least.
The client also detects that mods are on the server.

1559495509_Screenshot2022-08-01205337.png.2132b817272fd31b56990aead51af1bc.png
But the server doesn't seem to load them correctly.

Link to comment
1 hour ago, BuTscH said:

hmm that's a good question I did not know that it plays a role ^^

I can only tell you that on ArmA3 not all mods work on Linux and since DayZ is from the same publisher it is most likely the case…

 

Also keep in mind that this game was only available for Windows for a long time.

  • Thanks 1
Link to comment
On 7/28/2022 at 1:15 AM, MrGr8 said:

In that case I think it should start with whichever version is currently installed. Here are the logs from the startup:

Sorry that it took so long, pushed now an update where it always falls back to the installed version if the latest version or your preferred version can't be fetched.

  • Upvote 1
Link to comment

Can anyone help me? I am having issues getting my Ark server running. I got it visible to join but it keeps giving timed out errors and now I am losing my mind trying to get it working and the log file is completely useless to the point I hope I am looking at the wrong log (ark-se\ShooterGame\Saved\Logs). Also how can I disable Battle Eye, I tried using the arguments but Battle Eye is still on so apparently I am using the wrong arguments. 

Thank you for your time. 

Edit. No one helped me but I did figure it out. I had to change docker from using a bridged connection to using br0 custom connection with its own IP address and now it can bee seen and can be logged into. 

Edited by killam97
i figured out the issue and want to leave an update incase anyone has this issue in the future and finds my comment.
Link to comment

Hey, so a buddy and I are having an issue with setting up 7 Days to Die and importing a local multiplayer save to the docker. We're both extremely new to all this, so apologies if the information is vague or confusing. 

 

Started up the docker to download all the necessary files. Shut it off to make changes to the XML files. After I copy my save info from my local machine to the XML file and turn the docker back on, the XML file reverts back to default settings. 

Link to comment
3 hours ago, itsbandrix said:

Started up the docker to download all the necessary files. Shut it off to make changes to the XML files. After I copy my save info from my local machine to the XML file and turn the docker back on, the XML file reverts back to default settings. 

Have you changed any of the settings in the template or better speaking did you turn on validation?

 

I would recommend to give the xml another file name that already exists in there and change the name for the xml in the template too, with this way you are making sure that the file doesn't get overwritten.

 

Anyways, I would also recommend that you join @Spectral Force's Discord over her, he helps me out with 7DtD: Click

Link to comment
19 hours ago, itsbandrix said:

Hey, so a buddy and I are having an issue with setting up 7 Days to Die and importing a local multiplayer save to the docker. We're both extremely new to all this, so apologies if the information is vague or confusing. 

 

Started up the docker to download all the necessary files. Shut it off to make changes to the XML files. After I copy my save info from my local machine to the XML file and turn the docker back on, the XML file reverts back to default settings. 

Come to my discord, role yourself, add unraid role & theres an unraid channel. I can provide help there.

  • Like 1
Link to comment

Anyone here use Forge with Minecraft? I ask because since 1.18 Forge changed how it executes and I can’t seem to get it working as the docker requires a .jar file to be run from the main directory. (Forge now executes with a script.) I’d like to update my server to 1.19 but am currently stuck on 1.16.x. Any ideas would be appreciated. 

Link to comment
30 minutes ago, thunderclap said:

Anyone here use Forge with Minecraft? I ask because since 1.18 Forge changed how it executes and I can’t seem to get it working as the docker requires a .jar file to be run from the main directory. (Forge now executes with a script.) I’d like to update my server to 1.19 but am currently stuck on 1.16.x. Any ideas would be appreciated. 

I think this issue will give you a clue on how to do that, can't really help because I don't run Forge.

 

Add a variable with the Key: JVM_CUSTOM_COMMAND and as the Value type in your script and whatever needs to appended like:

-jar YOURJAR.jar nogui

 

 

Please note that you maybe also need to change the Java version...

  • Thanks 1
Link to comment
10 hours ago, ich777 said:

I think this issue will give you a clue on how to do that, can't really help because I don't run Forge.

 

Add a variable with the Key: JVM_CUSTOM_COMMAND and as the Value type in your script and whatever needs to appended like:

-jar YOURJAR.jar nogui

 

 

Please note that you maybe also need to change the Java version...

Does it have to be a .jar file, or can it be the .sh script Forge wants to use?

 

And speaking games, Terraria... it looks like you may not support it any more due to their constant changes -- or maybe it was a launcher or mod or something -- but I was running the vanilla version and can no longer update. Am I correct you no longer support Terraria?

Link to comment
2 hours ago, thunderclap said:

Does it have to be a .jar file, or can it be the .sh script Forge wants to use?

I think that it has to be a jar file, but try to open the sh file and use the command that's in there or post the command that's in there here and I try to form it into something you can use in the container.

 

2 hours ago, thunderclap said:

Am I correct you no longer support Terraria?

I dropped support for TModloader but not for Terraria, can you give me a bit more insight, what version are you trying to download so that I can try it on my own.

Link to comment
30 minutes ago, ich777 said:

I think that it has to be a jar file, but try to open the sh file and use the command that's in there or post the command that's in there here and I try to form it into something you can use in the container.

 

I dropped support for TModloader but not for Terraria, can you give me a bit more insight, what version are you trying to download so that I can try it on my own.

I'll give that a try with Minecraft. As for Terraria the current version in docker is 1.4.3.2 but the most current version is 1.4.3.6.

Link to comment
20 minutes ago, thunderclap said:

As for Terraria the current version in docker is 1.4.3.2 but the most current version is 1.4.3.6.

Have you yet changed the version number in the template?

I will try this tomorrow and report back.

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.