[Support] ich777 - Gameserver Dockers


3014 posts in this topic Last Reply

Recommended Posts

2 hours ago, HellraiserOSU said:

I might just destroy data and start again. See if that works and just forget about the old database.

If that's an option for you it would be great...

 

Please note, I've made some minor changes and the docker rebuilds now will be available in the next 30 minutes. But should have no effect if you already created it new.

Link to post
  • Replies 3k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Summary: Support Thread for ich777 Gameserver Dockers (CounterStrike: Source & ConterStrike: GO, TeamFortress 2, ArmA III,... - complete list in the second post) Application: SteamCMD Do

Dockers Available so far:   SteamCMD DedicatedServers: CounterStrike: Source CounterStrike: Global Offensive TeamFortress 2 ArmA3 - requested by @MrSage D

Just thought I'd share my experience setting up a Valheim server with this docker app from @ich777(thank you!)   You don't need to worry about Steam authentication for Valheim, the default a

Posted Images

5 hours ago, 702Pilgrim said:

I've been searching and trying but I cannot find a solution for the Arma 3 server docker how to install mods?

Under the GAME_PARAMS: -mod=  What do I put here?

 

Depending on your mod you must enter the path and extra parameters.

The path to the main director inside the docker is relative path: '<modfolder>' or the absolute path: '/serverdata/serverfiles/<modfolder>' after that you must enter the folder name or where you put your mods.

Look here underMmodifications: *LINK*

Link to post
53 minutes ago, Pede said:

Hi again.

 

It makes this error when im trying to install the server: image.png.b0d7575ae870d506c5a5474f65165bc5.png

 

Do i have to own the game on the account that i uses to install steamservers?

Please don't use a username or password if there is no required mark in the template.

For this docker leave the username and password empty. ;)

Link to post
19 minutes ago, allanp81 said:

Did you get this working? I'm really struggling.

Yes otherwise it wouldn't be in the list.

What exactly?

Did you forward the ports properly? Also this game needs to be reachable from outside otherwise it won't work.

Link to post

No problem here, you must provide a steam username where steamguard is disabled (i recommend you to create a new account for this and your gameserver - this account don't have to had the game in the library) - you must provide a username and password for this to download.

 

I actually tried it to download it from the CA App and everything works fine also attached the log, please ignore the error on the end of the log, i don't have my firewall setup correctly for this game.

 

Log.txt

Link to post
3 minutes ago, allanp81 said:

I kinda guessed that, but I couldn't figure out the docker run command as it fails when I try.

Did you install it through Unraid?

What error message did you get?

Are there any port conflicts with other containers?


In Unraid it looks like this:

 

docker run -d --name='AssettoCorsa' --net='bridge' --log-opt max-size='50m' --log-opt max-file='1' -e TZ="Europe/Berlin" -e HOST_OS="Unraid" -e 'GAME_ID'='302550' -e 'USERNAME'='steamusername' -e 'VALIDATE'='' -e 'PASSWRD'='yoursupersecretpassword' -e 'UID'='99' -e 'GID'='100' -p '9600:9600/tcp' -p '9600:9600/udp' -p '8081:8081/tcp' -v '/mnt/user/appdata/steamcmd':'/serverdata/steamcmd':'rw' -v '/mnt/user/appdata/assettocorsa':'/serverdata/serverfiles':'rw' --restart=unless-stopped 'ich777/steamcmd:assettocorsa'

Edited by ich777
Link to post
15 hours ago, Mantiphex said:

Hi Ich777, firstly let me say a big thank you for all your work on the docker game servers. I wanted to ask if you have a list of upcoming dockers or a facility by which one could be requested?

 

Hello, I've got no list of upcoming gameservers because i don't plan them, just request it and i will look into it. You could request all gameservers if there is a linux version of the game or better a dedicated server version for linux, I've also made some windows games but this is possible through WINE but this gameservers with WINE will consume a fair ammount of your system resources since it is not linux native.

Hope this helps

 

1 hour ago, Braxhn said:

Hello! Would it be possible to make LFS (Live for Speed) a docker? I'd be forever greatful! 

Thanks for all your work! 

I will look into it, it's maybe possible through WINE but i can not guarantee that it works.

Link to post

Hi, we are currently having an issue with the dockers accepting outside connections. The unraid server is able to connect to the internet and accepts remote connections, and we can connect to the docker servers (minecraft and terraria) via lan ip, but we cannot seem to connect at all to the game dockers via internet connection/ip. We have port forwarded with no change. We've put quite a few hours into trying to find someone with a simlar issue and/or solution, but we cant seem to find what the issue is.

Link to post
5 hours ago, frostmcloud said:

Hi, we are currently having an issue with the dockers accepting outside connections. The unraid server is able to connect to the internet and accepts remote connections, and we can connect to the docker servers (minecraft and terraria) via lan ip, but we cannot seem to connect at all to the game dockers via internet connection/ip. We have port forwarded with no change. We've put quite a few hours into trying to find someone with a simlar issue and/or solution, but we cant seem to find what the issue is.

Can you post a few pictures of the configuration within unraid also the server configuration files, wich router/firewall did you use?

Wich minecraft container? Bedrock or java?

Did you setup any vlans in unraid?

 

If it's sensitive data you can also send me a PM.

Link to post
On 5/9/2019 at 1:35 AM, ich777 said:

Please read this post Link

He describes that the server must conmect to the internet and show properly up in the list to show on the lan list.

Edit: But i think if the server need's to register at the Steam master server just forward the port 27015 UDP in your router to your Unraid server IP.

 

I will take a look into that.

Hi!

 

I'm having the "unable to query server for invite" problem again.  I think it may have started when I tried to install your CS:GO docker and didn't realize the ports were the same, but I can't be sure.  I also tried editing the steamcmd folder for Ark to a new one, but that hasn't worked.  The server shows up in steam if I favorite it, but no other way, and it says the version is 298.41, while my clients are all on 301.  There appear to be update-related errors in the logs:

 

---Setting umask to 000---
SteamCMD not found!
steamcmd.sh
linux32/steamcmd
linux32/steamerrorreporter
linux32/libstdc++.so.6
linux32/crashhandler.so
---Update SteamCMD---
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[ 0%] Checking for available update...
[----] Downloading update (0 of 50328 KB)...
[ 0%] Downloading update (810 of 50328 KB)...
~~~~
[ 99%] Downloading update (50328 of 50328 KB)...
[100%] Download Complete.
[----] Applying update...
[----] Extracting package...
[----] Extracting package...
[----] Extracting package...
[----] Extracting package...
[----] Installing update...
[----] Installing update...
[----] Installing update...
[----] Installing update...
[----] Installing update...
[----] Installing update...
[----] Installing update...
[----] Installing update...
[----] Cleaning up...
[----] Update complete, launching...
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
[ 0%] Downloading update...
[ 0%] Checking for available updates...
[----] Download complete.
[----] Extracting package...
[----] Extracting package...
[----] Extracting package...
[----] Extracting package...
[----] Installing update...
[----] Installing update...
[----] Installing update...
[----] Installing update...
[----] Installing update...
[----] Installing update...
[----] Installing update...
[----] Installing update...
[----] Cleaning up...
[----] Update complete, launching Steamcmd...
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
Logging in user '****' to Steam Public ...
Logged in OK
Waiting for user info...OK
---Update Server---
---Validating installation---
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
Logging in user '****' to Steam Public ...
Logged in OK
Waiting for user info...OK
Update state (0x0) : Timed out waiting for update to start, bailing.
Error! App '376030' state is 0x204 after update job.
---Prepare Server---
---Server ready---
---Start Server---
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Setting breakpad minidump AppID = 346110

Any ideas?  Thanks for all the help, and the great dockers!

 

--P

Link to post
6 hours ago, pengrus said:

Hi!

 

I'm having the "unable to query server for invite" problem again.  I think it may have started when I tried to install your CS:GO docker and didn't realize the ports were the same, but I can't be sure.  I also tried editing the steamcmd folder for Ark to a new one, but that hasn't worked.  The server shows up in steam if I favorite it, but no other way, and it says the version is 298.41, while my clients are all on 301.  There appear to be update-related errors in the logs:

The port confilict shouldn't be the problem, if there was a port issue the container wouldn't start.

I think it has more to do with changing the steamcmd folder (btw why, steamcmd is only used to download the games through steampipe).

And the version error is because steam couldn't download or better speaking validate the game as your log shows above:

6 hours ago, pengrus said:

Update state (0x0) : Timed out waiting for update to start, bailing.

Error! App '376030' state is 0x204 after update job.

Can it be that there is some issue on your network and the container can't connect to steam?

 

Also i've seen that you specified a username is this for ARK required (i'm not 100% shure because i'm not at home)?

 

Please try to redownload the container from the CA App and start over again only for testing.

Link to post
10 hours ago, ich777 said:

The port confilict shouldn't be the problem, if there was a port issue the container wouldn't start.

I think it has more to do with changing the steamcmd folder (btw why, steamcmd is only used to download the games through steampipe).

And the version error is because steam couldn't download or better speaking validate the game as your log shows above:

Can it be that there is some issue on your network and the container can't connect to steam?

 

Also i've seen that you specified a username is this for ARK required (i'm not 100% shure because i'm not at home)?

 

Please try to redownload the container from the CA App and start over again only for testing.

Got it.  Yes, there absolutely could be an issue with the container's network access, but I've pinholed the TCP and UDP for 7777, 7778, and 27015 both ways, it should be fine, and other bridged dockers are fine.  Yes, Ark requires a username, had to set up a separate account for that with SteamGuard disabled.

 

Ok, so I removed both dockers, as well as their folders from my appdata and redownloaded Ark-SE.  Here is the error I'm getting now, did my best to snippet:
 

---Prepare Server---

---Server ready---
---Start Server---
/opt/scripts/start-server.sh: line 61: cd: /serverdata/serverfiles/ShooterGame/Binaries/Linux: No such file or directory
/opt/scripts/start-server.sh: line 62: ./ShooterGameServer: No such file or directory
---Setting umask to 000---
---Update SteamCMD---
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
Logging in user 'thepengrusservers' to Steam Public ...
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
Logging in user '****' to Steam Public ...
Logged in OK
Waiting for user info...OK
---Update Server---
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
Logging in user '****' to Steam Public ...
Logged in OK
Waiting for user info...OK
ERROR! Failed to install app '376030' (No subscription)
---Prepare Server---
---Server ready---
---Start Server---
/opt/scripts/start-server.sh: line 61: cd: /serverdata/serverfiles/ShooterGame/Binaries/Linux: No such file or directory
/opt/scripts/start-server.sh: line 62: ./ShooterGameServer: No such file or directory

It definitely looks like the container can't get out to the network, and/or Ark isn't getting installed for some reason?

 

Thanks!

 

--P

Link to post

Remove the account. I just installed the docker and logged in anonymously and it downloaded, and installed just fine. After that it looks like you would need to stop the container then add the account info and start it back up. Atleast, that's what I'm guessing:

Connecting anonymously to Steam Public...Logged in OK
Waiting for user info...OK
Success! App '376030' already up to date.
---Prepare Server---
---Server ready---
---Start Server---
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.

Setting breakpad minidump AppID = 346110

is saying.

 

Hope this helps!

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.