[Support] ich777 - Gameserver Dockers


4202 posts in this topic Last Reply

Recommended Posts

5 hours ago, Spectral Force said:

I did but never got around to addressing it.  If you want you can PM for the official discord.  However i had issues with my unraid and Ich took down the container :( so I can't re download it.  If there was an example/template of what needs to be done for unraid I can probably have the author fork out an official container.

I can probably export the docker template for you. (portainer is great for this) for the always loading, i dont know what the fix is for that.

The issue i has was that the initial call to start the program was called with a timeout of 60 seconds, for some reason even though my system runs at only 20% usage max on everything 60 seconds was not long enough for it to build all the tables. if you are missing even 1 table, it looks like its all running but when you try and login with steam, it returns and gives a 502 error. This error was basically a timeout packet was received. The timeout being called by CSMM. Long story short the logs basically pointed to not being able to find tables, which then i fixed by manually running the command with a 5min timeout. (also had tried merging db files which was working, but i always was still missing 1-2 tables.)

 

I'd love to help in anyway i can to get this working for the community.

Link to post
  • Replies 4.2k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Summary: Support Thread for ich777 Gameserver Dockers (CounterStrike: Source & ConterStrike: GO, TeamFortress 2, ArmA III,... - complete list in the second post) Application: SteamCMD Do

Just thought I'd share my experience setting up a Valheim server with this docker app from @ich777(thank you!)   You don't need to worry about Steam authentication for Valheim, the default a

Dockers Available so far:   SteamCMD DedicatedServers: CounterStrike: Source CounterStrike: Global Offensive TeamFortress 2 ArmA3 - requested by @MrSage D

Posted Images

1 hour ago, Natcoso9955 said:

I can probably export the docker template for you. (portainer is great for this) for the always loading, i dont know what the fix is for that.

The issue i has was that the initial call to start the program was called with a timeout of 60 seconds, for some reason even though my system runs at only 20% usage max on everything 60 seconds was not long enough for it to build all the tables. if you are missing even 1 table, it looks like its all running but when you try and login with steam, it returns and gives a 502 error. This error was basically a timeout packet was received. The timeout being called by CSMM. Long story short the logs basically pointed to not being able to find tables, which then i fixed by manually running the command with a 5min timeout. (also had tried merging db files which was working, but i always was still missing 1-2 tables.)

 

I'd love to help in anyway i can to get this working for the community.

The docker template, is that a generic unraid template or specific to ich's release of this?  Containers aren't my thing so not quite sure what you mean?  I'm not sure what the difference is between a "standard" container vs what unraid uses.

Link to post
9 hours ago, Spectral Force said:

I did but never got around to addressing it.  If you want you can PM for the official discord.  However i had issues with my unraid and Ich took down the container :( so I can't re download it.  If there was an example/template of what needs to be done for unraid I can probably have the author fork out an official container.

 

4 hours ago, Natcoso9955 said:

I can probably export the docker template for you. (portainer is great for this) for the always loading, i dont know what the fix is for that.

The issue i has was that the initial call to start the program was called with a timeout of 60 seconds, for some reason even though my system runs at only 20% usage max on everything 60 seconds was not long enough for it to build all the tables. if you are missing even 1 table, it looks like its all running but when you try and login with steam, it returns and gives a 502 error. This error was basically a timeout packet was received. The timeout being called by CSMM. Long story short the logs basically pointed to not being able to find tables, which then i fixed by manually running the command with a 5min timeout. (also had tried merging db files which was working, but i always was still missing 1-2 tables.)

 

I'd love to help in anyway i can to get this working for the community.

Should I reupload the template if you confirm it works and increase the time?

Link to post

Hello, I have following issue:
I copied over my whole server I created on windows (is this correct), also with three maps world, world_nether and world_the_end.

It all started well, but the map was wrong, except for the inventory... What have I possibly done wrong? 

Also the world has strange borders... (see picture)

I have searched for hours, but no result... What do I need to do?

Link to post
2 hours ago, Augmentum said:

Hello everyone, I'm super new to this.

 

I was just wondering how would I create multiple terraria worlds?

 

Create multiple Containers with multiple Containernames and filepaths.

 

1 hour ago, xBotRaid said:

Hello, I have following issue:
I copied over my whole server I created on windows (is this correct), also with three maps world, world_nether and world_the_end.

It all started well, but the map was wrong, except for the inventory... What have I possibly done wrong? 

Also the world has strange borders... (see picture)

I have searched for hours, but no result... What do I need to do?

Can you post the logs? Does the server generate a new world?

Is everything set right in the server.properties?

 

I think the weird look of the world boarder could also be that the server uses another seed to generate the world...

Also does the server create a new terrain?

 

Link to post
6 minutes ago, Natcoso9955 said:

@ich777 I think the issue with tshock is that it's not downloading the prerelease versions which are required for the updated terraria version.

 

Really want to help with this one, so if you don't have the game and need it to test, I'll shout you a copy of it.

I can try it if I download and install everything manually if the server starts correctly (since I know how the container works it's easier for me to do that).

 

If you can send me a copy of the game i can test if everything is working as expected (if you do so, please note that weekend is family time for me and I will do testing and averything else next week).

Link to post
On 6/4/2020 at 9:32 PM, ich777 said:

Create multiple Containers with multiple Containernames and filepaths.

 

Can you post the logs? Does the server generate a new world?

Is everything set right in the server.properties?

 

I think the weird look of the world boarder could also be that the server uses another seed to generate the world...

Also does the server create a new terrain?

 

Problem resolved itself. It was an issue on my side, the world was indeed faulty, not the server.

Link to post

Hey,

 

Noticed that the planetary annihilation server is spitting out this error:

 

/serverdata/serverfiles/stable/server: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by /serverdata/serverfiles/stable/server)

 

The dependency may need to be updated

Link to post
6 hours ago, spacecops said:

Hey,

 

Noticed that the planetary annihilation server is spitting out this error:

 

/serverdata/serverfiles/stable/server: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by /serverdata/serverfiles/stable/server)

 

The dependency may need to be updated

Thank you will look into that and report back. ;)

Link to post
7 hours ago, spacecops said:

Hey,

 

Noticed that the planetary annihilation server is spitting out this error:

 

/serverdata/serverfiles/stable/server: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by /serverdata/serverfiles/stable/server)

 

The dependency may need to be updated

Please update the container, error is now resolved and all is working again. ;)

Link to post

Hey, trying to run terraria server but having some issues, docker installs and created fine, but it creates a 1.3.5.3 world, I tried changing version to 1.4.0.5 or blank which updates fine to latest, but fails to create a world and crashes with this error.

 

Tried creating multiple dockers but could only get it to create a world when the default version value is used.

 

---Starting...---
/opt/scripts/start-server.sh: line 5: [: : integer expression expected
------------------------------------------------------------------------------------
---------------------------------W A R N I N G--------------------------------------
---The variable Prefered Version doesn't work anymore for Version 1.4.0.2 and up----

---The conatainer will always pull the latest version if set to 1.4.0.2 or higher---

------------------------------------------------------------------------------------
---Version Check---

---Terraria Version up-to-date---

---Prepare Server---
---Server ready---
---Checking for old logs---
---Start Server---
Error Logging Enabled.

[?1h=[6n[H[JTerraria Server v1.4.0.5

[H[J
Server crash: 6/7/2020 7:43:38 PM
System.NullReferenceException: Object reference not set to an instance of an object
at Terraria.Main.WriteFancyWorldLoadErrorToConsole () [0x00005] in <0ebea07e9a804a06a9f1dd17904b9c9c>:0
at Terraria.Main.DedServ () [0x00b21] in <0ebea07e9a804a06a9f1dd17904b9c9c>:0
at Terraria.Program.LaunchGame (System.String[] args, System.Boolean monoArgs) [0x000ac] in <0ebea07e9a804a06a9f1dd17904b9c9c>:0

Please send crashlog.txt to support@terraria.org
Terminated
[?1l>[39;49m'---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
/opt/scripts/start-server.sh: line 5: [: : integer expression expected

Session terminated, killin

 

Link to post
1 hour ago, Mizerka said:

Hey, trying to run terraria server but having some issues, docker installs and created fine, but it creates a 1.3.5.3 world, I tried changing version to 1.4.0.5 or blank which updates fine to latest, but fails to create a world and crashes with this error.

 

Tried creating multiple dockers but could only get it to create a world when the default version value is used.

Can you please be a little bit more specific?

Is this the normal Terraria Server or a mod server?

 

EDIT: I tried it on my server and got almost the same error but not completely, since the last major update of Terraria almost all of my containers are messed up, i will look into it as soon as I got a little bit spare time...

Edited by ich777
Link to post
1 hour ago, ich777 said:

Can you please be a little bit more specific?

Is this the normal Terraria Server or a mod server?

 

EDIT: I tried it on my server and got almost the same error but not completely, since the last major update of Terraria almost all of my containers are messed up, i will look into it as soon as I got a little bit spare time...

This is vanilla, I tried few more versions since, but could only get it to generate a 1.3.5.3 world. Tried few more modes, small medium large, all giving the same error, I'm not great at reading syntax but seems like it's just expecting a integer early on probably from some variable, or from initial error where some var is just not set at all.

Link to post
1 minute ago, Mizerka said:

This is vanilla, I tried few more versions since, but could only get it to generate a 1.3.5.3 world. Tried few more modes, small medium large, all giving the same error, I'm not great at reading syntax but seems like it's just expecting a integer early on probably from some variable, or from initial error where some var is just not set at all.

This is not an error that I get when I'm installing the container/game and also this shouldn't affect the game since this is the real problem:

Server crash: 6/7/2020 7:43:38 PM
System.NullReferenceException: Object reference not set to an instance of an object

I will look into it as soon as possible but I'm very busy at the moment (I think i will fix it this week but give me a few days).

Link to post
18 minutes ago, ich777 said:

This is not an error that I get when I'm installing the container/game and also this shouldn't affect the game since this is the real problem:


Server crash: 6/7/2020 7:43:38 PM
System.NullReferenceException: Object reference not set to an instance of an object

I will look into it as soon as possible but I'm very busy at the moment (I think i will fix it this week but give me a few days).

To confirm, if I take your template as is, it works fine, it generates a 1.3.5.3 world, and I can just upgrade server to 1.4.0.5 but I'd like to generate a new world in 1.4 for a few reasons (and expert + medium/large but that's something else, on side topic, I assume master and journey worlds can also be created by incrementing values further?).

 

For now I'm just running it locally, also tried creating the world locally and moving it over, which didn't work either, with same error.

 

and yeah no rush, I appreciate your work on this.

Edited by Mizerka
Link to post

Ich, I have a question about the Quake 3 server.

 

Can it be used to host an Instagib server ? There is a separate .pk3 file for instagib and it's own .cfg file, I copied these into the baseq3 folder but it still loads Quake with all weapons etc.

 

Any ideas ?

 

Tia

 

Myles

Link to post
25 minutes ago, Myleslewis said:

Ich, I have a question about the Quake 3 server.

 

Can it be used to host an Instagib server ? There is a separate .pk3 file for instagib and it's own .cfg file, I copied these into the baseq3 folder but it still loads Quake with all weapons etc.

 

Any ideas ?

 

Tia

 

Myles

I will look into this but give me some time since I'm really busy at the moment.

Can you give me a little bit more information what this is exactly?

I've created this container by request and don't know everything.

Link to post

Thanks, take all the time you need :)

 

Instagib is a server side mod that removes all weapons apart from the rail gun, it's one shot one kill mechanic making for a fast paced game environment.

 

A link to the mod can be found here: https://www.fileplanet.com/archive/p-4518/InstaGib-1-29h

 

To play single player you extract the files into a folder in the same directory as baseq3 in your Q3 install, not sure how you'd do it on the server though.

 

Thanks for looking into it for me :)

Link to post

Hi ich777, I hope you are keeping well.

 

I appreciate you are super busy at the moment, so there is no rush on this request at all, but please may I ask you to add Project Cars 2 Dedicated Server to your list? Details here: https://steamdb.info/app/413770/.

 

Thanks again for all your hard work on these game servers, it's great to see so many in the apps list now :) Please let me know if you need any extra info.

 

 

Link to post
1 hour ago, Mantiphex said:

Hi ich777, I hope you are keeping well.

 

I appreciate you are super busy at the moment, so there is no rush on this request at all, but please may I ask you to add Project Cars 2 Dedicated Server to your list? Details here: https://steamdb.info/app/413770/.

 

Thanks again for all your hard work on these game servers, it's great to see so many in the apps list now :) Please let me know if you need any extra info.

I've already looked this up some time ago and since you are need to own a copy of the game (that I don't own) to install the dedicated server I can't create a Container for this game.

Keep in mind that you need a dedicated account with a copy of the game in the library with SteamGuard disabled to successfully download the game with this Container or you disable SteamGuard for your own account (but that is a thing that I and also Steam doesn't recommend since your account could be easiely stolen these days if you got a weak password...).

Link to post
19 hours ago, ich777 said:

I've already looked this up some time ago and since you are need to own a copy of the game (that I don't own) to install the dedicated server I can't create a Container for this game.

Keep in mind that you need a dedicated account with a copy of the game in the library with SteamGuard disabled to successfully download the game with this Container or you disable SteamGuard for your own account (but that is a thing that I and also Steam doesn't recommend since your account could be easiely stolen these days if you got a weak password...).

You can enter the steamGuard code into the console of steamcmd, but i dont know how you would incorporate that into the docker container.
killing floor has the same thing.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.