[Support] ich777 - Gameserver Dockers


3771 posts in this topic Last Reply

Recommended Posts

  • Replies 3.8k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Summary: Support Thread for ich777 Gameserver Dockers (CounterStrike: Source & ConterStrike: GO, TeamFortress 2, ArmA III,... - complete list in the second post) Application: SteamCMD Do

Just thought I'd share my experience setting up a Valheim server with this docker app from @ich777(thank you!)   You don't need to worry about Steam authentication for Valheim, the default a

Dockers Available so far:   SteamCMD DedicatedServers: CounterStrike: Source CounterStrike: Global Offensive TeamFortress 2 ArmA3 - requested by @MrSage D

Posted Images

5 hours ago, evocraigst said:

how do i make dedicated 7 days to die server on experimental branch ?

 

 

thanks

Page 66:

 

Not different than any other linux dedicated server. ;)

 

With the GAME_ID you choose which game to download through SteamCMD and also you can add for example your option -beta latest_experimental (in your case this should be: '294420 -beta latest_experimental' without quotes).

Link to post
3 minutes ago, ich777 said:

Page 66:

 

Not different than any other linux dedicated server. ;)

 

With the GAME_ID you choose which game to download through SteamCMD and also you can add for example your option -beta latest_experimental (in your case this should be: '294420 -beta latest_experimental' without quotes).

thanks sorry im new :)

Link to post
12 minutes ago, evocraigst said:

Can i request Space Engineers Dedicated Server please :) 

thanks

Nope, this game was designed without Linux in mind and I've done several attempts to get it running through WINE but failed... :P

Link to post
On 7/12/2020 at 10:48 AM, ich777 said:

Have you read the description of the container itself?

You have to put the dedicated server exe from your game into the main directory of the created container in your appdata folder.

 

Sorry but I don't create gameservers for games that I don't own anymore, that makes troubleshooting impossoble for me.

 

But as far as I've discovered this gamehas only a windows dedicated server and some posts say that the dedicated server for linux is released with the v1.0 release of the game, is the game already at v1.0?

yes i did, and it runs perfect now... but to make multiple servers, i need to make multiple docker also with different settings? am i doing it wrong? or is it possible to run multiple server from one docker?

 

i found this to run multiple servers, maybe this helps? https://pixxelhunter.de/acc_software.html

 

and for AMS2 yes the game is already V1.0 now. thank you

Link to post
13 hours ago, ich777 said:

Done, the container is now updated, please wait a few hours and redownload it from the CA App and you will find the new options to install Assetto-Server-Manager.

thank you very much, will try that

Link to post
18 minutes ago, daniz24 said:

yes i did, and it runs perfect now... but to make multiple servers, i need to make multiple docker also with different settings? am i doing it wrong? or is it possible to run multiple server from one docker?

Yes, simply create multiple containers with multiple server directories and also with multiple port mappings but you have to delete the old ones and create new entries corresponding to your gameconfig and you are good to go.

 

20 minutes ago, daniz24 said:

i found this to run multiple servers, maybe this helps? https://pixxelhunter.de/acc_software.html

You know that this is for windows? You can run easily multiple docker containers at once like discribed above, I will not make another modification to the container itself. The baseimage is used for all containers so you are saving a lot of space. ;)

 

22 minutes ago, daniz24 said:

and for AMS2 yes the game is already V1.0 now.

Yes but I couldn't find any informations on Linux servers (since all my containers are based on Linux).

Link to post

Hello,

 

I'm sorry if this is the wrong spot to post about this, but I'm receiving this error message when trying to launch the Killing Floor 2 dedicated server docker container:

"/serverdata/serverfiles/Binaries/Win64/KFGameSteamServer.bin.x86_64: error while loading shared libraries: libcurl.so.4: cannot open shared object file: No such file or directory"
-I've verified that the file is there.
-I've performed a full/fresh install of both KF2 dedicated server and SteamCMD within the unraid docker

 

Any suggestions would be appreciated.

Thanks!

 

@ich777 I spoke with some people on the unRAID discord. They're saying that 'curl' is missing. Can you look into this?

Edited by ss1gohan13
Additional info
Link to post
3 hours ago, ss1gohan13 said:

Hello,

 

I'm sorry if this is the wrong spot to post about this, but I'm receiving this error message when trying to launch the Killing Floor 2 dedicated server docker container:

"/serverdata/serverfiles/Binaries/Win64/KFGameSteamServer.bin.x86_64: error while loading shared libraries: libcurl.so.4: cannot open shared object file: No such file or directory"
-I've verified that the file is there.
-I've performed a full/fresh install of both KF2 dedicated server and SteamCMD within the unraid docker

 

Any suggestions would be appreciated.

Thanks!

 

@ich777 I spoke with some people on the unRAID discord. They're saying that 'curl' is missing. Can you look into this?

As an extension of this post, the missing package is libcurl4.

 

For the timebeing, this can be fixed by installing libcurl4 via the container's console, during initial download of the server files. Any attempt to do so after the container has download its game files will fail due the bootloop caused by the missing dependency. 

Link to post
7 hours ago, ss1gohan13 said:

Hello,

 

I'm sorry if this is the wrong spot to post about this, but I'm receiving this error message when trying to launch the Killing Floor 2 dedicated server docker container:

"/serverdata/serverfiles/Binaries/Win64/KFGameSteamServer.bin.x86_64: error while loading shared libraries: libcurl.so.4: cannot open shared object file: No such file or directory"
-I've verified that the file is there.
-I've performed a full/fresh install of both KF2 dedicated server and SteamCMD within the unraid docker

 

Any suggestions would be appreciated.

Thanks!

 

@ich777 I spoke with some people on the unRAID discord. They're saying that 'curl' is missing. Can you look into this?

Thank you for reporting this! :)

Container now fixed, I think they might have changed somthing so that Curl is now needed.

Please update the Container itself or delete the installed one and redownload it from the CA App.

 

@MrMeeb thank you for the answer. ;)

 

7 hours ago, zacmontey said:

Trying to get some clear info on how to install steam workshop mods on the Ark Docker. I have attempted to add the adjustments in the game.ini and the gameusersettings.ini. Is there something more that I need to be doing? 

Click on the Ark icon on the Docker page and open up a console and type in this command:

 

${STEAMCMD_DIR}/steamcmd.sh +login anonymous +force_install_dir ${SERVER_DIR} +"workshop_download_item 346110 WORKSHOPID" validate +quit

 

(Replace WORKSHOPID with the ID that you want to install)

 

All other things I can't help because I simply play the game often enough or without mods but I think if you search something like: 'ark steamcmd workshop content install linux' on google you should find how to do it, anyways the command above is the right one for installing workshop content and also has the right paths in it.

Link to post
3 hours ago, mbc0 said:

I think I know the answer but is it possible for any of these dockers to work on xbox one?

?

Don't know the question...

You want to play with your Xbox on this servers?

Link to post
3 hours ago, ich777 said:

?

Don't know the question...

You want to play with your Xbox on this servers?

Sorry, I wasn't very clear, I have used dockers in the past to host gameservers for PC but my Son has an Xbox One and wants a server for Assetto Corsa and I am wondering if that is even possible for any Xbox Game? Google is hard for this one!

Link to post
On 7/12/2020 at 11:57 PM, ich777 said:

Page 66:

 

Not different than any other linux dedicated server. ;)

 

With the GAME_ID you choose which game to download through SteamCMD and also you can add for example your option -beta latest_experimental (in your case this should be: '294420 -beta latest_experimental' without quotes).

I'm not what's going on, but with the beta the server seems to have an issue starting and doesn't allow the port to be opened. Anyone else experiencing this with the A19 of 7DTD? This is what's in the log:

 

---Prepare Server---
---Moving SaveGameFolder location---
---Savegame location found---
---Moving UserDataFolder location---
---UserDataFolder location found---
---Server ready---
---Start Server---
Found path: /serverdata/serverfiles/7DaysToDieServer.x86_64
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Setting breakpad minidump AppID = 251570

Link to post
13 hours ago, mbc0 said:

Sorry, I wasn't very clear, I have used dockers in the past to host gameservers for PC but my Son has an Xbox One and wants a server for Assetto Corsa and I am wondering if that is even possible for any Xbox Game? Google is hard for this one!

That's a really good question, most games on the Xbox can't connect to private dedicated servers like MinecraftBedrock Edition (but there are some workarounds), if that's working for Assetto Corsa I really can't tell.

From what I know Ark Survival Evolved should work but you have to add some startup commands, some correct me if I'm wrong.

Search for something like 'xbox assetto corsa private dedicated server' and you should find something.

 

12 hours ago, thunderclap said:

I'm not what's going on, but with the beta the server seems to have an issue starting and doesn't allow the port to be opened. Anyone else experiencing this with the A19 of 7DTD? This is what's in the log:

 

---Prepare Server---
---Moving SaveGameFolder location---
---Savegame location found---
---Moving UserDataFolder location---
---UserDataFolder location found---
---Server ready---
---Start Server---
Found path: /serverdata/serverfiles/7DaysToDieServer.x86_64
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Setting breakpad minidump AppID = 251570

That looks pretty right.

 

The line:

12 hours ago, thunderclap said:

Setting breakpad minidump AppID = 251570

Tells you that everything is working and running.

Link to post
6 hours ago, ich777 said:

That looks pretty right.

 

The line:

Tells you that everything is working and running.

Yeah, that's what's confusing me. I even deleted the A19 docker, created a new docker using the latest stable and it works fine. I then added the -beta latest-experimental code and once it updates I can no longer get through the port. It's really weird.

Link to post
18 minutes ago, thunderclap said:

Yeah, that's what's confusing me. I even deleted the A19 docker, created a new docker using the latest stable and it works fine. I then added the -beta latest-experimental code and once it updates I can no longer get through the port. It's really weird.

Does it use CPU and RAM as usual?

Sorry I personlly don't play this game and I also can't test anything because I don't own it.

Someone reported a similar problem but after he deletes the created folder in the appdata directory and the container itself and reinstalled it everything worked (it's somewhere above in the post that I've linked).

 

EDIT:

 

Link to post
9 hours ago, ich777 said:

Does it use CPU and RAM as usual?

Sorry I personlly don't play this game and I also can't test anything because I don't own it.

Someone reported a similar problem but after he deletes the created folder in the appdata directory and the container itself and reinstalled it everything worked (it's somewhere above in the post that I've linked).

 

EDIT:

 

Same usage as far as I can tell. I even disabled the A18.4 server to see if there was a conflict but there wasn’t.

Link to post
7 hours ago, thunderclap said:

Same usage as far as I can tell. I even disabled the A18.4 server to see if there was a conflict but there wasn’t.

So you have created a second Container?

Have you changed the port inside the template?

If so have you deleted the port entries in the template and created new ones and also change it in your serversettings file?

 

If you only change them in the template it will not work...

Link to post
7 hours ago, ich777 said:

So you have created a second Container?

Have you changed the port inside the template?

If so have you deleted the port entries in the template and created new ones and also change it in your serversettings file?

 

If you only change them in the template it will not work...

Yes, I changed all the port numbers in the container as well as the server config file. As I previously mentioned, I installed the second container using the latest stable build (18.4) using your install and it worked along side the first container install. It's only after I upgraded to the latest experimental that it stops working.

 

Oh well, maybe it's something with the latest A19 build of 7DTD. I realize it's hard to troubleshoot for you since you don't have the game and I do appreciate you taking the time to try and help.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.