[Support] Josh.5 Docker Templates


Recommended Posts

I've had lancache-bundle running on my unraid server in the past without issue. Same server, same router. Just installed it again and it only works if I connect to it directly by configuring my PC's IPv4 settings, but not if I configure my router to point to the docker (which used to work in the past). It sounds as though a few people are having issues so I thought I'd share as much information as I could to see if we can get to the bottom of some of them.

 

Here's my working 1 PC setup (not ideal)

 

image.thumb.png.c58ab44271a47274699cf9d3bda7e19b.png

Docker config in Unraid

 

image.png.2eb53810f8d265d2e8b0f5ffa9ae7691.png

Docker config continued

 

image.png.eb0e4e144832981d6ab06edd4517a41a.png

IPv4 DNS settings on my PC

 

image.png.8192a67c991303951aba3e5f38610744.png

Router DNS Config (I know this isn't pointing to my lancache docker image at 192.168.50.245 - this is the less than ideal non-router setup)

 

image.png.fedf576fda03605a562eaebdfb39a5f3.png

Initial download speeds from steam

 

image.png.b7243b44978adabe59c65715cae4e0d5.png

Plenty of stuff in my new lancache share

 

image.png.3ec6c257d394072b087a185affde98b1.png

Re-download speeds that prove the cache is functioning correctly

 

Now if I change the router config to point to the lancache docker image as the DNS it doesn't work and nothing on my netwrk can resolve DNS addresses...

 

image.png.a077ffa12a33df56b0f37f41f1f86e02.png

Router pointing to lancache docker image

 

image.png.dea3b22f3ee8d6aecaf9a8d64e18ad0e.png

Windows told to resolve DNS automatically (leave it to the router)

 

image.png.ee03fefeee9b364665215d12f553d0d1.png

Unresolved DNS

 

So why is it that if I point my PC directly to the docker image it works, but if I leave my PC to automatically resolve, and point the router to the docker image, it does not work?

 

Any ideas folks?

Link to comment

@MajorTomG Is it possible that your router would try to connect to the DNS using the WAN connection on your router?

You could try running another DNS server (pihole or something like that) and point your router to that and see if it will resolve... If it will not resolve either, than I think your router will use the WAN port for DNS lookups. In that case you can setup LanCache to use your router as source DNS and point your systems to the LanCache IP.

Maybe it's possible to change it in the DNS settings of your router so it will hand out the LanCache IP as the DNS server to you DHCP clients.

Link to comment

having issues using the lancache

 

i finding my computers accessing the internet is much slower then when i using 1.1.1.1  where its bang fast

i also like to know for Epic Games   how do you have endless caching?  default is like 152 days for caching  how do you set caching for different days 

like Epic, Battle net, Steam  =  Endless..    anythng else can be 152 days

 

as it takes me 6 months to redownload  Epic games on my account on my current internet speed 24/7 going drives me nuts so i dont want it erasing it..  and my epic games takes up 3TB of data  on my gaming drive..  do i need least 3TB  for lancache..  

 

as i frustrated how Epic Launcher works for verifying games.. and the trick work around doesnt work

 

Link to comment
  • 3 weeks later...

Hey Guys,

 

for people with issues with lancache...

I did some research on the original Lancache website and they mention Lancache does not like when certain ports are shared with Lancache e.g.53,80 and 443. This is likely the issue here when running on Unraid assuming you run other containers using any of these ports.

 

A workaround is to create a VM e.g. ubuntu and install Lancache on that VM. Within that VM Lancache has exclusive access to these ports.

I am currently checking this myself and it looks promising!! My issues went away but still testing more.

A video guide here:

 

a written guide here:

https://lurkingforgames.com/lancache

 

I am happy with this and still testing! Also within the lancache folder you can do a "nano .env" and you can see most of the parameters from the Unraid Lancache docker settings. Change them exactly like you had it before.

 

Link to comment
On 7/3/2021 at 9:03 AM, xPliZit_xs said:

Hey Guys,

 

for people with issues with lancache...

I did some research on the original Lancache website and they mention Lancache does not like when certain ports are shared with Lancache e.g.53,80 and 443. This is likely the issue here when running on Unraid assuming you run other containers using any of these ports.

 

A workaround is to create a VM e.g. ubuntu and install Lancache on that VM. Within that VM Lancache has exclusive access to these ports.

I am currently checking this myself and it looks promising!! My issues went away but still testing more.

A video guide here:

 

a written guide here:

https://lurkingforgames.com/lancache

 

I am happy with this and still testing! Also within the lancache folder you can do a "nano .env" and you can see most of the parameters from the Unraid Lancache docker settings. Change them exactly like you had it before.

 

In my experience the VM solution is slower, besides I have this configured to use its own IP so there shouldn't be any port conflicts. This worked before the most recent update.

Link to comment
Posted (edited)
21 hours ago, arch1mede said:

In my experience the VM solution is slower, besides I have this configured to use its own IP so there shouldn't be any port conflicts. This worked before the most recent update.

I actually figured out the issue, unknown to me, md1 was spitting out xfs errors even though the main page/dashboard showed everything green. As it happens, the lancache-bundle docker has a user setting that pointed to md1 which was really not accessible so wouldn't start. Rebooted the unraid box resolved the issue but not really happy with that solution as I shouldn't have needed to reboot it. As a result, md1 had a xfs error on it so I had to run a parity check on the whole array to resolve the issue, I may still have to put the array into maintenance mode and do a repair but thought id share how this was resolved.

Edited by arch1mede
Link to comment
21 minutes ago, arch1mede said:

md1 was spitting out xfs errors even though the main page/dashboard showed everything green.

The green status indicators means the drive hasn't returned any write errors. Nothing to do with the validity of any filesystem on the drive.

Link to comment
19 hours ago, jonathanm said:

The green status indicators means the drive hasn't returned any write errors. Nothing to do with the validity of any filesystem on the drive.

Yes I realize that but not sure how I am supposed to know there is an issue if I have to check multiple places.

Link to comment
14 minutes ago, arch1mede said:

Yes I realize that but not sure how I am supposed to know there is an issue if I have to check multiple places.

Only major issues when the drive is unmountable or disabled (two separate issues with two separate indicators) show up on the main GUI. File system corruption minor enough that the drive still mounts don't show up there currently.

 

I'm probably going to submit a feature request, it may or may not ever get any attention.

Link to comment
Posted (edited)
2 hours ago, jonathanm said:

Only major issues when the drive is unmountable or disabled (two separate issues with two separate indicators) show up on the main GUI. File system corruption minor enough that the drive still mounts don't show up there currently.

 

I'm probably going to submit a feature request, it may or may not ever get any attention.

For me md1 was mounting but showing up like: d?????????????? so it would have been good to know that there was an issue with the mount point.

Edited by arch1mede
Added more verbiage for clarity
Link to comment
  • 3 weeks later...
  • 4 weeks later...

is it possible to run 2 lancaches..  or least offer 2 IP address with 2 DNS's

i run VPN and WAN (bypass VPN)    and when i use 1.1.1.1  it leaks DNS resolutions whatever you call it.

and if i set to 192.168.0.1  it buggers up my WAN connections as the Resolver doesnt always like the WAN stuff..  like amazon com

 

it be nice if possible

192.168.0.32 (DNS)  ------> 192.168.0.1 (UPSTREAM DNS)    for (VPN Clients)

192.168.0.33 (DNS) --------> 1.1.1.1 (UPSTREAM DNS)            for (WAN Clients)

this way can use the same lancache but point to 2 different DNS's  for resolving issues

and if not possible in 1.. 

be nice if you could run 2 Lancaches..  but the 2nd one would point to the same lancache as the first one this way..it can share and not need to 2 duplicate everything

Edited by comet424
Link to comment
  • 2 weeks later...

so i found the add container option in docker  and i was able to recreate a 2nd lancache,,  i just renamed it and changed IP address.. i have it still pointing to the same lancache..  will  both work together ok  without issue or it wont?

1 is for game caching and windows update For Non VPN clients

2. is for windows update for VPN Clients

Link to comment
  • 2 weeks later...

so i having issues setting this up right

 

i have 2 Lan caches  running on my server

 

so my unraid is 

192.168.0.3   and dns is 192.168.0.1

 

now lan cahce  (no vpn)  i se to 192.168.0.32   upstream 1.1.1.1

now lancache 2 (vpn users)  i set it to 192.168.0.33 upstream 192.168.0.1

 

and they both point to the same directory

 

but it doesnt like to work  i reboot my pfsense  router..    i think  the 192.168.0.32  uses 192.168.0.1  as its dns from unraid

 

i tried in pfsense to tell it 192.168.0.32  would use dns 1.1.1.1  and 192.168.0.33  would use 192.168.0.1

 

but it just doesnt work right..  how u get it lancache to read it

 

i set the upstream 1.1.1.1 for lan cache no vpn    and 192.168.0.1  for the lancache vpn users...  

 

but doesnt 100% work right

 

i think both lancaches  use the DNS  of tower(unraid)  and i dont want that

 

also i tried

cache ip 192.168.0.32     bind dns ip  1.1.1.1

192.168.0.33  bind dns ip 192.168.0.1

 

but doenst work right 

Edited by comet424
Link to comment

For those of you running on PiHole, there is a way to be able to use it to be able to use LANCACHE while not having to mess up your setup.

 

In my case, I have certain devices allowed to bypass PiHole (was driving my GF nuts). To change my routers DNS settings to LANCACHE and then have the upstream DNS sent to PiHole would not have worked for me because then everything would have been the same IP/MAC address which would not work for my lists. This was not a possible solution for me.

 

What I ended up having to do was to compile the lists into a dnsmasq format. Luckily, there was already a solution to this located [url=https://github.com/uklans/cache-domains/tree/master/scripts]here[/url]. Even better, its an official solution!

 

I tried it on Windows but I ran in to errors while compiling the list so I did end up having to run it on the RaspberryPi that is running PiHole. 

 

1. SSH in to your RPi

 

2. Copy the repository using "git clone https://github.com/uklans/cache-domains.git"

 

3. Change to the folder that the config file is in: "cd ./cache-domains/scripts/"

 

4. Change the configuration to your standards. "cp config.example.json config.json && sudo nano config.json" 

For me, I kept it simple and made everything the same IP (I am not sure what the benefit of splitting them up is...)

{
	"ips": {
		"generic":	"LANCACHE IP HERE (keep the quotes)"
	},
	"cache_domains": {
		"default": 	"generic"
	}
}

If you want to set up different IPs for each service or multiple IPs for a single service, have a look at the example file on how to do that.

 

5. Save the config file by hitting "ctrl+x" then "y" and then "enter".

 

6.0. If you do not have jq installed, you need to install it: "sudo apt-get install jq -y"

6.1. Run the dnsmasq script to generate the appropriate files: "bash create-dnsmasq.sh"

 

7. Copy the generated files into the PiHole dnsmasq directory: "sudo cp ./output/dnsmasq/*.conf /etc/dnsmasq.d/"

 

8. Restart the pihole-FTL service: "sudo service pihole-FTL restart"

 

And that should be it!

 

One note to doing this is that you need to change your upstream DNS to something other than PiHole otherwise you will be creating an infinite loop (aka things will not download). I changed mine to 1.1.1.1.

Edited by LTM
Clarification of upstream DNS
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.