Jump to content
hernandito

[BIG REQUEST] IPSec VPN Server

5 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Hi Guys,

 

For ages I have been trying to get OpenVPN to work without any luck.

 

I ran into IPSec VPN Server which used the IPSec and  L2TP protocols.

 

I used to have a D-link router that used these protocols; and it worked flawlessly.

 

Here is a project that automates the install of all the components.

https://github.com/hwdsl2/setup-ipsec-vpn

 

Here is a Docker image:

https://github.com/hwdsl2/docker-ipsec-vpn-server

 

I have not tried adding the Docker manually yet.... I was wondering if anyone has any thoughts.

 

Thanks,

 

H.

 

Edited by hernandito
clarity

Share this post


Link to post
Posted (edited)

Hmm. Last time I tried, the kernel modules for IPSEC were not compiled in. But that back in 6.0

Edited by ken-ji

Share this post


Link to post

I just tried loading the docker and got nowhere fast. The stuff being spat out is incomprehensible to me....

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.