SMB Apple Time Machine 6.7


Recommended Posts

I just updated to version 6.7  and the only issue that i am running to is the SMB share for the time machine. It starts to work and after a couple of minutes it stops working on my Macbook Pro. All it says is stopping and it wait for the next time to run again and it just keeps happening. Any one has the same issue that has resolve it and that can help me please.

 

Thank you.

Link to comment

I am not having the same issue per se, rather I am unable to view the SMB share in Time Machine. I can create with all of the variables and then when in time machine, add disk, nothing is visible. In contrast, when I create a share for Time Machine using AFP, it shows up and am able to use it.

Link to comment
19 minutes ago, mfwade said:

I am not having the same issue per se, rather I am unable to view the SMB share in Time Machine. I can create with all of the variables and then when in time machine, add disk, nothing is visible. In contrast, when I create a share for Time Machine using AFP, it shows up and am able to use it.

Are you able to back up through wireless using afp protocol? I am able to do it through smb but for some reason it starts and then stops. It does not complete. What you mean by the variables? 

Link to comment

Same problem for me. It seems that the "Time Machine support via SMB" is not working if Active Directory implementation is enabled at the SMB settings on V 6.7.

While checking the /etc/rc.d/rc.samba script, I found out that if [ "$SECURITY" = "ads" ] then no "fruit:..." settings will be done at /etc/samba/smb-names.conf.

Without these settings, there is no Time Machine support via SMB. See also here: https://www.mankier.com/8/vfs_fruit

If I'm adding the fruit settings manually (and restart the SMB deamon) then I'm able to see the SMB-Share at Time Machine for adding the share.

But I also remember, that there are some issues on this implementation of fruit/samba. If im not wrong, maybe this is the reason why it is not working as expected...

Link to comment
7 minutes ago, Reini said:

Same problem for me. It seems that the "Time Machine support via SMB" is not working if Active Directory implementation is enabled at the SMB settings on V 6.7.

While checking the /etc/rc.d/rc.samba script, I found out that if [ "$SECURITY" = "ads" ] then no "fruit:..." settings will be done at /etc/samba/smb-names.conf.

Without these settings, there is no Time Machine support via SMB. See also here: https://www.mankier.com/8/vfs_fruit

If I'm adding the fruit settings manually (and restart the SMB deamon) then I'm able to see the SMB-Share at Time Machine for adding the share.

But I also remember, that there are some issues on this implementation of fruit/samba. If im not wrong, maybe this is the reason why it is not working as expected...

I dont have any of the fruit code in the smb setting under unraid. It finds the smb and I am able to connect and it starts. It seems like there is a timeout or something is stopping it. 

Link to comment
1 hour ago, Tucubanito07 said:

Are you able to back up through wireless using afp protocol? I am able to do it through smb but for some reason it starts and then stops. It does not complete. What you mean by the variables? 

Yea, I am able to backup over the wire and wireless with the AFP protocol. The variables are all set in Unraid (web GUI) when setting up the ‘share’.

 

-MW

  • Like 1
Link to comment
2 hours ago, mfwade said:

Yea, I am able to backup over the wire and wireless with the AFP protocol. The variables are all set in Unraid (web GUI) when setting up the ‘share’.

 

-MW

If this works well, the it would be great to know the right settings.

On the other side, I read "Note: AFP is now deprecated and macOS users are encouraged to use SMB only." at: 

 

 

So, AFP don't run stable and the SMB-Share isn't visible in Time Machine wile ADS is enabled, hmmm ...

Edited by Reini
Link to comment
2 hours ago, Tucubanito07 said:

I dont have any of the fruit code in the smb setting under unraid. It finds the smb and I am able to connect and it starts. It seems like there is a timeout or something is stopping it. 

Have you configured unRAID-SMB with joining to an Active Directory domain controller ?

  • Like 1
Link to comment
11 minutes ago, Reini said:

Have you configured unRAID-SMB with joining to an Active Directory domain controller ?

I don't know how to do that. I have gone to SMB and enabled the Time share. After that i have one disk just for the share. It seems like it times-out. That is my only issue. i dont know if there is a setting set to run for like 4 minutes and then stop.

Link to comment

Whenever reporting an issue, always include diagnostics.zip from Tools/Diagnostics page, captured after the issue has happened.

That said, try this:

On Settings/AFP set "Enable AFP" to No.

On Settings/SMB set "Enhanced macOS interoperability" to Yes

Then select your Time Machine share and under SMB Security Settings set "Export" to Yes/TimeMachine.

If you are attempting to use a share that was previously and AFP/TimeMachine target, I believe this should work, but if there are still issues, you should try creating a new share for your Time Machine target and let your Mac create a fresh backup.

  • Like 1
Link to comment
7 hours ago, Reini said:

Same problem for me. It seems that the "Time Machine support via SMB" is not working if Active Directory implementation is enabled at the SMB settings on V 6.7.

While checking the /etc/rc.d/rc.samba script, I found out that if [ "$SECURITY" = "ads" ] then no "fruit:..." settings will be done at /etc/samba/smb-names.conf.

Without these settings, there is no Time Machine support via SMB. See also here: https://www.mankier.com/8/vfs_fruit

If I'm adding the fruit settings manually (and restart the SMB deamon) then I'm able to see the SMB-Share at Time Machine for adding the share.

But I also remember, that there are some issues on this implementation of fruit/samba. If im not wrong, maybe this is the reason why it is not working as expected...

Right I didn't have the resources available to test combination of AD with/TimeMachine, so as to not possibly fubar AD further, decided not to add the necessary 'fruit' settings when AD is selected.  You should be able to add these lines to Settings/SMB/Samba extra configuration:

fruit:aapl = yes
fruit:resource = file
fruit:metadata = netatalk
fruit:locking = none
fruit:encoding = native
fruit:nfs_aces = no

And then let me know if this works. 👍

Link to comment
19 minutes ago, limetech said:

Right I didn't have the resources available to test combination of AD with/TimeMachine, so as to not possibly fubar AD further, decided not to add the necessary 'fruit' settings when AD is selected.  You should be able to add these lines to Settings/SMB/Samba extra configuration:


fruit:aapl = yes
fruit:resource = file
fruit:metadata = netatalk
fruit:locking = none
fruit:encoding = native
fruit:nfs_aces = no

And then let me know if this works. 👍

I have this under the SMB. Will that be ok?

 

#vfs_recycle_start
#Recycle bin configuration
[global]
   syslog only = Yes
   log level = 0 vfs:0
#vfs_recycle_end

[rootshare]
path = /mnt/user
comment =
browseable = yes
valid users = tucubanito07
write list = tucubanito07
vfs objects =

fruit:aapl = yes
fruit:resource = file
fruit:metadata = netatalk
fruit:locking = none
fruit:encoding = native
fruit:nfs_aces = no

Link to comment
59 minutes ago, Tucubanito07 said:

ok. I will do that. So i can manage my rootshares by smb on my windows 10 computer.

Unraid is designed to export individual shares.  What you are doing is circumventing, among other things, built-in share security.  I'm assuming you know what you're doing.  This post is for others who read this: my recommendation is don't do what @Tucubanito07 is doing here unless you too, know what you're doing.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.