No more connection after update to 6.7.0. Server crash

Recommended Posts

As Sgt Oddball says "I only ride ’em, I don’t know what makes ’em work"

I use Unraid I don't know what makes it work, and I shouldn't need to know, I spend a few hours on Saturday getting the server to work after the 6.7 update then downgrading to 6.6, ether my system is odd in some way or the update is broken

Edited by phileeny
Link to comment
On 5/16/2019 at 12:55 PM, hi2hello said:

Ok, I solved the problem and thought it might help to share this, just in case anyone is hazzling with similar problems. 
Sidenote: Digging a bit deeper in "the bond0-not-found"-problem in several other unRaid forum topics (and there a plenty of them!), it more or less always turned out, that there is something wrong with the USB-Stick (though I still do not get what causes a problem under 6.7 while it is working flawlessly under 6.6*).


Anyway, I deciced to do a fresh and clean install of unRaid 6.6.7, using the unRaid USB-Creator from the download-section.
- I made a backup of the "old" USB-Stick first
- than wiped the USB-Stick and created a new 6.6.7 (on that same stick) with the unRaid USB-Creator
- finally, I took the folder "config" from the previously made backup and put it back on the fresh USB-Stick, overwriting the existing folder (rest remained completely untouched)

- put the stick back into the server and started it

- after unRaid booted into 6.6.7, I repeated the update procedure with the web GUI (tool > update OS) to go for 6.7

- rebooted afterwards

- surprise: 6.7


Don’t ask, I don’t get it! A fine USB-Stick under 6.6, not working under 6.7 …
(Probably one of the downsides of running an OS from a USB-Stick. Just sort of being trustworthy, especially for a server, usually reyling on stability - but that might be just my personal opinion). I just hope the server remains stable (as it always used in the past) …

Whatever: Thanks to everyone trying to help! Much appreciated :)




Your method worked like a charm, thanks! 

Link to comment

I tried the above but it didn't work.

What I did do was to create a brand new copy of 6.7.0 on a new USB stick with the USB Creator, ran make_bootable.exe and did not touch any other file, booted the server with this virgin install and there was no change, still got the following errors.

modprobe: FATAL: Module bonding not found in directory /lib/modules/4.19.41-Unraid

Cannot find device "bond0"

still no network connection to or from the server, no GUI.


The next thing I did was to go into the BIOS and turn off IOMMU and booted my server again, and quess what it worked, no errors fully working virgin install with GUI.



Link to comment
  • 1 month later...

I also just had to revet back to 6.6.7.  It really makes no sense it would be a USB drive issue seeing that 6.6.7 boots just fine and so do 6.7.0, it is just that the server has limited access.  For example, I found it interesting I could update my dockers, but the dockers themselves could not reach the Internet.  So this seems to be a Docker integration issue. 


I am kind of surprised that we have not heard anything from unRAID on this nor has a 6.7.1 come out to fix it as it yet. (Unless I totally missed something post by unRAID on it and how to actually fix it.)

Link to comment
  • 1 month later...

Are there any further updates to this as i've only just come across it and it seems to be similar to what i'm seeing on my 6.7.2 build. I intend to rgress but how do i get back to 6.6.7 as my web gui only offers me 6.7? My system becomes unresponsive at random intervals but i did  notice that my dockers are unable to connect to the internet also. Nothing has changed my end in years other than upgardes so i'm really glad to have stumbled across this discussion although kinda sorry that there seems little update other than that it still seems to need end user intervention after 6.7 upgrades. anyone know if this is on Limetech's radar? My system is a SM x8sia-f, dual nics although only one in use. Could this be confusing things?

Link to comment
23 minutes ago, superloopy1 said:

Thanks, i've now got it .... but i'm a complete novice at all of this and reluctant to start wiping the existing usb stick. Could try a new stick but isnt the key tied to the guid of the stick, how do i get around that one?

You don't have to wipe the USB flash drive or lose your configuration.  Just download and extract the 6.6.7 files to a folder and then copy all the bz* files over to the root of the unRAID USB flash drive.  That downgrades all the important files.


If you want to use a new USB stick, you can transfer the license to the GUID of the new flash drive.  Limetech lets you do this once a year.

Edited by Hoopster
Link to comment

Thanks, i'll give it a go.

Just one thing which stands out ... in my network.cfg file there are a couple of references to 'use dhcp6=Y',  i've no idea whether these are giving me grief as i cant see where these are in the settings to 'enable', there's only reference to dhcp4. Anyone any ideas? These lines do not appear in the pre-6.7 releases.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.