Jump to content
Taddeusz

SATA Parity Write Cache Disabled

28 posts in this topic Last Reply

Recommended Posts

For whatever reason I've recently been looking at the write cache on my drives. All of my array drives are showing write cache enabled except for my parity drive. Is this by design?

 

When I try to manually set the write cache on that drive using hdparm this is what I get so it never gets enabled:

root@unRAID:~# hdparm -W 1 /dev/sdj

/dev/sdj:
 setting drive write-caching to 1 (on)
 write-caching =  0 (off)

 

unraid-diagnostics-20190513-1345.zip

Share this post


Link to post
34 minutes ago, Taddeusz said:

Is this by design?

No, some drives come with it disabled, mostly enterprise drives, though it appears to be happening with more and more drives recently.

Share this post


Link to post
19 minutes ago, johnnie.black said:

No, some drives come with it disabled, mostly enterprise drives, though it appears to be happening with more and more drives recently.

The drive I'm having problems with is an enterprise drive, a WD WD4000FYYZ Re/RE4 4TB. It's also on a separate cross-flashed IBM M1015. The rest of the drives are on a cross-flashed Dell H310. I've not found any information from WD on enabling the write cache on the drive. I can try moving the drive either to the H310 or to one of my motherboard's SATA ports.

Share this post


Link to post

You're not the first where hdparm fails to enable it, but IIRC just second one, the other user tried different controllers and didn't make a difference, but it won't hurt to try.

Share this post


Link to post
On 5/13/2019 at 10:23 AM, johnnie.black said:

No, some drives come with it disabled, mostly enterprise drives, though it appears to be happening with more and more drives recently.

 

thread hijack: I upgraded one of my servers to 6.7.0 today and received a message from fix common problems that my cache (dual ssd mirror) and 2 enterprise drives had their cache off. I input the command above for each and they enabled and I saw fast speeds like I haven't had before on the server cache drive(s).

 

So why does this happen? and is the command above persistent or needs to be applied at reboot?

Share this post


Link to post
 
thread hijack: I upgraded one of my servers to 6.7.0 today and received a message from fix common problems that my cache (dual ssd mirror) and 2 enterprise drives had their cache off. I input the command above for each and they enabled and I saw fast speeds like I haven't had before on the server cache drive(s).
 
So why does this happen? and is the command above persistent or needs to be applied at reboot?
Turn off and on and see if FCP yells at you again...

Sent via telekinesis

Share this post


Link to post
Posted (edited)

I too experienced this after 6.7, I have been using the EXACT same config and hardware for 6 months and went through all r versions of the 6.7 build without issue. Mine is showing on disc 1,3, and 4 of the array. Something in the update disabled it just on these discs not all of them, they are ALL identical WD red Pro 10tb drives.

here are my results. I can not get it to enable.

 

root@MediaServer:~# hdparm -W 1 /dev/sdf

/dev/sdf:
 setting drive write-caching to 1 (on)
 write-caching =  0 (off)
root@MediaServer:~# hdparm -W 1 /dev/sdg

/dev/sdg:
 setting drive write-caching to 1 (on)
 write-caching =  0 (off)

root@MediaServer:~# hdparm -W 1 /dev/sdd

/dev/sdd:
 setting drive write-caching to 1 (on)
 write-caching =  0 (off)
root@MediaServer:~# 

Edited by olschool
Added my results

Share this post


Link to post
10 hours ago, olschool said:

too experienced this after 6.7,

Personally, I doubt this has anything to do with 6.7  If you found out via FCP, then it's simply that the test for this went in at the same time that 6.7 was released

Share this post


Link to post
Just now, Squid said:

I doubt this has anything to do with 6.7

Yes, AFAIK this is a disk setting, not kernel related

Share this post


Link to post
5 hours ago, Squid said:

Personally, I doubt this has anything to do with 6.7  If you found out via FCP, then it's simply that the test for this went in at the same time that 6.7 was released

Can you please explain how to correct it? Again I have not edited anything added or removed anything, and had the exact same setup for 6 months. Something changed, but it wasn't across all discs. Theses discs are actually on seperate controllers from one another, and switching them does not help. I have tried HD parm with array active, the array stopped, rebooted several times, but still will not enable the write cache.

 

The discs themselves return no errors in  SMART or overall parity scans. They are all identical discs and added at the same time, one has less then 100 megs of data on it and stays spun down most of the time because it isn't needed in the array because storage hasn't reached the need for it. I run FCP on a schedule every few days and on reboots. 

 

Any assistance with correcting it is greatly appreciated. 

Share this post


Link to post
6 hours ago, johnnie.black said:

Yes, AFAIK this is a disk setting, not kernel related

Thank you for your input. Can you please refer me to the disc setting that I need to change for this to return to normal function?

Share this post


Link to post

hdparm -W 0 /dev/sdX  disables write cache

hdparm -W 1 /dev/sdX enables

Share this post


Link to post
1 minute ago, olschool said:

Can you please refer me to the disc setting that I need to change for this to return to normal function?

See first post on this thread, assuming it's a SATA disk.

Share this post


Link to post
10 minutes ago, Squid said:

hdparm -W 0 /dev/sdX  disables write cache

hdparm -W 1 /dev/sdX enables

I posted my results from doing this in my previous comments on all three discs and the indication that it is not enableing. I even tried disabling, even though it is already disabled, and the enabling it, but it is not enabling. 

 

Can you provide a means to fix the hdparm commands not working properly? Thank you.

Share this post


Link to post
12 minutes ago, johnnie.black said:

See first post on this thread, assuming it's a SATA disk.

Please see the results in my post that you replied to. I already tried this under all of the conditions I stated. Is there an alternative means or a way to force it to enable? Thank you 

Share this post


Link to post
Just now, olschool said:

Please see the results in my post that you replied to.

Sorry, didn't notice, that's one of the problems with posting in an existing thread.

 

1 minute ago, olschool said:

Is there an alternative means or a way to force it to enable?

Not that I know of.

 

So you're saying write cache was enable on those disks before v6.7? Or that yo never got a warning from FCP before?

 

 

 

Share this post


Link to post
1 minute ago, johnnie.black said:

Sorry, didn't notice, that's one of the problems with posting in an existing thread.

 

Not that I know of.

 

So you're saying write cache was enable on those disks before v6.7? Or that yo never got a warning from FCP before?

 

 

 

Both. Prior to updating those discs worked flawlessly with zero errors in FCP. I run regular scans in FCP over the past 6 months, same discs and hardware the entire time, and no issues. I update to 6.7 reboot and boom the cache write errors on only 3 of the 8 identical discs, 2 are parity disc. 

 

It is very odd that this write cache function has worked without issue all of this time with the only change being the update. As far as troubleshooting the hardware they are on an Adaptec 16 port pie controller that also has been in place the entire time. The discs that are showing this error are on the same breakouts from the controller as discs without these errors. I eveneed  swapped the drives to the cables of the discs not showing the errors and the issues are following these three discs.

 

Thank you for your time

Share this post


Link to post

Have you checked the cache is enabled if you run an earlier Unraid release?    I believe that check has only just been added to FCP so you could have had the issue without realising it.

Share this post


Link to post
4 minutes ago, olschool said:

Prior to updating those discs worked flawlessly with zero errors in FCP

Like @Squidmentioned FCP only started testing for this now, write cache was already disable, you just didn't know.

Share this post


Link to post
57 minutes ago, olschool said:

It is very odd that this write cache function has worked without issue all

It should be noted though that this isn't an "issue" per se (why it's simply a warning in FCP)  The side effect of write cache being disabled is slower access to the drive(s).

Share this post


Link to post

As the OP I just thought I would chime in that I’m NOT getting a cache warning from FCP.


Sent from my iPhone using Tapatalk

Share this post


Link to post
As the OP I just thought I would chime in that I’m NOT getting a cache warning from FCP.


Sent from my iPhone using Tapatalk
Either you haven't updated FCP or your parity drive is spun down when the test runs

Sent via telekinesis

Share this post


Link to post
Either you haven't updated FCP or your parity drive is spun down when the test runs

Sent via telekinesis



Neither, I have the latest version of FCP and I don’t spin down drives.


Sent from my iPhone using Tapatalk

Share this post


Link to post
5 hours ago, johnnie.black said:

Like @Squidmentioned FCP only started testing for this now, write cache was already disable, you just didn't know.

Thank you and Squid. I apologize as I understood what you both were saying differently. I understand now that this is a new feature with the new release. My frustration is not being able to enable it, so is that a flaw in the drive itself or the way the drive is communicating with the unraid software? 

I would like to find a way to fix or repair it if possible. The unraid parity write speeds suck as it is, but to disable the disc cache just compounds the issue and frustration

Share this post


Link to post

Probably best to check / ask on WD's support forum.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.