Jump to content
Sign in to follow this  
fl0at

[SOLVED] [6.7.0] Active Directory / Cannot access shares

2 posts in this topic Last Reply

Recommended Posts

Posted (edited)

I'm on trial, trying to get this thing to meet my needs because I really want to use this as my NAS.  But I'm running into some pretty basic configuration issues.  Everything from small things like TLD not being honored in Network Settings, to the biggest thing, which is that I cannot access user shares over SMB, when domain joined.

 

Here are my steps:

 

Client PC: Windows 10, 1803

 

AD/DC:

Windows Server 2016

Domain: KH.LOCAL

 

Unraid:

Networking Settings DNS points to AD/DC.

Unraid Server Name (Settings -> Identification): DROP.KH.LOCAL

SMB (Settings - > SMB) set to Yes, Active Directory

 

Join AD using a domain admin (also the account testing from the client PC)

I can verify I've joined by going inside Active Directory Users and Computers in the AD/DC, and see that the Unraid server is listed.

 

I can go in terminal and ping:

KH.LOCAL and get a response, or any other computer on the domain, and get a response.  I can also ping other computers on the domain just by computer name, without needing FQDN.  I can ping DROP which resolves to the right IP.  I can ping DROP.KH.LOCAL which resolves to 127.0.0.1

 

I cannot ping DROP.KH.LOCAL, from anywhere else, though.  Or DROP.  Or drop.  Or drop.kh.local.  I cannot access the web ui over drop.kh.local, either.

 

But, I continue along, anyway.  I start the array, and add a share, Test.  The only thing I set is the name.  I then click on it and see that export is Yes, and security is public.

 

Now, at this point, when SMB is using workgroups, under SMB column on Shares, it'll show "Public" or whatever the permissions is.  Here, I get "-"

 

I stop the array and reboot.  Just in case.  I come back in, I verify still domain joined.  Can still ping from Unraid to the ad/dc, and other computers on the network.

 

I then try to using File Explorer to open address \\drop\ or \\DROP\ or \\drop\Test or \\DROP\Test or \\drop.kh.local\ or \\Drop.kh.local, nothing works. 

 

Anyone got AD working that can give me a hand?

 

 

 

 

 

Edited by fl0at
Solved

Share this post


Link to post

Going to mark as solved, but here is solution.

 

Joining Domain not sufficient, here.  Have to also add a host entry to the AD through DNS manager.

 

So for me, in WS2016, I went to DNS, Forward Lookup, selected Domain, then right clicked in space to bring up context menu.

 

Then add host 

 

Name: DROP

FQDN: DROP.KH.LOCAL

IP:  Static IP as set in Unraid

 

Add host, then can navigate to shares.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this