Jump to content
Sign in to follow this  
DougG

Disk 3 after upgrade

8 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Everything has been running fine, upgraded to 6.7.0 and rebooted.  Disk 3 is "Unmountable: No file system".  I ran  xfs_repair -n, then  xfs_repair, then currenly running  xfs_repair -L.

It's been running for 8+ hours.

Seems to be stuck on "resetting inode 4321574511 nlinks from 11 to 9"

 

Any help would be appreciated.

 

2019_05_16_06_14_05_unraid.png

dransik-diagnostics-20190516-0910.zip

Edited by DougG

Share this post


Link to post

I have cancelled and ran it 2x more.  Let it run for over 36 hours total.

Still the same....

resetting inode 4321574511 nlinks from 11 to 9

 

any ideas?

 

Edited by DougG

Share this post


Link to post
4 hours ago, DougG said:

any ideas?

xfs_repair should always finish, with more or less data loss as needed, if it's not finishing there's some bug, you can try updating to the latest xfsprogs and run it again:

 

-create a folder called extra on your flash drive

-download xfsprogs 5.0.0 and copy it to the new extra folder

-reboot Unraid, and check new xfsprogs installed by running xfs_repair -V

-run xfs_repair again

 

If that doesn't work your best bet is to ask for help on the xfs mailing list.

Share this post


Link to post

johnnie.black,

 

thank you.  Updating to  xfsprogs 5.0.0 finished my checkdisk and upon reboot, my array came back up.

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this