Jump to content
bnr32jason

VM Installations Constantly Failing

5 posts in this topic Last Reply

Recommended Posts

I've had limited success with VM's in the past, although I've at least been able to get them to install. Trying to get setup two Windows 10 VM's, after several failures, I finally got one to install, but the other one has been giving me even more problems. I've tried installing to a M.2 NVME, the array, an unassigned HDD, and even the cache, all either give me a BSOD almost immediately or make it anywhere from 20-60% through the "Getting files ready..." phase of the installation and then freezes up. When this happens it actually freezes the entire unRAID server and I have to hard reboot by holding down the power button. I've tried different ISOs, and even tried a Ubuntu ISO just to see, it froze up at the very beginning of the install too.

 

While creating the VM I've tried different BIOS settings, changing from IDE to USB to SATA, changing the location, etc. Tried assigning only CPU 0, 2/4/6/8 CPU's, varying amounts of RAM, CPU passthrough and QEMU. While installing I've tried two different versions of Windows (April and October update) ISO files, different versions of Win10 within the install (Home, Pro, Education).

Specs:
unRAID 6.7.0 (also tried 6.4.1 which also failed so I upgraded today)

i9-9900k, 64GB DDR4-3000, Asus Maximus XI Code, GTX 1080Ti, etc.

Not sure what other info I can give, hoping someone can help guide me to a solution, thanks for the help!

Share this post


Link to post

Those are exactly the guides I have followed this time and before, but my installation fails every time.

Share this post


Link to post

try using seabios instead of ovmf

Share this post


Link to post
18 minutes ago, fluisterben said:

I see lots of misconfigurations with PCI buses and network bridges with unraid. My VMs suddenly stop working or fail to start up because of that, mostly. Something keeps changing buses or network bridges within unraid, but doesn't adapt VM xml files to those changes. I haven't bought unraid yet, but it does come across as not very well tested, to be honest. I had a perfectly fine VM, just failed to even start after upgrading to the latest stable unraid. They really need to test unraid on more different boards and hardware.

 

your comment has zero to do with my suggestion. if after trying seabios and it doesn't work, the next step is to look at what bios the Mobo is running and see if there is an update.

 

from reading your other posts, I get that you're a bit frustrated. but your problem of xml changes with a virtual bus after changing vm settings have nothing to do with just trying to get a fresh windows 10 install. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.