Jump to content
kbrutlag

No Internet access after 6.7.0 update (SOLVED)

4 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Updated yesterday from 6.6.7 and noticed tonight that none of my dockers were able to access the Internet.  Started doing some digging, and found that it's not the dockers, but the system in general.  I have storage/GUI access and can ping to my firewall, but when I try to go further (ping 1.1.1.1) I get an immediate 'ping: connect: Network is unreachable'.  I have two network interfaces (10G and 1G) both with static IP/DNS/gateway settings.  One thing I find odd is, when I shutdown the 1G interface I could still ping the IP, so I tested removing its network cable - still able to ping it.

 

Looking for a little direction on this one.

 

Thanks much

unraid-1-diagnostics-20190517-0218.zip

Edited by kbrutlag

Share this post


Link to post

I am not a real expert in this area but you seem to have three Network adapters in your server--- eth0, eth1, eth2.  Apparently you are only using two of them for the server-- eth0 and eth1.  

 

The ethtool.txt diagnostics file is showing that eth1 does not have an active link to the switch.  That is where I would start looking...

Share this post


Link to post

You have three interfaces defined in the same network (192.168.166.x) this is not recommended as it may lead to routing issues.

Also using jumbo frames (9000) may lead to unexpected behavior. Better start off with the default MTU size.

 

Edit the "network.cfg" in the /config folder on your USB device and put the following content (eth1 and eth2 are removed)

# Generated settings:
IFNAME[0]="eth0"
DHCP_KEEPRESOLV="yes"
DNS_SERVER1="192.168.166.1"
DNS_SERVER2="1.1.1.1"
DNS_SERVER3="8.8.8.8"
DHCP6_KEEPRESOLV="no"
DESCRIPTION[0]="10 GB"
PROTOCOL[0]="ipv4"
USE_DHCP[0]="no"
IPADDR[0]="192.168.166.23"
NETMASK[0]="255.255.255.0"
GATEWAY[0]="192.168.166.1"
METRIC[0]="1"
USE_DHCP6[0]="yes"
MTU[0]=""
SYSNICS="1"

After saving the file, reboot your system.

 

This makes interface eth0 (your 10G interface) the single interface to communicate. Make sure this 10G interface has internet access to your router.

 

Share this post


Link to post

bonienl - thanks much!  This got everything going again.  Not sure what happened with the network settings during the update, but all good now.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.