Jump to content
lordvaderxiii

HELP: BTRFS Cache Convert Error

3 posts in this topic Last Reply

Recommended Posts

Hi All

 

Im having an issue with BTRFS, I have added a second cache drive and when I try to do the ballance it fails. with 

kernel: BTRFS error (device sdi1): balance: invalid convert metadata profile raid1

Ballance looks like this 

 

Data, single: total=25.00GiB, used=23.93GiB
System, single: total=32.00MiB, used=16.00KiB
Metadata, single: total=2.00GiB, used=53.83MiB
GlobalReserve, single: total=16.00MiB, used=0.00B

 

No balance found on '/mnt/cache'

 

I ran 

-dconvert=single -mconvert=raid0

And then I tried it in the console and got

[ 9856.213350] BTRFS error (device sdi1): balance: invalid convert data profile raid0

 

Here is what my drives look like

 

imageproxy.php?img=&key=00b562fcac28e727imageproxy.php?img=&key=00b562fcac28e727imageproxy.php?img=&key=00b562fcac28e727imageproxy.php?img=&key=00b562fcac28e727unraidbtrfs.thumb.PNG.bcec843eba596de131ffb5d635d968f8.PNG

 

 

tower-diagnostics-20190517-0616.zip

Share this post


Link to post

Pool is only one device, despite two being assigned, stop array, unassign cache2, start array, stop array, re-assign cache2.

 

38 minutes ago, lordvaderxiii said:

-dconvert=single -mconvert=raid0

Also this isn't a recommend profile, -d is for data, -m is for metadata, after the pool is correct and if you want raid0 use:

-dconvert=raid0 -mconvert=raid1

 

if you want raid1:

-dconvert=raid1 -mconvert=raid1

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.