Jump to content
nraygun

Borg mount as a share

3 posts in this topic Last Reply

Recommended Posts

I'm a noob still experimenting with unRaid 6.7.0 and borg 1.1.9.

 

How can I mount a borg repository such that it's available via a share?

 

I can mount the repository to a directory in unRaid in the terminal and the contents are displayed correctly in another terminal.

I tried to create a share, then mounted the borg repository to that share expecting the contents to appear. I connect to this share as admin, but it only shows the contents of the root of the unRaid server and oddly, the mount point directory does not display anywhere in this directory structure.

I created a share called borgmount, then issued this command:

borg mount -f /mnt/disks/backup1/backup1 /mnt/user/borgmount

The borg repository is on an unassigned disk.

If I connect as admin to the disk where the share's directory resides, it's empty.

I noticed before issuing the command, the share has owner:group of nobody:users, but then when the borg mount command is running it's root:root.

There's probably some sort of permissions thing going on, but I can't figure it out.

Any ideas?

Share this post


Link to post

I also tried setting up a rootshare as described in one of Space Invader's videos. The borgmount directory doesn't show up.

I tried my own user account, root, and admin as the accounts.

No go.

Share this post


Link to post

Got it! Good ol' IRC...

Just add "-o allow_other" to the borg mount command like this:

sudo borg mount -f -o allow_other /mnt/disks/backup1/backup1 /mnt/user/borgmount

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.