Jump to content
javier911

Trying to resurrect my old unraid server - back to 1 disk down

7 posts in this topic Last Reply

Recommended Posts

Posted (edited)

UPDATE: The "missing" disk came back when I added more disks to the external PSU.  So it's probably a power issue, correct?  So now I still have the one failed disk, I still could use some advice on how to proceed.  Thanks

 

Unraid 5.0.5 on an old DDR2 AMD system, I forget exactly which CPU it is.  10 disks total, 9x 2TB data and 1x 4TB parity.  I cannot recall the PSU specs and I can't see the label on it now but it's an Antec.

 

Long time ago, one of my disks "red balled", I cannot remember everything I did now, but the disk always seemed to be OK after tests and whatever steps I took, but it kept going to red ball, so I'd shut off the box and months would pass before I'd have a try again.  In the end I decided it must be either a cable issue or insufficient PSU.

 

Now I'm trying again, I had that one failed (red balled) disk, same as the past.  I disconnected all the SATA cables because it was a mess in there, this allowed me to check the power connectors and all the SATA cables carefully.

 

I put them all back and now another disk is reporting as "missing", as I talked about in the other thread.  I've changed the missing disk's SATA cable, still missing, I've switched a few disks to an external PSU to see if it's due to insufficient power, still missing.  I thought about the SATA port on the motherboard as the possible culprit, but it shows up in POST.

The "missing" disk has returned.

 

On that note, does unraid care what controller or port a disk has been connected to?  I could move the missing disk onto my PCI-E card which still has 3 ports free.

 

I could also try swapping out the PSU with the most powerful PSU I have on hand which is an approximately 1-2 year old 650w.

 

Another option is to just abandon this box entirely.  With the external PSU connected for a few days, get whatever I can off the array.

 

Edited by javier911

Share this post


Link to post
2 hours ago, javier911 said:

On that note, does unraid care what controller or port a disk has been connected to?  I could move the missing disk onto my PCI-E card which still has 3 ports free.

Depends on the version of unraid.

Share this post


Link to post
Posted (edited)
38 minutes ago, jonathanm said:

Depends on the version of unraid.

Sorry it's 5.0.5.  But I guess I don't need to try moving it to the PCI-E card now since the missing disk came back.

 

Any other advice you have on how to proceed would be greatly appreciated though.  I looked up old posts from when I first started having the original failed disk issue.  Initially I did the "Trust My Array" procedure and I screwed it up a bit, but then someone told me to do this and it worked:

Quote

 

Your data should be fine, and you can use the V6 procedure for 5.0.5.

 

Go to tools -> New config, reassign all disks, check "parity is already valid" and start array.

 

Should I do that again now that I'm testing with an external PSU and see if the disk red balls again?

 

Another suggestion after I solved the trust messup was this:

Quote

You should run a non correcting parity check to make sure the failed disk is really OK, if there are sync errors but no disk errors then run a correcting check.

I don't know if that has any relevance now.

 

Thanks for all the help.

 

Edited by javier911

Share this post


Link to post

With the array as it is right now, can you start it and see the files on the emulated red ball disk and the rest of the array?

Share this post


Link to post
Posted (edited)
18 hours ago, jonathanm said:

With the array as it is right now, can you start it and see the files on the emulated red ball disk and the rest of the array?

Yes the array automatically started when it rebooted after I connected more disks to the external PSU.  I can see and copy files from it, and if I go to the direct share for the disk that's red balled, \\unraid\disk2, I can see and open the files in there.  The size of some directories, that is the total of all the filesizes in them, seem smaller than I remember, but that could just be my memory.

 

I'm using a util to copy some files now and I'm looking at the the list of failed copies, there's a bunch but they're small files in very long paths so maybe just some quirk Windows cannot handle.

 

UPDATE: There was some kind of error several times in the logs while copying those files, text file attached.

unraid_errors_during_copy1.txt

 

UPDATE 2: I should not have powered it down yesterday but with this external PSU setup and such I felt it wasn't a good idea to leave it running overnight.  Unfortunately now there are more problems, there's Buffer I/O errors when it's starting up, I don't recall seeing them or at least not as many before.  Another disk now says "unformatted" so there goes another 2TB of stuff.  It's just getting worse and worse.

Edited by javier911

Share this post


Link to post
Posted (edited)

IF I remember correcting 5.0.5 uses reiserfs as the file system on data drives.  I would suggest that you google  mount reiserfs in windows  (or whatever OS your PC is using) and look to see if there is a way you could read these disks on another system.  That would allow you to copy the files off of any working disks onto new media.

 

Personally, I would be looking at building a totally new server using 6TB to 10TB parity and data drives and move the data to it.  (The only piece of hardware I would recycle would possibly be the case.)  From the data that I have seen, bigger hard drives have roughly the same failure rate as smaller drives.  

Edited by Frank1940

Share this post


Link to post

Thanks for the reply.  I was getting some help from people in a chat and I've gotten most of the the data off now.  Part of that was done the same way you suggested, I setup another PC with Ubuntu live USB and pulled the unraid disk and read/copied it there.

 

There's still that other disk that suddenly went "unformatted".  Attempts to reiserfsck --check on it do not work, neither when it was in the array using the md device or on Ubuntu, both exit with an error something like "bread: cannot read from block".  Any ideas how that could be recovered?  I guess at this point with little to lose, I could setup the unraid array again, force it to re-accept that first failed disk that was always actually OK, and then let it simulate the "unformatted" disk contents?

 

I'd like to have unraid going again but purchasing a bunch of new large disks just isn't possible for me at this time.  I probably will use some extra parts I have to build a new unraid box but re-use most of the same disks, I'll be sure to pre-clear and check them extensively though.  To speed that up I'll look into running those pre-clear and checks on another fast machine with a temporary unraid install or some kinda live Linux.

 

I understand why you suggested ditching the drives though.  If I make a "new" array I won't think of it as a backup, I know that's a bad idea and admittedly I've been guilty of that in the past which is why I always had to move so slow and carefully when I started having problems, which led to this being drawn out over years :).

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.