Jump to content
linuxserver.io

[Support] Linuxserver.io - Calibre

16 posts in this topic Last Reply

Recommended Posts

linuxserver_medium.thumb.png.ae48d9a767a3f3ac8ea306b445417b03.png

Application Name: Calibre
Application Site: https://calibre-ebook.com/
Docker Hub: https://hub.docker.com/r/linuxserver/calibre/
Github: https://github.com/linuxserver/docker-calibre

 

Please post any questions/issues relating to this docker you have in this thread.

If you are not using Unraid (and you should be!) then please do not post here, rather use the linuxserver.io forum for support.

Share this post


Link to post

just installed this container. Great job.

I have imported my library and for now it's working very well.

Share this post


Link to post

I installed this container using the recommended settings, but I'm having trouble getting it to load. This is my log in unRAID:

 



ErrorWarningSystemArrayLogin

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 10-adduser: executing...

-------------------------------------
_ ()
| | ___ _ __
| | / __| | | / \
| | \__ \ | | | () |
|_| |___/ |_| \__/


Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/donate/
-------------------------------------
GID/UID
-------------------------------------

User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 11-moduser: executing...
[cont-init.d] 11-moduser: exited 0.
[cont-init.d] 12-prep_xrdp: executing...
[cont-init.d] 12-prep_xrdp: exited 0.
[cont-init.d] 13-update_app_name: executing...
[cont-init.d] 13-update_app_name: exited 0.
[cont-init.d] 14-configure_openbox: executing...
[cont-init.d] 14-configure_openbox: exited 0.
[cont-init.d] 30-update_webapp_context: executing...
[cont-init.d] 30-update_webapp_context: exited 0.
[cont-init.d] 35-update_guac_creds: executing...
[cont-init.d] 35-update_guac_creds: exited 0.
[cont-init.d] 50-config: executing...
[cont-init.d] 50-config: exited 0.
[cont-init.d] 99-custom-scripts: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-scripts: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
Unable to find an X display. Ensure you have permission to connect to the display.
Unable to find an X display. Ensure you have permission to connect to the display.
Unable to find an X display. Ensure you have permission to connect to the display.
Unable to find an X display. Ensure you have permission to connect to the display.
guacd[399]: INFO: Guacamole proxy daemon (guacd) version 0.9.14 started
guacd[399]: INFO: Listening on host 127.0.0.1, port 4822

X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-138-generic x86_64 Ubuntu
Current Operating System: Linux d6347f2f1113 4.19.48-Unraid #1 SMP Wed Jun 5 09:16:04 PDT 2019 x86_64
Kernel command line: BOOT_IMAGE=/bzimage initrd=/bzroot
Build Date: 25 October 2018 04:11:27PM
xorg-server 2:1.19.6-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.pid-400.log", Time: Tue Jun 18 16:19:15 2019
(++) Using config file: "/etc/X11/xrdp/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xorgxrdpSetup:
xrdpdevSetup:
rdpmousePlug:
rdpkeybPlug:
rdpIdentify:
rdpDriverFunc: op 10

:
rdpPreInit:
rdpScreenInit: virtualX 800 virtualY 600 rgbBits 8 depth 24
rdpScreenInit: pfbMemory bytes 1920000
rdpScreenInit: pfbMemory 0x14afe13be010
rdpSimdInit: assigning yuv functions
rdpSimdInit: cpuid ax 1 cx 0 return ax 0x000406d8 bx 0x0a100800 cx 0x43d8e3bf dx 0xbfebfbff
rdpSimdInit: sse2 amd64 yuv functions assigned
rdpXvInit: depth 24
rdpClientConInit: kill disconnected [0] timeout [0] sec

rdpScreenInit: out
rdpmousePreInit: drv 0x564dcdb22e10 info 0x564dcdc9e460, flags 0x0
rdpmouseControl: what 0
rdpmouseDeviceInit:
rdpmouseCtrl:
rdpRegisterInputCallback: type 1 proc 0x14afe1797c60
rdpmouseControl: what 1
rdpmouseDeviceOn:
rdpkeybPreInit: drv 0x564dcdb21a20 info 0x564dcde0f080, flags 0x0
rdpkeybControl: what 0
rdpkeybDeviceInit:
rdpkeybChangeKeyboardControl:
rdpkeybChangeKeyboardControl: autoRepeat on
rdpRegisterInputCallback: type 0 proc 0x14afe1594530
rdpkeybControl: what 1
rdpkeybDeviceOn:
rdpSaveScreen:
rdpDeferredRandR:
rdpResizeSession: width 1024 height 768
calling RRScreenSizeSet
rdpRRScreenSetSize: width 1024 height 768 mmWidth 271 mmHeight 203
rdpRRGetInfo:
screen resized to 1024x768
RRScreenSizeSet ok 1
rdpInDeferredUpdateCallback:
rdpkeybChangeKeyboardControl:
rdpkeybChangeKeyboardControl: autoRepeat off
Warning: Cannot convert string "-*-helvetica-bold-r-normal--*-120-*-*-*-*-iso8859-1" to type FontStruct
Warning: Cannot convert string "-*-courier-medium-r-normal--*-120-*-*-*-*-iso8859-1" to type FontStruct
s6-svwait: fatal: timed out
s6-svwait: fatal: timed out
rdpRRGetInfo:
Obt-Message: Xinerama extension is not present on the server
Openbox-Message: Unable to find a valid menu file "/var/lib/openbox/debian-menu.xml"
ERROR: openbox-xdg-autostart requires PyXDG to be installed


s6-svwait: fatal: timed out
s6-svwait: fatal: timed out
s6-svwait: fatal: timed out

 

Any ideas?

Share this post


Link to post

Is there any option to deal with accented characters ?

I can't import files with accents or from a folder with a name with accents.

Share this post


Link to post
On 6/18/2019 at 4:23 PM, zandrsn said:

 

Any ideas?

Anyone know what could be causing the problem I mentioned above? Thanks.

Share this post


Link to post
Anyone know what could be causing the problem I mentioned above? Thanks.
Post your docker run command

Sent from my Mi A1 using Tapatalk

Share this post


Link to post

I installed this docker through Community Applications, so didn't use my own docker run command, but the one that CA generated was:

docker run -d --name='calibre' --net='bridge' -e TZ="America/New_York" -e HOST_OS="Unraid" -e 'GUAC_USER'='' -e 'GUAC_PASS'='' -e 'PUID'='99' -e 'PGID'='100' -p '8787:8080/tcp' -p '8788:8081/tcp' -v '/mnt/user/Media/Books/Library/':'/books':'rw' -v '/mnt/user/Downloads/Books/':'/import':'rw' -v '/mnt/cache/appdata/calibre':'/config':'rw' 'linuxserver/calibre' 

 

Share this post


Link to post
I installed this docker through Community Applications, so didn't use my own docker run command, but the one that CA generated was:
docker run -d --name='calibre' --net='bridge' -e TZ="America/New_York" -e HOST_OS="Unraid" -e 'GUAC_USER'='' -e 'GUAC_PASS'='' -e 'PUID'='99' -e 'PGID'='100' -p '8787:8080/tcp' -p '8788:8081/tcp' -v '/mnt/user/Media/Books/Library/':'/books':'rw' -v '/mnt/user/Downloads/Books/':'/import':'rw' -v '/mnt/cache/appdata/calibre':'/config':'rw' 'linuxserver/calibre' 

 

Try setting guac user and guac password

Sent from my Mi A1 using Tapatalk

Share this post


Link to post
6 hours ago, CHBMB said:

Try setting guac user and guac password

Sent from my Mi A1 using Tapatalk
 

Just did and had the same response:
 



ErrorWarningSystemArrayLogin

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 10-adduser: executing...

-------------------------------------
_ ()
| | ___ _ __
| | / __| | | / \
| | \__ \ | | | () |
|_| |___/ |_| \__/


Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/donate/
-------------------------------------
GID/UID
-------------------------------------

User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 11-moduser: executing...
[cont-init.d] 11-moduser: exited 0.
[cont-init.d] 12-prep_xrdp: executing...
[cont-init.d] 12-prep_xrdp: exited 0.
[cont-init.d] 13-update_app_name: executing...
[cont-init.d] 13-update_app_name: exited 0.
[cont-init.d] 14-configure_openbox: executing...
[cont-init.d] 14-configure_openbox: exited 0.
[cont-init.d] 30-update_webapp_context: executing...
[cont-init.d] 30-update_webapp_context: exited 0.
[cont-init.d] 35-update_guac_creds: executing...
[cont-init.d] 35-update_guac_creds: exited 0.
[cont-init.d] 50-config: executing...
[cont-init.d] 50-config: exited 0.
[cont-init.d] 99-custom-scripts: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-scripts: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
Unable to find an X display. Ensure you have permission to connect to the display.
Unable to find an X display. Ensure you have permission to connect to the display.
Unable to find an X display. Ensure you have permission to connect to the display.

X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-148-generic x86_64 Ubuntu
Current Operating System: Linux f9c52acf4ca0 4.19.56-Unraid #1 SMP Tue Jun 25 10:19:34 PDT 2019 x86_64
Kernel command line: BOOT_IMAGE=/bzimage initrd=/bzroot
Build Date: 03 June 2019 08:10:35AM
xorg-server 2:1.19.6-1ubuntu4.3 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.pid-404.log", Time: Sun Jul 14 17:16:34 2019
guacd[410]: INFO: Guacamole proxy daemon (guacd) version 0.9.14 started
guacd[410]: INFO: Listening on host 127.0.0.1, port 4822
(++) Using config file: "/etc/X11/xrdp/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xorgxrdpSetup:
guacd[410]: INFO: Guacamole connection closed during handshake
xrdpdevSetup:
rdpmousePlug:
rdpkeybPlug:
rdpIdentify:
rdpDriverFunc: op 10

:
rdpPreInit:
rdpScreenInit: virtualX 800 virtualY 600 rgbBits 8 depth 24
rdpScreenInit: pfbMemory bytes 1920000
rdpScreenInit: pfbMemory 0x14f602442010
rdpSimdInit: assigning yuv functions
rdpSimdInit: cpuid ax 1 cx 0 return ax 0x000406d8 bx 0x0e100800 cx 0x43d8e3bf dx 0xbfebfbff
rdpSimdInit: sse2 amd64 yuv functions assigned
rdpXvInit: depth 24
rdpClientConInit: kill disconnected [0] timeout [0] sec

rdpScreenInit: out
rdpmousePreInit: drv 0x5581ab517e10 info 0x5581ab693450, flags 0x0
rdpmouseControl: what 0
rdpmouseDeviceInit:
rdpmouseCtrl:
rdpRegisterInputCallback: type 1 proc 0x14f60281bc60
rdpmouseControl: what 1
rdpmouseDeviceOn:
rdpkeybPreInit: drv 0x5581ab516a20 info 0x5581ab804070, flags 0x0
rdpkeybControl: what 0
rdpkeybDeviceInit:
rdpkeybChangeKeyboardControl:
rdpkeybChangeKeyboardControl: autoRepeat on
rdpRegisterInputCallback: type 0 proc 0x14f602618530
rdpkeybControl: what 1
rdpkeybDeviceOn:
rdpSaveScreen:
rdpDeferredRandR:
rdpResizeSession: width 1024 height 768
calling RRScreenSizeSet
rdpRRScreenSetSize: width 1024 height 768 mmWidth 271 mmHeight 203
rdpRRGetInfo:
screen resized to 1024x768
RRScreenSizeSet ok 1
rdpInDeferredUpdateCallback:
rdpkeybChangeKeyboardControl:
rdpkeybChangeKeyboardControl: autoRepeat off
Warning: Cannot convert string "-*-helvetica-bold-r-normal--*-120-*-*-*-*-iso8859-1" to type FontStruct
Warning: Cannot convert string "-*-courier-medium-r-normal--*-120-*-*-*-*-iso8859-1" to type FontStruct
rdpRRGetInfo:
Obt-Message: Xinerama extension is not present on the server
Openbox-Message: Unable to find a valid menu file "/var/lib/openbox/debian-menu.xml"
s6-svwait: fatal: timed out
s6-svwait: fatal: timed out
s6-svwait: fatal: timed out
ERROR: openbox-xdg-autostart requires PyXDG to be installed

s6-svwait: fatal: timed out

 

Share this post


Link to post
1 hour ago, zandrsn said:

Just did and had the same response:
 




ErrorWarningSystemArrayLogin

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 10-adduser: executing...

-------------------------------------
_ ()
| | ___ _ __
| | / __| | | / \
| | \__ \ | | | () |
|_| |___/ |_| \__/


Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/donate/
-------------------------------------
GID/UID
-------------------------------------

User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 11-moduser: executing...
[cont-init.d] 11-moduser: exited 0.
[cont-init.d] 12-prep_xrdp: executing...
[cont-init.d] 12-prep_xrdp: exited 0.
[cont-init.d] 13-update_app_name: executing...
[cont-init.d] 13-update_app_name: exited 0.
[cont-init.d] 14-configure_openbox: executing...
[cont-init.d] 14-configure_openbox: exited 0.
[cont-init.d] 30-update_webapp_context: executing...
[cont-init.d] 30-update_webapp_context: exited 0.
[cont-init.d] 35-update_guac_creds: executing...
[cont-init.d] 35-update_guac_creds: exited 0.
[cont-init.d] 50-config: executing...
[cont-init.d] 50-config: exited 0.
[cont-init.d] 99-custom-scripts: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-scripts: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
Unable to find an X display. Ensure you have permission to connect to the display.
Unable to find an X display. Ensure you have permission to connect to the display.
Unable to find an X display. Ensure you have permission to connect to the display.

X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-148-generic x86_64 Ubuntu
Current Operating System: Linux f9c52acf4ca0 4.19.56-Unraid #1 SMP Tue Jun 25 10:19:34 PDT 2019 x86_64
Kernel command line: BOOT_IMAGE=/bzimage initrd=/bzroot
Build Date: 03 June 2019 08:10:35AM
xorg-server 2:1.19.6-1ubuntu4.3 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.pid-404.log", Time: Sun Jul 14 17:16:34 2019
guacd[410]: INFO: Guacamole proxy daemon (guacd) version 0.9.14 started
guacd[410]: INFO: Listening on host 127.0.0.1, port 4822
(++) Using config file: "/etc/X11/xrdp/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xorgxrdpSetup:
guacd[410]: INFO: Guacamole connection closed during handshake
xrdpdevSetup:
rdpmousePlug:
rdpkeybPlug:
rdpIdentify:
rdpDriverFunc: op 10

:
rdpPreInit:
rdpScreenInit: virtualX 800 virtualY 600 rgbBits 8 depth 24
rdpScreenInit: pfbMemory bytes 1920000
rdpScreenInit: pfbMemory 0x14f602442010
rdpSimdInit: assigning yuv functions
rdpSimdInit: cpuid ax 1 cx 0 return ax 0x000406d8 bx 0x0e100800 cx 0x43d8e3bf dx 0xbfebfbff
rdpSimdInit: sse2 amd64 yuv functions assigned
rdpXvInit: depth 24
rdpClientConInit: kill disconnected [0] timeout [0] sec

rdpScreenInit: out
rdpmousePreInit: drv 0x5581ab517e10 info 0x5581ab693450, flags 0x0
rdpmouseControl: what 0
rdpmouseDeviceInit:
rdpmouseCtrl:
rdpRegisterInputCallback: type 1 proc 0x14f60281bc60
rdpmouseControl: what 1
rdpmouseDeviceOn:
rdpkeybPreInit: drv 0x5581ab516a20 info 0x5581ab804070, flags 0x0
rdpkeybControl: what 0
rdpkeybDeviceInit:
rdpkeybChangeKeyboardControl:
rdpkeybChangeKeyboardControl: autoRepeat on
rdpRegisterInputCallback: type 0 proc 0x14f602618530
rdpkeybControl: what 1
rdpkeybDeviceOn:
rdpSaveScreen:
rdpDeferredRandR:
rdpResizeSession: width 1024 height 768
calling RRScreenSizeSet
rdpRRScreenSetSize: width 1024 height 768 mmWidth 271 mmHeight 203
rdpRRGetInfo:
screen resized to 1024x768
RRScreenSizeSet ok 1
rdpInDeferredUpdateCallback:
rdpkeybChangeKeyboardControl:
rdpkeybChangeKeyboardControl: autoRepeat off
Warning: Cannot convert string "-*-helvetica-bold-r-normal--*-120-*-*-*-*-iso8859-1" to type FontStruct
Warning: Cannot convert string "-*-courier-medium-r-normal--*-120-*-*-*-*-iso8859-1" to type FontStruct
rdpRRGetInfo:
Obt-Message: Xinerama extension is not present on the server
Openbox-Message: Unable to find a valid menu file "/var/lib/openbox/debian-menu.xml"
s6-svwait: fatal: timed out
s6-svwait: fatal: timed out
s6-svwait: fatal: timed out
ERROR: openbox-xdg-autostart requires PyXDG to be installed

s6-svwait: fatal: timed out

 

Remove your existing appdata, put a username in for GUAC_USER and try using this GUAC_PASS

 

d41d8cd98f00b204e9800998ecf8427e

 

That's the md5 hash of an empty password

Share this post


Link to post
50 minutes ago, CHBMB said:

Remove your existing appdata, put a username in for GUAC_USER and try using this GUAC_PASS

 

d41d8cd98f00b204e9800998ecf8427e

 

That's the md5 hash of an empty password

Same result...

 



ErrorWarningSystemArrayLogin

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 10-adduser: executing...

-------------------------------------
_ ()
| | ___ _ __
| | / __| | | / \
| | \__ \ | | | () |
|_| |___/ |_| \__/


Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/donate/
-------------------------------------
GID/UID
-------------------------------------

User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 11-moduser: executing...
[cont-init.d] 11-moduser: exited 0.
[cont-init.d] 12-prep_xrdp: executing...
[cont-init.d] 12-prep_xrdp: exited 0.
[cont-init.d] 13-update_app_name: executing...
[cont-init.d] 13-update_app_name: exited 0.
[cont-init.d] 14-configure_openbox: executing...
[cont-init.d] 14-configure_openbox: exited 0.
[cont-init.d] 30-update_webapp_context: executing...
[cont-init.d] 30-update_webapp_context: exited 0.
[cont-init.d] 35-update_guac_creds: executing...
[cont-init.d] 35-update_guac_creds: exited 0.
[cont-init.d] 50-config: executing...
[cont-init.d] 50-config: exited 0.
[cont-init.d] 99-custom-scripts: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-scripts: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
Unable to find an X display. Ensure you have permission to connect to the display.
guacd[410]: INFO: Guacamole proxy daemon (guacd) version 0.9.14 started
guacd[410]: INFO: Listening on host 127.0.0.1, port 4822

X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-148-generic x86_64 Ubuntu
Current Operating System: Linux 0d383648e74d 4.19.56-Unraid #1 SMP Tue Jun 25 10:19:34 PDT 2019 x86_64
Kernel command line: BOOT_IMAGE=/bzimage initrd=/bzroot
Build Date: 03 June 2019 08:10:35AM
xorg-server 2:1.19.6-1ubuntu4.3 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.pid-402.log", Time: Sun Jul 14 19:20:59 2019
(++) Using config file: "/etc/X11/xrdp/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xorgxrdpSetup:
xrdpdevSetup:
rdpmousePlug:
rdpkeybPlug:
rdpIdentify:
rdpDriverFunc: op 10

:
rdpPreInit:
rdpScreenInit: virtualX 800 virtualY 600 rgbBits 8 depth 24
rdpScreenInit: pfbMemory bytes 1920000
rdpScreenInit: pfbMemory 0x146bf7b05010
rdpSimdInit: assigning yuv functions
rdpSimdInit: cpuid ax 1 cx 0 return ax 0x000406d8 bx 0x0e100800 cx 0x43d8e3bf dx 0xbfebfbff
rdpSimdInit: sse2 amd64 yuv functions assigned
rdpXvInit: depth 24
rdpClientConInit: kill disconnected [0] timeout [0] sec

rdpScreenInit: out
guacd[410]: INFO: Guacamole connection closed during handshake
rdpmousePreInit: drv 0x560ea9bfae10 info 0x560ea9d76450, flags 0x0
rdpmouseControl: what 0
rdpmouseDeviceInit:
rdpmouseCtrl:
rdpRegisterInputCallback: type 1 proc 0x146bf7edec60
rdpmouseControl: what 1
rdpmouseDeviceOn:
rdpkeybPreInit: drv 0x560ea9bf9a20 info 0x560ea9ee7070, flags 0x0
rdpkeybControl: what 0
rdpkeybDeviceInit:
rdpkeybChangeKeyboardControl:
rdpkeybChangeKeyboardControl: autoRepeat on
rdpRegisterInputCallback: type 0 proc 0x146bf7cdb530
rdpkeybControl: what 1
rdpkeybDeviceOn:
rdpSaveScreen:
rdpDeferredRandR:
rdpResizeSession: width 1024 height 768
calling RRScreenSizeSet
rdpRRScreenSetSize: width 1024 height 768 mmWidth 271 mmHeight 203
rdpRRGetInfo:
screen resized to 1024x768
RRScreenSizeSet ok 1
rdpInDeferredUpdateCallback:
rdpkeybChangeKeyboardControl:
rdpkeybChangeKeyboardControl: autoRepeat off
Warning: Cannot convert string "-*-helvetica-bold-r-normal--*-120-*-*-*-*-iso8859-1" to type FontStruct
Warning: Cannot convert string "-*-courier-medium-r-normal--*-120-*-*-*-*-iso8859-1" to type FontStruct
rdpRRGetInfo:
Obt-Message: Xinerama extension is not present on the server
Openbox-Message: Unable to find a valid menu file "/var/lib/openbox/debian-menu.xml"
ERROR: openbox-xdg-autostart requires PyXDG to be installed

s6-svwait: fatal: timed out

 

Share this post


Link to post

Try again after removing the container and image and running

 

rm -rf /mnt/cache/appdata/calibre

Share this post


Link to post

How are you transferring the books to your devices when Calibre is running on it's own IP? I can use the content server but that will download the epub file, and not give me the option to create a library within my ereader.

Share this post


Link to post
Posted (edited)

Thanks for the container, it's great to have a Calibre app with regular updates! I'm having a bit of trouble configuring reverse proxy for the container though. I use nginx (in fact your LetsEncrypt container) I want to use a variable in proxy_pass so the proxy can start even if the Calibre container is shut down. So far I have been unable to make it work with variables. The following configuration without variables works just fine:

location = /calibre { return 301 $scheme://$http_host/calibre/; }
location /calibre/ {
    proxy_pass http://calibre:8080/;
}

However, when I try to use a variable, it stops working:

location = /calibre { return 301 $scheme://$http_host/calibre/; }
location ~ ^/calibre/(.*)$ {
    # Avoid nginx startup failure if host is not available
    set $calibre_host calibre;
    proxy_pass http://$calibre_host:8080/$1;
}

The problem seems to be one resource that fails to load via angular.js:

https://<network address>/calibre/api/session/data/noauth/connectionGroups/ROOT/tree?token=<long token string>

The server returns 403 Forbidden error.

 

All other resources load just fine. This happens regardless of using basic auth in my proxy or not. It also happens if I use a username and password with the environment variables or leave them empty. Interestingly, the password prompt does show up and entering a wrong password gives an error "Invalid Login", but the right user/password combination results in an auth resource not loading with error code 403. Does anyone have any idea what could be causing this and how to correct it?

Edited by sam19

Share this post


Link to post
2 hours ago, sam19 said:

Thanks for the container, it's great to have a Calibre app with regular updates! I'm having a bit of trouble configuring reverse proxy for the container though. I use nginx (in fact your LetsEncrypt container) I want to use a variable in proxy_pass so the proxy can start even if the Calibre container is shut down. So far I have been unable to make it work with variables. The following configuration without variables works just fine:


location = /calibre { return 301 $scheme://$http_host/calibre/; }
location /calibre/ {
    proxy_pass http://calibre:8080/;
}

However, when I try to use a variable, it stops working:


location = /calibre { return 301 $scheme://$http_host/calibre/; }
location ~ ^/calibre/(.*)$ {
    # Avoid nginx startup failure if host is not available
    set $calibre_host calibre;
    proxy_pass http://$calibre_host:8080/$1;
}

The problem seems to be one resource that fails to load via angular.js:

https://<network address>/calibre/api/session/data/noauth/connectionGroups/ROOT/tree?token=<long token string>

The server returns 403 Forbidden error.

 

All other resources load just fine. This happens regardless of using basic auth in my proxy or not. It also happens if I use a username and password with the environment variables or leave them empty. Interestingly, the password prompt does show up and entering a wrong password gives an error "Invalid Login", but the right user/password combination results in an auth resource not loading with error code 403. Does anyone have any idea what could be causing this and how to correct it?

There is already both a subdomain and subfolder proxy conf in our let's encrypt container.

Share this post


Link to post

Okay, I have absolutely no idea why my config didn't work and your example config did (in fact I had already tried a virtually identical config with rewrite before), but now it's working as intended. I might actually convert all of my other app location blocks to use rewrite as well. Thanks for the tip, @saarg!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.