Jump to content
linuxserver.io

[Support] Linuxserver.io - Clarkson

13 posts in this topic Last Reply

Recommended Posts

linuxserver_medium.thumb.png.c9e905c8f85717e1818f9315768eca8a.png

Application Name: Clarkson

Application Site: https://github.com/linuxserver/Clarkson

Docker Hub: https://hub.docker.com/r/linuxserver/clarkson/

Github: https://github.com/linuxserver/docker-clarkson

 

Please post any questions/issues relating to this docker you have in this thread.

 

If you are not using Unraid (and you should be!) then please do not post here, instead head to linuxserver.io to see how to get support.

 

Note:  This requires MySQL v5.7.* and is not compatible with MariaDB, this is due to a limitation in flyway.

Share this post


Link to post

I am having issues getting this to work with the MySQL docker image available in the community applications section... I am not new to unraid but I am by no means a pro.  If someone has gotten this app to work with dockers on their unraid setup, a little help would be appreciated...

I keep getting connection refused or something can't recall now... I was able to connect to the mysql setup with MySQL Workbench but Clarkson would fail on docker start no matter what I used for credentials.

 

Edit:  I have now gotten the 2 to communicate... just can't seem to register the initial account as I am getting a 500 error in the logs.

To fix the first issue was to make sure to use the 5.7.26 tag of the mysql docker

 

Edit2:  Not sure what the issue was but I nuked everything and started over and got it installed... Thanks anyways as I prob didn't give much time for posts lol

Edited by Repooc

Share this post


Link to post

Same issue as user above.

 

Container config asks for user, but from log output, looks like it's trying w/o password.

ERROR:
Unable to obtain Jdbc connection from DataSource (jdbc:mysql://x.x.x.x) for user 'clarkson': Could not connect: Access denied for user 'clarkson'@'172.17.0.1' (using password: NO)
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
SQL State  : 28000
Error Code : 1045
Message    : Could not connect: Access denied for user 'clarkson'@'172.17.0.1' (using password: NO)

I did ensure the user and password were created ahead of time. 

DB created ahead of time.

Share this post


Link to post

Followed instructions a little closer, and saw the mysql:5.7 dependency.

Once that was deployed correctly; all is fine.

 

Derp.

Edited by TQ

Share this post


Link to post

Hello,

 

I have got Clarkson started and connected to MySQL database. However Im not able to register for an account. I have enabled registrations, but when I go to register the page just seems to not commit?

Share this post


Link to post
On 2/19/2020 at 11:33 AM, p.wrangles said:

Hello,

 

I have got Clarkson started and connected to MySQL database. However Im not able to register for an account. I have enabled registrations, but when I go to register the page just seems to not commit?

I am having the same issue. Did you find the solution?

Share this post


Link to post

Hello, I did , however it was so long ago I can't remember exactly. However, looking back over my notes, it seems like it was to do with the way I was creating the DB.

 

Try deleting everything, Then create the DB in MySQL using the below command then install Clarkson. I think it was to do with using CREATE SCHEMA instead of CREATE DATABASE.

 

CREATE SCHEMA `clarkson`;
CREATE USER 'clarkson' IDENTIFIED BY 'clarkson';
GRANT ALL ON `clarkson`.* TO 'clarkson';

 

Share this post


Link to post
On 4/15/2020 at 10:53 AM, cyberfreakde said:

I am having the same issue. Did you find the solution?

Hey @cyberfreakde - did you find a solution?  p.wrangles doesn't seem to work for me. 

Share this post


Link to post
51 minutes ago, noja said:

Hey @cyberfreakde - did you find a solution?  p.wrangles doesn't seem to work for me. 

Nope.. Tried everything I know and read,  still won't work. 😔

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.