Jump to content
boianski

Plex Docker Disappeared, Unable to Re-Install

7 posts in this topic Last Reply

Recommended Posts

Hi all,

 

I was watching something on Plex last night before bed, when all of a sudden it stopped. I logged in to UnRaid to find that the docker for plex (and only that docker) had disappeared. All shares are fine, no data loss, unraid machine never went offline. I am totally unsure how this happened, the only changes I've recently made is to get a new router. Maybe plex tried to update and something happened? Also tried re-installing and was not able to do so. Im really lost. I've included some screen shots. 

 

 

chrome_2019-06-12_08-57-20.png

chrome_2019-06-12_08-57-34.png

chrome_2019-06-12_08-57-55.png

Share this post


Link to post

I get this error message when I try to re-install it: 
 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="plex" --net="host" -e TZ="America/New_York" -e HOST_OS="unRAID" -e "VERSION"="docker" -e "NVIDIA_VISIBLE_DEVICES"="" -e "TCP_PORT_32400"="32400" -e "TCP_PORT_3005"="3005" -e "TCP_PORT_8324"="8324" -e "TCP_PORT_32469"="32469" -e "UDP_PORT_1900"="1900" -e "UDP_PORT_32410"="32410" -e "UDP_PORT_32412"="32412" -e "UDP_PORT_32413"="32413" -e "UDP_PORT_32414"="32414" -e "PUID"="99" -e "100"="100" -v "/mnt/user/Media/":"/movies":rw -v "/mnt/user/Media/":"/tv":rw -v "":"/music":rw -v "":"/transcode":rw -v "/mnt/user/appdata/plex":"/config":rw linuxserver/plex

/usr/bin/docker: Error response from daemon: invalid volume spec ":/music:rw": invalid volume specification: ':/music:rw'.
See '/usr/bin/docker run --help'.

The command failed.

 

u/ritonlajoie on reddit said: 

Look at your -v arguments they are wrong. It should be -v "/xxx:/yyy", not -v "/xxx":"/yyy". Your double quotes are wrong

 

im so lost. 

 

chrome_2019-06-12_21-12-39.thumb.png.42af21201e175382ef1426ce9a95b454.png

Share this post


Link to post

From the command, it appears you do not have a host path set for the music path. Edit the container and fix

Sent via telekinesis

Share this post


Link to post

The host path for /transcode also appears to be empty.

Share this post


Link to post

I think you have a bigger problem at hands here.

What maesters itimpi and squid told you is why your Plex docker failed to install i.e. your paths are wrong.

 

Dockers can auto update but it should be doing that with the same config i.e. paths.

 

They usually don't suddenly reinstall itself with new paths and certainly would not have installed previously with the same wrong paths. Hence, the only plausible conclusion here is something / someone has changed the paths.

 

Based on your description "when all of a sudden it stopped", it was done without your knowledge. So you need to dig deep into it. Perhaps you were hacked (especially if your server is exposed to the Internet). Perhaps someone in your household had itchy hands. Or perhaps it's something else behind the scene entirely.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.