Jump to content
Husker_N7242C

Cache read only after btrfs balance - VMs and docker service won't start

3 posts in this topic Last Reply

Recommended Posts

Guys, my cache pool was unbalanced which was causing it to pause the VMs for no reason. I ran the btrfs balance start -dusage=50 /mnt/cache from terminal which completed successfully then I tried to run btrfs balance 75 but it gave an error that the cache was read only. The VMs and docker service crashed shortly after and I'm stuck.

 

I ran docker safe permissions but it didn't help.

 

I'd appreciate some advice. Thanks!

nas-diagnostics-20190614-0801.zip

Share this post


Link to post

Balance failed, there's likely metadata corruption, you can reboot and try again though it will probably fail again, if not done already before rebooting back up any important data on cache.

 

If it fails again best to backup, re-format and restore pool.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.