Jump to content
Sign in to follow this  
Ouze

(solved) dell poweredge c2100, how to downgrade BMC firmware to reduce fan noise?

3 posts in this topic Last Reply

Recommended Posts

Posted (edited)

hello all,

 

I bought a dell poweredge c2100 for my second Unraid build. I've built many PCs but this is my first actual commercial server - the other Unraid build was a Supermicro board in a Norco 4224. 

 

This server is 2u and it is very, very loud. It appears the fans run at 100%, all the time, which is like 5k rpm. They are not in a particularly warm room. With the Norco, I removed the 80mm screamers and replaced them with a 120mm fan plate and some nice quiet Noctuas, but this doesn't seem like a viable option here - changing to different fans would seem to cause lots of fan alerts, according to Google. 

 

What google said was that BMC firmware of 1.7.0 and below didn't have this problem, the fans idled at around 3k rpms. I'd like to downgrade as I am at 1.82.

 

Here is where I am running into trouble: I don't know what I am doing. 

 

I enabled dedicated NIC for BMC and plugged in a cable. I set an IP in the bios, then logged into BMC, changed to a secure password. I am not clear exactly what to do now. When I go into the "firmware update" section of BMC, which seems very straightforward, I see an option to upload a new firmware.  I tried getting the appropriate firmware from here: https://www.dell.com/support/home/ae/en/aebsdt1/drivers/driversdetails?driverid=hh9ww   but... the files I see on here don't seem to actually contain the correct bin I need to upload, and the instructions included with the files are... very not clear to me.

 

What is the easiest way to do this? 

 

Thanks!

 

Edited by Ouze
solved issue

Share this post


Link to post

OK, I figured it out. Turns out there was nothing wrong with my process, I just wasn't waiting long enough. After the bin file is uploaded, it just sits there for about 8 minutes, but it did indeed then finally update and I have my issue fixed. 3500RPM fans now, much better!

Share this post


Link to post

Can you tell me what bin file you ended up using exactly?  I have downloaded over 10 BMC Update files all from the Dell sites, and the only response I get from the unit is "Check failed 0x84"

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this