Can't access share after transferring file with cache enabled

Recommended Posts

I am relatively new to both Linux and Unraid and have come unstuck and don't know where to go with diagnosing this issue and I'm not having much luck googling the issue. 
So I have a share called 'Documents' with 'Use cache disk' enabled and I am exporting it with smb private share giving my user read/write permissions. I can access the share from Windows just fine until I create or copy a file to the share. Then I lose access to the share and Windows displays a network error saying I don't have permission to access the share.
If I head to the Unraid web ui and run the mover I can then access the share again.
This issue occurs on any share that I allow to use the cache disk.

This makes me think that the file created on the cache drive doesn't have read permissions for my user. When I head into /mnt/user/cache I can see the folder with the share name 'Documents' and inside it is the file I copied. If I run ls -la the permissions are:

 drwxrwx---+ 2 nobody users

The same permissions are set for the share when I navigate to /mnt/user/Documents both inside the Documents share file and for the Documents share itself.

I also used the groups command to check my user had the group 'users' assigned and restarted the machine.
I am running Windows 10 1809 on the client and Unraid 6.7.0 on the server. I'm not entirely sure when this issue arose but it could have been when I upgraded from Unraid 6.6.
Any help would be appreciated, thanks.

Link to comment
  • 4 weeks later...

I am having the same issue.  

I have a share called "Main" that I created years ago and have had no problems accessing it until today.  

I attempted a reboot of my windows 10 machine, then the server and the win10 machine, and neither helped.

I thought it was a SMB issue, but after some trouble shooting I realized that I could access some child folders and but not all child folders but I could not drill down from parent to child:

I could access Main\Downloads\folder1 (I had to type it out or use an existing shortcut to the location)

I could access Main\Downloads\folder2 (I had to type it out or use an existing shortcut to the location)

I could not access Main\Downloads\folder3

       (this folder has files on the cache drive folder1 and folder2 do not have files on cache drive)

I cannot access Main\Downloads (I am guess it is because of folder3 having files on the cache drive)

I can Main\ (which I would have thought I would not be able to because of folder3 having files on the cache drive)


I invoked mover to see what this would do, but it did not seem to help.

I installed the "Tips and Tweaks" Plugin and changed my "Max Watches 'fs.inotify.max_user_watches'" from 524288 to 2524288

   (just added a 2 to the front of the default value, and will play around with this value over time, if need be.)

   see Still not enough inotify watches?

As soon as I adjusted the inotify value, I could access folder1, folder2 and any other problem folder I had.


Not sure if these will help but I attached the diagnostics file before and after the inotify changes.


Unfortunately I invoked mover and also adjusted the inotify value with in minutes of each other, so I am not certain which of the changes allowed access to the offending folders.


Thanks dlandon for the plugin Tips and Tweaks !

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.