Recommended Posts

Hey there,

I have been using Unraid for about a month now having had one 6tb drive, a 6tb parity and a small SSD cache drive.

I was looking to add another couple of my old WD my books to my array to get more storage, however I have run into issues with both drives on pre-clear and S.M.A.R.T, but these drives were working fine on Windows machine before hand and when I plug them into my windows machine, format them and look at S.M.A.R.T on there, they appear fine.

I have tried swapping the sata cables, power cables, sata slots and still the same issues.

One of the drives failed on a post-read initially, but cleared fine, so i added it to the array and then found S.M.A.R.T issues, so i took it out of the array and ran pre-clear again, however this time it failed on the pre-read. I have attached an image to this thread, to see if anyone can make sense of the errors. I have also attached the S.M.A.R.T diagnostics for this drive, which again makes no sense to me and i am hoping someone can help me.

I haven';t got the diagnostics for the other drive, as I have been changing things so much to figure out whats going on, but still no results.

Could someone please help? 



Screen Shot 2019-06-21 at 06.42.08.png


Link to comment
12 minutes ago, coldjim said:

how come this drive passes in windows?

SMART test will still fail on Windows, SMART it's not OS dependent.


13 minutes ago, coldjim said:

Is there nothing i can do to fix it?

You can try a full write cycle, but most likely it will fail again right or soon after.

Link to comment
11 minutes ago, coldjim said:

how come this drive passes in windows? Is there nothing i can do to fix it?

Did you try running the SMART tests on Windows?  What about running the manufacturer’s tools to carry out a thorough test?   The SMART report you posted shows the drive has failed SMART tests.


Windows will often continue to use a disk with problems and you get away with it if you do not end up accessing the problem area.   Unraid requires the whole disk to be OK as if it is not then it will not be able to recover a different drive if it fails.

Link to comment
2 hours ago, coldjim said:

yes i tried running it in Windows and all appears fine there, but on unraid it fails on pre-clear and S.M.A.R.T, thats why im so confused. 

I havent used the manufacturers tools yet. 

What did you use on Windows to tun the SMART tests?    Windows does not have this built in so you would have had to either use a third party tool or the manufacturer’s diagnostic software.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.