[Support] Linuxserver.io - Code-server


180 posts in this topic Last Reply

Recommended Posts

Got this setup but I can't drop my SSH key in the .ssh folder. It's grayed out. When I check permissions it says I have read/write but when I try to drop it in, it just doesn't go. Doesn't say I don't have permissions, just doesn't do anything. Thanks for all your hard work!

Screen Shot 2020-04-06 at 9.50.08 PM.png

Link to post
  • Replies 179
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

We have not made a proxy confs for subdirectory. Didn't find an option to set a prefix for subfolder in code-servers documentation.

Root access in gui terminal is not very secure, the official container running as root is also not secure.   If you want to add packages to this container and you want them to be persistent,

Code server is hosting their own marketplace because the licenses prevent them from accessing the official Microsoft marketplace. There may be some issues with some of the extensions. You should repor

Posted Images

2 hours ago, adambeck7 said:

Got this setup but I can't drop my SSH key in the .ssh folder. It's grayed out. When I check permissions it says I have read/write but when I try to drop it in, it just doesn't go. Doesn't say I don't have permissions, just doesn't do anything. Thanks for all your hard work!

Screen Shot 2020-04-06 at 9.50.08 PM.png

 

That just looks like it's greyed out because it's hidden files. Have you tried to open the folder?

I don't know how you are accessing your appdata, but you can also copy them to the appdata folder and move them using the command line to the .ssh folder.

Link to post

Hello,

Probably a dumb question - but how do I install extensions?
I've tried to install the POWERSHELL extension directly throuhg VSCODE - apparently it was installed, but after a reload of the page:

"Unable to find PowerShell. Do you have PowerShell installed?"

 

What is the correct way to install this extension?
Thanks in advice!

 

EDIT: So after reading it TWICE... problem isn't the extension itself.. but that POWERSHELL is missing.

How can I integrate it?

Edited by TDA
Link to post
2 hours ago, TDA said:

Hello,

Probably a dumb question - but how do I install extensions?
I've tried to install the POWERSHELL extension directly throuhg VSCODE - apparently it was installed, but after a reload of the page:

"Unable to find PowerShell. Do you have PowerShell installed?"

 

What is the correct way to install this extension?
Thanks in advice!

 

EDIT: So after reading it TWICE... problem isn't the extension itself.. but that POWERSHELL is missing.

How can I integrate it?

You will have to find a way of installing powershell.

Link to post
2 minutes ago, aptalca said:

You can do a new docker mod. We already provide a few. They are about to officially launch and the readmes will have info on them starting this week.

 

https://mods.linuxserver.io

Ah cool.
I will wait till it's online and then I'll check how to implementate it, cause I use VSCode mainly for PowerShell scripts 🙂

Link to post
7 hours ago, saarg said:

 

That just looks like it's greyed out because it's hidden files. Have you tried to open the folder?

I don't know how you are accessing your appdata, but you can also copy them to the appdata folder and move them using the command line to the .ssh folder.

I was connecting from my macbook via smb. I was able to drop them in the code-server folder then move them into the .ssh folder from the terminal. Thanks!

Link to post
5 hours ago, adambeck7 said:

Alright, next stupid question. My project is running on a web server at localhost:port. How do I access that? Could i set up ngrok on unraid somehow?

You gotta give us more info. Where is it running? Inside the code-server container?

Link to post
15 hours ago, aptalca said:

You gotta give us more info. Where is it running? Inside the code-server container?

Sorry about that. Yea, code-server container is running on my server, just locally, at http://192.168.1.200:8443/. Inside the code-server terminal I navigate to my workspace folder and run my start script for my web app and it says Server listening on http://localhost:3001 but when I navigate there it's not working. Not sure how exactly to access it. 

Link to post
31 minutes ago, adambeck7 said:

Sorry about that. Yea, code-server container is running on my server, just locally, at http://192.168.1.200:8443/. Inside the code-server terminal I navigate to my workspace folder and run my start script for my web app and it says Server listening on http://localhost:3001 but when I navigate there it's not working. Not sure how exactly to access it. 

You have to map the port 3001 so you get access to it outside the container. And you also need to make sure your server is running using your host IP.

Link to post
On 4/8/2020 at 7:46 AM, saarg said:

make sure your server is running using your host IP.

Sorry, not sure exactly what you mean by this second part. 
 

Here's what my port mapping looks like.

 

Edited by adambeck7
Link to post
7 hours ago, adambeck7 said:

Sorry, not sure exactly what you mean by this second part. 
 

Here's what my port mapping looks like.

Screen Shot 2020-04-08 at 8.01.26 AM.png

 

You said you started the script for your web app and it started the server on localhost:3001. So you need to tell your web app server to use the host IP instead of localhost. The host IP is the unraid IP, 192.168.1.200 by the looks of your screenshot.

Link to post
51 minutes ago, saarg said:

 

You said you started the script for your web app and it started the server on localhost:3001. So you need to tell your web app server to use the host IP instead of localhost. The host IP is the unraid IP, 192.168.1.200 by the looks of your screenshot.

Error: listen EADDRNOTAVAIL: address not available 192.168.1.200:3001
    at Server.setupListenHandle [as _listen2] (net.js:1292:21)
    at listenInCluster (net.js:1357:12)
    at doListen (net.js:1496:7)
    at processTicksAndRejections (internal/process/task_queues.js:85:21)
Emitted 'error' event on Server instance at:
    at emitErrorNT (net.js:1336:8)
    at processTicksAndRejections (internal/process/task_queues.js:84:21) {
  code: 'EADDRNOTAVAIL',
  errno: 'EADDRNOTAVAIL',
  syscall: 'listen',
  address: '192.168.1.200',
  port: 3001
}

Not code-server related, but any idea why it would be saying the address isn't available? I tried a few different ports I know are open but it doesn't like any of them so I'm assuming it's having an issue w/ the ip not the port. No matter which IP on my local network it crashes saying the address isn't available.  Thanks for all your help!

Edited by adambeck7
Link to post
2 hours ago, adambeck7 said:

Error: listen EADDRNOTAVAIL: address not available 192.168.1.200:3001
    at Server.setupListenHandle [as _listen2] (net.js:1292:21)
    at listenInCluster (net.js:1357:12)
    at doListen (net.js:1496:7)
    at processTicksAndRejections (internal/process/task_queues.js:85:21)
Emitted 'error' event on Server instance at:
    at emitErrorNT (net.js:1336:8)
    at processTicksAndRejections (internal/process/task_queues.js:84:21) {
  code: 'EADDRNOTAVAIL',
  errno: 'EADDRNOTAVAIL',
  syscall: 'listen',
  address: '192.168.1.200',
  port: 3001
}

Not code-server related, but any idea why it would be saying the address isn't available? I tried a few different ports I know are open but it doesn't like any of them so I'm assuming it's having an issue w/ the ip not the port. No matter which IP on my local network it crashes saying the address isn't available.  Thanks for all your help!

Try 0.0.0.0

Link to post

I searched around a bit but found on information on this topic: every time code-server container updates, it removes everything I installed within it. Stuff from apt (cmake, build-essential, gdb...), as well as manually build libraries like openCV & protobuf which reside in /opt or /usr. Vscode extensions are preserved, but everything else is purged.

 

Am I using the container in ways not intended? Is there a way to avoid this (besides not updating)?

Link to post
1 hour ago, Nihil said:

I searched around a bit but found on information on this topic: every time code-server container updates, it removes everything I installed within it. Stuff from apt (cmake, build-essential, gdb...), as well as manually build libraries like openCV & protobuf which reside in /opt or /usr. Vscode extensions are preserved, but everything else is purged.

 

Am I using the container in ways not intended? Is there a way to avoid this (besides not updating)?

That is how docker container works. Read the blog about customizing our containers at blog.linuxserer.io for info of how to make those packages "survive" an update.

Link to post

Apologies for the noob question, I can't get the script to work. I'm trying to install nodejs. Can anybody see what I'm doing wrong from the logs below?

 

[cont-init.d] 99-custom-scripts: executing...
[custom-init] files found in /config/custom-cont-init.d executing
[custom-init] apt-get update && apt-get install -y nodejs: executing...
/bin/bash: /config/custom-cont-init.d/apt-get: No such file or directory
[custom-init] apt-get update && apt-get install -y nodejs: exited 127
[cont-init.d] 99-custom-scripts: exited 0.
[cont-init.d] done.

Link to post
1 hour ago, mintjberry said:

Apologies for the noob question, I can't get the script to work. I'm trying to install nodejs. Can anybody see what I'm doing wrong from the logs below?

 

[cont-init.d] 99-custom-scripts: executing...
[custom-init] files found in /config/custom-cont-init.d executing
[custom-init] apt-get update && apt-get install -y nodejs: executing...
/bin/bash: /config/custom-cont-init.d/apt-get: No such file or directory
[custom-init] apt-get update && apt-get install -y nodejs: exited 127
[cont-init.d] 99-custom-scripts: exited 0.
[cont-init.d] done.

Can you post your config?

Link to post
4 hours ago, mintjberry said:

Apologies for the noob question, I can't get the script to work. I'm trying to install nodejs. Can anybody see what I'm doing wrong from the logs below?

 

[cont-init.d] 99-custom-scripts: executing...
[custom-init] files found in /config/custom-cont-init.d executing
[custom-init] apt-get update && apt-get install -y nodejs: executing...
/bin/bash: /config/custom-cont-init.d/apt-get: No such file or directory
[custom-init] apt-get update && apt-get install -y nodejs: exited 127
[cont-init.d] 99-custom-scripts: exited 0.
[cont-init.d] done.

Did you look at the link above your post?

Link to post
6 hours ago, aptalca said:

Did you look at the link above your post?

I've also tried that method but couldn't get it to work so I must be doing something wrong.

Here's my code-server environment variable:

image.png.4c593a8aed494cc78c85eaa266c73042.png

 

Yet I still can't get node to run -

image.png.3b61cc0a9a613e4a0f7f9e0044c744f4.png

 

 

 

 

Link to post
1 hour ago, mintjberry said:

I've also tried that method but couldn't get it to work so I must be doing something wrong.

Here's my code-server environment variable:

image.png.4c593a8aed494cc78c85eaa266c73042.png

 

Yet I still can't get node to run -

image.png.3b61cc0a9a613e4a0f7f9e0044c744f4.png

 

 

 

 

`DOCKER_MODS` needs to be in Key. It should look like this

Screen Shot 2020-04-12 at 5.20.59 PM.png

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.