Jump to content
Hman2121

*SOLVED* Install Plugin Issue - Read only file system

8 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Hi there everyone! I am relatively new to Unraid, and have just started getting it setup. However, when trying to install my first plugin, I get this error. Any recommendations to solve this issue?

 

 

Thank you!

errorunraid.JPG

 

Edited by Hman2121

Share this post


Link to post

you should always

 

Go to Tools - Diagnostics and attach the complete diagnostics zip file to your next post.

Share this post


Link to post
5 minutes ago, trurl said:

you should always

 

Go to Tools - Diagnostics and attach the complete diagnostics zip file to your next post.

Hi there! I went ahead and attached it to my post, thank you!

Share this post


Link to post
2 hours ago, trurl said:

attach the complete diagnostics ZIP file to your NEXT post

2 hours ago, Hman2121 said:

I went ahead and attached it to my post

Since I saw the thread had a new post, I visited the thread again. If you had simply added the attachment to the first post without actually making a new post, I would not have come back to this thread since I would not have known there was anything new in it.

 

The diagnostics downloaded from the webUI is already a single zip file. Please just give us the zip file exactly as it was downloaded. There is no need for you to rar it, so no need for us to figure out how to open some other archive format.

 

I will wait for the zip attached to your next post.

Share this post


Link to post
26 minutes ago, Hman2121 said:

Here's the ZIP file. diagnostics-20190703-2315.zip

It appears that key /boot/config/* files are set to read-only  That is the USB flash drive.  Try removing your boot flash from the server and running a chkdsk on it in a Windows machine.  It will likely find and correct file system errors and then the server should boot properly and you should be able to install plugins.

Share this post


Link to post

That is not the diagnostics zip file downloaded from the webUI. It has another diagnostics folder inside it. You must have created that zip file yourself.

 

If you think the download is a bunch of separate files and folders, and so you must zip them up yourself, that is because your computer or browser is configured to automatically open zip files. The download itself is a single zip file, saved into the folder your browser normally uses for downloads, one level up from where you see the separate files and folders after the zip was automatically opened. See if you can figure this out. You should not create a zip file. The diagnostics is already a zip file.

 

All of this trouble we are having right now is why I used these exact words in my first reply:

3 hours ago, trurl said:

Go to Tools - Diagnostics and attach the complete diagnostics zip file to your next post.

 

In any case, the diagnostics show what I already suspected. Your flash drive is corrupt. Shut down, put the flash drive in your PC and let it checkdisk.

 

Are you using a USB2 port on your server to boot from? USB3 ports aren't as reliable for the boot drive, so USB2 is recommended.

Share this post


Link to post
4 minutes ago, Hoopster said:

It appears that key /boot/config/* files are set to read-only  That is the USB flash drive.  Try removing your boot flash from the server and running a chkdsk on it in a Windows machine.  It will likely find and correct file system errors and then the server should boot properly and you should be able to install plugins.

Okay thank you for the help, I will try that!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.