I typically shut my system down carefully, by first stopping the VMs, then stopping the array, then powering down. Today I went straight for "stop array" and ended up with an unclean shutdown. Some research brought me to this helpful post by @dlandon:     Basically, these settings must be in sync to get your system to shutdown gracefully: "Settings->VM Manager->VM Shutdown time-out": must be long enough to allow your VMs to shutdown "Settings->Disk Settings-&