Jump to content
coblck

missing csrf_token

51 posts in this topic Last Reply

Recommended Posts

Will disable tautulli tonight and check in the morning 

Share this post


Link to post
Posted (edited)

Looking back at my syslog, and it first appeared right after loading avahi-daemon.

 

Jul  4 06:22:17 Tower kernel: docker0: port 6(veth7d57666) entered forwarding state
Jul  4 06:22:18 Tower avahi-daemon[22640]: Joining mDNS multicast group on interface veth7d57666.IPv6 with address fe80::682c:f0ff:fe8f:7f06.
Jul  4 06:22:18 Tower avahi-daemon[22640]: New relevant interface veth7d57666.IPv6 for mDNS.
Jul  4 06:22:18 Tower avahi-daemon[22640]: Registering new address record for fe80::682c:f0ff:fe8f:7f06 on veth7d57666.*.
Jul  4 11:47:45 Tower root: error: /gcsp/2.0: missing csrf_token
Jul  4 11:47:45 Tower root: error: /gcsp/2.0: missing csrf_token
Jul  4 11:47:45 Tower root: error: /gcsp/2.0: missing csrf_token

 

Edited by The_Mountain

Share this post


Link to post
Jul  6 00:01:23 Unraid root: /mnt/cache: 1.8 TiB (1980809101312 bytes) trimmed on /dev/sdc1
Jul  6 04:40:01 Unraid root: Fix Common Problems Version 2019.06.30a
Jul  6 04:40:01 Unraid root: Fix Common Problems: Warning: Docker Application jackett has an update available for it
Jul  6 04:40:01 Unraid root: Fix Common Problems: Warning: Docker Application ubooquity has an update available for it
Jul  6 05:05:34 Unraid crond[2688]: exit status 1 from user root /usr/local/sbin/mover &> /dev/null
Jul  6 09:18:35 Unraid root: error: /gcsp/2.0: missing csrf_token
Jul  6 09:18:35 Unraid root: error: /gcsp/2.0: missing csrf_token
Jul  6 09:18:35 Unraid root: error: /gcsp/2.0: missing csrf_token
Jul  6 09:18:35 Unraid root: error: /gcsp/2.0: missing csrf_token
Jul  6 10:23:47 Unraid root: error: /gcsp/2.0: missing csrf_token
Jul  6 10:23:47 Unraid root: error: /gcsp/2.0: missing csrf_token
Jul  6 10:23:47 Unraid root: error: /gcsp/2.0: missing csrf_token
Jul  6 10:23:47 Unraid root: error: /gcsp/2.0: missing csrf_token

Really wasn't much going on before the error started for me. And it began on July 6th on my server.

Share this post


Link to post

I think we have a winner with the Plex docker.  It's currently 4:20 and I didn't get my daily error log spam! 

Share this post


Link to post

I've stopped my tautulli and syncthing. Will find out tomorrow as I only get error at 1am every morning. 

Share this post


Link to post

i disabled my ipv6 on my controller and then restarted avahi-daemon and restarted docker service, and i have not seen the error since.

Share this post


Link to post

still got error at 1am with syncthing and tautulli stopped 

Share this post


Link to post

Just noticed this error this morning has started July 5th, continued the 6th,7th. Stopped for 8th and 9th, then continued every day and did this morning. I haven't began testing but I have a lot more containers than just Plex and Tautulli. 

Share this post


Link to post

I’ve noticed this issue too, and after some troubleshooting it seems to be related to Plex library scanning.

 

Is everyone running the beta server version 1.16.2.1297 ?

The date seems to line up with when I noticed the issue.

 

If I trigger a full scan through the web interface; left menu next to the “Libraries” heading, click the ellipsis/“...”, then “Scan library files”. Wait until it completes, then I see these errors in the Unraid system log.

I have Plex set to do a periodic scan daily, and also I see these errors once a day with no manual interaction.

(I also have partial scanning when changes are detected, and this does not trigger the issue.)

 

Can anyone verify that they’re see the same behaviour, and that the number of repeating logs a day matches their scanning frequency?

 

 

  • Like 1
  • Upvote 1

Share this post


Link to post
Posted (edited)

I think you're right Tyler, I have the same plex version and I have mine set to scan every 12 hours and that's exactly when I'm getting my errors. I did a manual library scan and I got the errors as soon as it started scanning my TV shows library  (it did dvr, movies, music, then TV shows).  Weird thing is if I tell it to just scan the tv shows library it doesn't do it.

Edited by romanodog

Share this post


Link to post

I think I’ve narrowed it down further, seems to be related to Music library scanning.

If I scan music individually I get the errors, with other types of media libraries I don’t.

 

Then went looking in the Plex Server logs, and can see; “Gracenote: Exception at line 1036, error 276889603 (Item not found.)” at the exact same time as the Unraid ones

 

And doing a search for “gcsp gracenote” returns a few hits relating to development with the Gracenote API/SDK.

Share this post


Link to post
3 minutes ago, Tyler said:

I think I’ve narrowed it down further, seems to be related to Music library scanning.

If I scan music individually I get the errors, with other types of media libraries I don’t.

 

Then went looking in the Plex Server logs, and can see; “Gracenote: Exception at line 1036, error 276889603 (Item not found.)” at the exact same time as the Unraid ones

 

And doing a search for “gcsp gracenote” returns a few hits relating to development with the Gracenote API/SDK.

Yup you're right, that's what happens to me when I scan music.

Share this post


Link to post

I'm on the same PMS version mentioned above. And I get the errors every time I scan my music library. So I think that's where the issue is.

Share this post


Link to post

Thanks for the work and information on this. In my case disabling the Plex Docker all but eliminated any errors. Didn't let it run a full 24 but log went from blood red to nothing. I'm on Version 1.16.1.1291. Out of curiosity how do I get detailed info about the actual docker container? Must just be a duh moment but I'll be dam'd if I can find it. I remember it being the one that was listed as from Plex and all updates that have popped up have been installed.

 

I'm going to try and disable music scanning and see what shakes out.

Share this post


Link to post
3 hours ago, drawmonster said:

I'm on the same PMS version mentioned above. And I get the errors every time I scan my music library. So I think that's where the issue is.

Same here. Version 1.16.2.1297. Happens only when I scan the music library.

Share this post


Link to post

So disabled plex docker last night no error using Version 1.16.0.1226, have unticked include music library's during scan to see if helps 

Share this post


Link to post
Posted (edited)

That's more than 4 of us seeing the issue with same symptoms, got to be something on the Plex PMS side of things.

Have created a thread over in their forum: https://forums.plex.tv/t/pms-beta-1-16-2-1297-errors-when-scanning-music-library-related-to-gracenote-gcsp/433087

Feel free to chime in.

 

1 hour ago, coblck said:

have unticked include music library's during scan to see if helps 

Unfortunately I doubt that'll help, I have that as my usual setting and still see the errors.

Edited by Tyler

Share this post


Link to post
1 hour ago, Tyler said:

Unfortunately I doubt that'll help, I have that as my usual setting and still see the errors.

Thanks 

 

Share this post


Link to post

I believe this is because Plex have stopped using Gracenote, so there will be problems with the music library until the transition is complete! Plex never give a time frame so I guess we wait!

Share this post


Link to post

Just updated to the new Plex Beta 1.16.3.1402 and I'm no longer getting the errors.

Share this post


Link to post
6 hours ago, sourCream said:

Just updated to the new Plex Beta 1.16.3.1402 and I'm no longer getting the errors.

Yep me either — just updated and I’m also not seeing the errors in either Unraid system log or PMS log.

Share this post


Link to post

Great news just waiting on my docker to update now. Great work guys and thanks. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.