Jump to content
Sign in to follow this  
Kuno Claes

External IP DHCP not working in VM

3 posts in this topic Last Reply

Recommended Posts

Hello,

I have an older laptop running Unraid and it works good. Now i have created a vlan in my unifi switch that switches the internet directly from my modem. If i add the vlan in unraid it works. Unraid gets an ip and i can even bridge it to a docker container. But if i create a vm it doesnt get an ip from my ISP DHCP. I cant configure a static ip because my isp has blocked that. The network adaptor on the vm works but only if i have it connected to my router.

 

Can anyone help me please for getting it to work with an external ip.

 

I know that i can use 16 ips and if i connect my pc to my modem it works.

Share this post


Link to post

What type of network adapter have you configured for the VM?    It needs to be a bridged variant to get an IP from an external server.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this