[KERNEL]custom kernel build with treaks (2020.03.07 v6.8.3|5.5.8|4.19.108|NAVI|VEGA|NFSv4|R8125|Zen2)

Recommended Posts

On 10/12/2019 at 1:51 PM, sturmstar said:

I have already tested if the gpu bug is fixed with the default kernel ... nope, still not working in 6.8 RC1 

Which bug do you mean? 127 type error of GPU?

I can build a custom kernel if someone really need (actually I am using custom build kernel with custom drivers of using 6.8 RC1).

Edited by Leoyzen
Link to comment
On 10/14/2019 at 8:34 AM, Leoyzen said:

Which bug do you mean? 127 type error of GPU?

I can build a custom kernel if someone really need (actually I am using custom build kernel with custom drivers of using 6.8 RC1).

would be awesome if you could share the newer build around 6.8 rc1

Link to comment

I have a gaming PC I've been struggling with.  2700X with ASUS x470-f Gaming and latest firmware Version 5220 2019/09/24 and a XFX RX 580.  I've tried everything I could think of to get this GPU pass-through to work in unRAID and of course get the D3 and 127 error etc.  I would like to try a custom kernel fix instead of risking a bricked motherboard with a BIOS downgrade.   


Looking at this fix that supports x570 motherboards,  would this still work with my configuration?  


How do I add it to the kernel.  I'm rather tech savvy but obviously looking in the wrong places for an explanation.  

Link to comment
1 hour ago, Leoyzen said:

@MortalMonkeyAccording to some people's feedback, the kernel sgould work.Just download it and put it into your usb stick.

Its really that easy?  No wonder I was overthinking the process.  Any particular location on the usb drive to place the file?  Also I see the file from OP is unavailable for download.  Another web link to access the file?  Thank You

Link to comment

@Leoyzen Thats honestly weird as heck!!! That download link failed for me yesterday and this evening after your first reply but just worked for me.  Maybe this is a sign I need to give it a break and get a good nights sleep and try this out this weekend when my mind is fresh.  


I keep getting this 2 gamers 1 cpu itch and finally trying to sit down and configure it on my gaming desktop.  I build the wife and I identical gaming pcs but i just need to try this out.  


Thanks again.  

Link to comment
9 hours ago, Leoyzen said:

Edit at 2019.10.18

Update kernel with :

1. support unRaid 6.8.0rc1

2. add AGESA reset fix patch

3. update r8125 ethernet driver

4. add zenpower to monitor zen cpu sensors.


upload at main floor.

@sturmstar @opera

Thanks for the update!  Did the unRAID 6.8.0-RC3 patch that was released today accomplish the same thing?  I guess I'll find out tonight when I test RC3 on my gaming pc.  If not I'll revert to RC1 and apply your patch.  :)

Link to comment

@Leoyzen Your kernel patch for rc1 works with rc3.  I am finally booted into my windows os "vm" with bare metal nvme passthrough.  My mouse works but my keyboard does not.  I assume that has something to do with IOMMU.  Something I can sort out later tonight.  Once this vm is tested with games and such,  Ill move on to adding a second RX580 and passthrough my wifes nvme windows os to try.  I built us identical gaming pc's so it shouldnt be any problems.... I hope.  

Link to comment

After locating and passing through a usb controller on the motherboard I finally have full control of my primary windows os with full gpu passthrough.  The 2nd VM works perfect also just need to passthrough another USB controller to it. 


Thanks again for the patch! 


I finally have 2 gamers one cpu with a Ryzen 7 2700x, ASUS ROG Strix X470-F gaming motherboard on latest bios revision.  2 nvme bare metal windows installs passed through to vms with 2 RX580 GPU's and gaming away.  


* Commented this so others may find this post. :)

Link to comment

This worked beautifully on my msi x370 sli plus that I updated for ryzen 3000. Was pulling my hair out trying different settings to get iommu working until I found this thread. Mucho kudos, now if we could get Limetech to implement these fixes....

Edited by phbigred
Link to comment

Quick question, were there changes in this build that affected the br0 settings with VMs? I can't isolate out VPN vs no VPN traffic without using the local client now. Used to just add the IPs to an alias list that routed it on the individual br0 IPs. Pfsense gateway routing used to work for unraid now doesn't function unless I remove the unraid server IP from the VPN.


For clarification I haven't tested against the Limetech build as I just figured this out yesterday. Might be worth some testing.

Edited by phbigred
Link to comment

I now have 2 unRAID servers.  The one on the left is my media/file server.  A Dell Poweredge T410 with dual Xeon cpus and the one on the right is the new 2 gamers 1 cpu build with dual nvme windows passthrough and dual Radeon RX580's.  The Ryzen server I will upgrade to a Ryzen 9 3900x and dual RX 5700 XT's in the near future and out of the desktop chassis and into a 4u server chassis.  @Leoyzen  Thanks again for building those kernel updates so quick to fix this unfortunate bug.  

Screenshot (23).png

Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.