[KERNEL]custom kernel build with treaks (2020.03.07 v6.8.3|5.5.8|4.19.108|NAVI|VEGA|NFSv4|R8125|Zen2)


Recommended Posts

  

On 4/16/2020 at 7:40 AM, Leoyzen said:

@Critica1Err0r Use this one instead. And add your audio id(for example:15b7:5002) to boot-args like this:


append  pcie_no_flr=15b7:5002  initrd=/bzroot

6.8.3-5.5.8-2.zipUnavailable

Thank you for the file! Passing the sound kept crashing my server but after adding your modified files to my usb and the pcie_no_flr to flash settings got my sound working! I'm having some issues passing a single usb hub, passing it to the windows 10 vm results in a unraid crash so I'm forced to pass the keyboard and mouse connected to it instead. I figured I could just append the id like so: 

IOMMU group 41:	[1022:149c] 0b:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Matisse USB 3.0 Host Controller
IOMMU group 42:	[1022:1487] 0b:00.4 Audio device: Advanced Micro Devices, Inc. [AMD] Starship/Matisse HD Audio Controller
append pcie_acs_override=downstream pcie_no_flr=1022:1487,1022:149c initrd=/bzroot

But my guess didn't pan out, I still cant pass that usb hub.
 

I'm on hour 30+ of trying to build this machine so I'm going to to bed, thank you all for your help I'm almost there this is literally the last thing I need to pass before I can go work on the dockers :). 
 

Edited by RaidBoi1904
spelling
Link to comment
  • 4 weeks later...

hi i am so sorry to message on this forum i want to know how to do this patch (3900x and MSI Creation X570 and 5700xt) i am trying to wrap my head a round it and i am lost if ant one could direct me to a video off this being done this would be amazing or a really detailed step by step for newbees 

Link to comment

First I have to say thank you. I have been ripping my hair out trying to get gpu passthrough working on my ryzen 2600 on a b450m with a Vega 56 and a Rx 550. Thanks to your patched kernel,  I can start the VM with the Vega fine an put it to sleep or reboot it fine, but when I shut it down within a few min the fan goes turbo on the Vega and even after using the server standby script to reset my gpu from spaceinvader1 the GPU is disconnected but doesn't reconnect and I am unable to start the VM untill I reboot.

Edited by lordbeavis
Link to comment
  • 3 weeks later...

Hello! I'm new to Unraid, servers, vm's, and other IT type stuff so please excuse my lack of understanding about all this....I have no idea what a kernel is but wondering if this will help me.

 

When building my server (first time to build a computer)....I purchased a Radeon rx580 OC Top Edition GPU not realizing AMD GPU's dont pass through easily. I have a VM w10 that works except when I try to pass through the GPU. However, I'm not sure if I can use your custom kernel since I have a Xeon cpu?? Also, not sure if it would help my issue anyway, but someone suggested that it may help.

 

Any guidance would be greatly appreciated!

Thanks!

Stephen

Edited by SPOautos
Link to comment

What exactly happens when you try to pass through the GPU? Try setting the machine type to Q35 if you haven't already as AMD drivers don't like i440fx.

 

This patch isn't specific to AMD CPU's, it just has patches which help with CPU's that are based on Zen2.

Edited by cobhc
  • Like 1
Link to comment
On 9/5/2020 at 3:56 AM, cobhc said:

What exactly happens when you try to pass through the GPU? Try setting the machine type to Q35 if you haven't already as AMD drivers don't like i440fx.

 

This patch isn't specific to AMD CPU's, it just has patches which help with CPU's that are based on Zen2.

 

I've switched it to Q35. The VM never boots up. I only have one GPU but I log in using my laptop and try to connect using Splashtop. Everything is perfect if I dont pass through GPU, I can open Splashtop and see my w10 VM login screen,  it all works....but passing through the rx580 the Splashtop will never see the VM or be able to connect. 

Link to comment
1 minute ago, SPOautos said:

 

I've switched it to Q35. The VM never boots up. I only have one GPU but I log in using my laptop and try to connect using Splashtop. Everything is perfect if I dont pass through GPU, I can open Splashtop and see my w10 VM login screen,  it all works....but passing through the rx580 the Splashtop will never see the VM or be able to connect. 

Hmm, you could try passing the vbios through as I've had issues before without doing that. I'm not sure past that as I've not had the best of luck myself with VM's.

 

  • Like 1
Link to comment
9 minutes ago, lordbeavis said:

I had to have 2 gpu unless you block it on boot

 

I may try that, I was planning on using a second one anyway because I use Unraid directly and when I pass through the VM my Unraid screen goes black. Good to know that having a second card may actually help with the passthrough issue.

Link to comment
  • 1 month later...
  • 3 weeks later...
On 10/26/2020 at 11:48 PM, bobo89 said:

This kernel doesn't allow me to select "turbo boost" under Tips and Tweaks. Is there another change that needs to be made in order to enable this feature ? (x470 board with 3900x)

Following up with this, I am also trying to figure out why I am getting some very high temperatures (or perhaps reported temps) on the 3900x.

 

Corsair Obsidian 1000D, and a Noctua NH-D15S with 1 140mm fan and one 120. At idle with this kernel unraid is reporting 52C, while under all core load I max out at 84C, with boost clocks still going up as high as 4.1-4.2Ghz.

 

Motherboard is MSI x470 carbon pro, with all settings as Auto in the bios. Is there any chance of incorrect temperatures reported on this kernel/cpu combo ? 

Edited by bobo89
Link to comment
  • 1 month later...

Has the latest Unraid (6.9.0) included all the fixes this Kernel includes?  I would like to upgrade to the latest version (or have a timeline for it), but not if it involves compiling a custom kernel to accommodate the whole x470 motherboards with Ryzen 2 3000 CPU's and pass-through. TY! 

 

Note, I am specifically referencing the FLR fix with the Kernel. 

 

Link to comment
  • 5 months later...
On 12/22/2020 at 5:10 AM, mattz said:

Has the latest Unraid (6.9.0) included all the fixes this Kernel includes?  I would like to upgrade to the latest version (or have a timeline for it), but not if it involves compiling a custom kernel to accommodate the whole x470 motherboards with Ryzen 2 3000 CPU's and pass-through. TY! 

 

Note, I am specifically referencing the FLR fix with the Kernel. 

 

Hey mattz,

I've found a few of your posts in trying to search for a result to my issue and I think it's very similar to what you were having.

Is your USB controller passthrough working correctly now?

I have an ASRock rack x470d4u and recently upgraded to a 3900x from a 2600. I've managed to get my VM to boot with a GPU passed through to it but cannot get the USB controller through to save myself. Any tips?

Link to comment
4 hours ago, k0vw said:

Hey mattz,

I've found a few of your posts in trying to search for a result to my issue and I think it's very similar to what you were having.

Is your USB controller passthrough working correctly now?

I have an ASRock rack x470d4u and recently upgraded to a 3900x from a 2600. I've managed to get my VM to boot with a GPU passed through to it but cannot get the USB controller through to save myself. Any tips?

 

I am now running 6.9.2 without issues for either GPU or USB Controller.  That is, 6.9.0 fixed the FLR issues that was causing my system to hang, without having to use the custom kernel with 6.8.3.

 

If you are updated past 6.9.0 you should be good to use the VFIO-PCI Config interface under Settings in your Unraid admin web GUI to isolate USB controllers.  The only caveat is that I had to be careful about which USB controller I isolated:  One had the Unraid USB key drive, and that needs to stay.  Another USB controller had my Network port on it, so I couldn't isolate that.  Otherwise, I isolated one controller for pass-through to my Windows VM.

Link to comment
13 hours ago, mattz said:

 

I am now running 6.9.2 without issues for either GPU or USB Controller.  That is, 6.9.0 fixed the FLR issues that was causing my system to hang, without having to use the custom kernel with 6.8.3.

 

If you are updated past 6.9.0 you should be good to use the VFIO-PCI Config interface under Settings in your Unraid admin web GUI to isolate USB controllers.  The only caveat is that I had to be careful about which USB controller I isolated:  One had the Unraid USB key drive, and that needs to stay.  Another USB controller had my Network port on it, so I couldn't isolate that.  Otherwise, I isolated one controller for pass-through to my Windows VM.

Ok thanks for that. I seem to be having a different issue then. My setup worked fine with a Ryzen 2600 on my asrock rack x470d4u. When i upgraded to a 3900x I havent been able to pass through any usb controllers. My whole unraid server will freeze up and need a reboot.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.