Jump to content
Sign in to follow this  
JamieK

[Solved] Warn that 'New Config' will clear Docker config

4 posts in this topic Last Reply

Recommended Posts

Posted (edited)

I forgot to un-assign a drive before swapping it out for a new one, and to clear up my mess used 'Tools > New Config' to reset my array with a valid Parity drive. I'm not sure this was necessarily the right way to do this (it might have been overly dramatic)!

 

However, I was surprised that this also cleared out my Docker config and I had to set up my containers again.

 

Could you consider adding some warning text on the 'Tools > New Config' page to say that this will happen?

Edited by JamieK

Share this post


Link to post

Only reason I can see that happening is if your docker.img file was on the drive you unassigned...  But hard to say without knowing the full chain of events

 

7 minutes ago, JamieK said:

I had to set up my containers again

Worst case if the docker image got erased, all you have to do is go to Apps, Previous Apps.  Check everything off and have a coffee.  When you're done they're all installed without you having to set anything up again.

Share this post


Link to post
20 minutes ago, JamieK said:

I forgot to un-assign a drive before swapping it out for a new one, and to clear up my mess used 'Tools > New Config' to reset my array with a valid Parity drive. I'm not sure this was necessarily the right way to do this (it might have been overly dramatic)!

 

However, I was surprised that this also cleared out my Docker config and I had to set up my containers again.

 

Could you consider adding some warning text on the 'Tools > New Config' page to say that this will happen?

There is no warning because New Config does not clear out Docker containers.    You need to lose the docker.img file for that to happen.    As was mentioned the docker config settings for installed containers is still available via Apps->Previous Apps.

Share this post


Link to post

Fair enough! You're right that my docker.img is on disk1 (though I'm not quite sure why that's the case). I'll stop my containers and move it. Thanks for your advice!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this