Jump to content
Sign in to follow this  
kakmoster

PCIe ACS override broke Plex hw transcoding possibilities

7 posts in this topic Last Reply

Recommended Posts

Posted (edited)

I was thinking about asking this in a Plex Docker thread but I do not believe this is an docker issue. 

 

I had to enable PCIe ACS override (set to both) to be able to passthrough my Nvidia graphics card to a VM. This setting broke the possibility to add 

--device /dev/dri:/dev/dri

to the extra parameters row in my Plex docker. It gives me the following error when I try to add the line

Error response from daemon: linux runtime spec devices: error gathering device information while adding custom device "/dev/dri": no such file or directory.

PCIe ACS override is the only option I'd changed before the restart. 

If any further information is needed just tell me and I'll do my best to provide.

Thanks..

 

Edit: to clarify, I use Intel Quicksync for Plex hardware transcoding, not the Nvidia card. 

Edited by kakmoster

Share this post


Link to post

It sounds strange that the ACS override would do this.

With the device passed through, do a ls -al /dev/dri and post the output.

 

Are you sure you have done the modprobe i915 and changed the permissions for /dev/dri?

 

 

Share this post


Link to post
9 hours ago, saarg said:

It sounds strange that the ACS override would do this.

With the device passed through, do a ls -al /dev/dri and post the output.

 

Are you sure you have done the modprobe i915 and changed the permissions for /dev/dri?

 

 

Where do you want me to write the command? In Unraid console? 

 

Everything worked fine before i changed the ACS override setting. I have in the syslinux configuration written i915.alpha_support=1

Share this post


Link to post

In the console, yes.

 

As far as I know, you don't need to add the alpha support anymore.

 

You didn't answer my question about modprobe i915 and changing permission. That is in the go file.

Share this post


Link to post
Posted (edited)
19 hours ago, saarg said:

In the console, yes.

 

As far as I know, you don't need to add the alpha support anymore.

 

You didn't answer my question about modprobe i915 and changing permission. That is in the go file.

Oh right sorry, it was such a long time ago since I changed the go file. This is my go file: 

#!/bin/bash
# Start the Management Utility
/usr/local/sbin/emhttp &
#enable module for iGPU and perms for the render device
modprobe i915
chown -R nobody:users /dev/dri
chmod -R 777 /dev/dri 

edit: from putty console:

root@DeusVult:~# ls -al /dev/dri
/bin/ls: cannot access '/dev/dri': No such file or directory

Same as when trying to pass it to the Plex docker container

Edited by kakmoster

Share this post


Link to post

Could it be my bios that changed the primary graphic adapter to the Nvidia card when I put it in? Instead of the onboard graphics of the cpu?

Share this post


Link to post
Posted (edited)

That might be the reason.

There are for sure no igpu available in your system. So you might need to go hunting in the bios for the correct settings.

Edited by saarg

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this