Jump to content
langelus

Networkproblems - Bonding not working as expected?

3 posts in this topic Last Reply

Recommended Posts

Hi!

 

Been trying to configure bonding for my two HP Microservers to my Netgear GS724TP switch. Tried both balance-rr and LACP and both works in the regard that I achieve connectivity to the servers but it still behaves like a single link in performance, networking isn't my strongest subject so any input from you guys is more than welcome :)

 

Tests performed:

 

SMB transfer from two concurrent clients reading large files one share (files reside on different disks in share)

Iperf3 test from two concurrent clients with the server running the Iperf3 server processes

 

Outcome: Server maxing out at 1 Gb/s

 

 

Share this post


Link to post

No personal experience, I haven't even played with it because what you observed seems to be typical. Bonding seems to be like hyperthreading, in that it makes no difference unless the application is specifically written to take advantage of it. The only benefit you will probably see is the ability to lose one of the links seamlessly. You could also try NFS to one of the clients, I bet both clients would get 1Gb/s if one was nfs and the other was smb.

 

If you want higher speeds you will need to move to 10Gb.

 

Share this post


Link to post
1 hour ago, jonathanm said:

No personal experience, I haven't even played with it because what you observed seems to be typical. Bonding seems to be like hyperthreading, in that it makes no difference unless the application is specifically written to take advantage of it. The only benefit you will probably see is the ability to lose one of the links seamlessly. You could also try NFS to one of the clients, I bet both clients would get 1Gb/s if one was nfs and the other was smb.

 

If you want higher speeds you will need to move to 10Gb.

 

Hard to see why that would make a difference NFS/SMB but might aswell give it a try.  Unfortunately 10 Gb is not possible without replacing all my hardware (no room for NIC's in the servers) so that's a "wallet says; no" :(

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.