Jump to content
bergePanzer581

GTX 1050Ti HDMI audio Linux problem

6 posts in this topic Last Reply

Recommended Posts

Hey guys, I've seen plenty of fixes for so-called 'demonic audio' for windows VM's, but virtually nothing about linux ones. Anyone have a Linux VM equivalent of the MSI utils trick??

 

I've encountered this problem with both Pop! OS, and Manjaro in their most recent versions with my GPU pass through. I've never had a problem in windows VM with any of this before, so Spaceinvader One's fixes don't seem to apply for me. I'm sick of using windows 10 as an HTPC VM (my server is in a case under my TV), and wanted to make the jump to Linux instead.

 

The first problem I ran into was the obvious, no drivers for my Creative Soundblaster Z sound card, so enter the GPU's HDMI audio. I'm using an OVMF bios with Q35 chipset, and a virtual hdd on the array for the linux VM. It's fully updated... The latest Nvidia proprietary drivers are installed in either case. Pulse is the audio control panel for both.


The problem short of video recording it, is when the GPU is enabled, audio repeats itself a hundred times achieving a fraction of an FPS, and same with video. Video feeds with the GPU audio disabled seem to be fine. A severe stuttering that I can't seem to fix... Maybe there's something in /etc I can modify?

🙄

Share this post


Link to post
4 hours ago, jonathanm said:

 

Great! Now if I only knew 'how' to create a .conf file in /etc with root privileges... Lol. Pop OS is based on Ubuntu, and Manjaro on Arch. I think the terminal commands seem to work slightly different depending on the distro you use... I'd love to try this though. Thanks for the reply.

edit:

 

holy eff, it worked. THANK YOU.

Edited by bergePanzer581
it worked

Share this post


Link to post
3 hours ago, bergePanzer581 said:

Great! Now if I only knew 'how' to create a .conf file in /etc with root privileges... Lol. Pop OS is based on Ubuntu, and Manjaro on Arch. I think the terminal commands seem to work slightly different depending on the distro you use... I'd love to try this though. Thanks for the reply.

edit:

 

holy eff, it worked. THANK YOU.

:D  This makes me happy!

Share this post


Link to post
Posted (edited)

Me too.

I was using an old Radeon hd 6570 to circumvent this problem.
Thanks to you guys i can now use my GTX 1050 TI on Linux'Vms with passthrough!
Thank you so much!

 

So, to summarize:

 

# From within the Linux Guest OS, do the following:

 

1) Create the file.

sudo gedit /etc/modprobe.d/snd-hda-intel.conf

 

2) Add the following line, save, and close.

options snd-hda-intel enable_msi=1

 

3) Reboot and issue should be solved!

 

Edited by dudous
Add comments.

Share this post


Link to post
Posted (edited)

Hi Guys! Just want to say that this worked for me, using Linuxmint 20 - ubuntu-based distro, on a Gigabyte Aorus Pro AC Mobo. unRAID 6.9.0-b30.

 

Passedthrough GPU was a GT710 card.

Edited by garydapogi

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.