Jump to content
ICDeadPpl

Forum open in Firefox prevents Windows 10 sleep

3 posts in this topic Last Reply

Recommended Posts

I recently noticed that when I have the Unraid forum open in a tab in Firefox, my Windows 10 won't go to sleep automatically.

"powercfg.exe -requests" gives the following result:

Forum open in Firefox tab

 

 

 

 

 

 

 

 

 

 

 

When I close the Firefox tab with the Unraid forum, I get this and sleep works again:

89753290_UnraidForumclosedinFirefox.png.867cb89b599d423a009e27fd02d0a41c.png

 

When I have the Unraid forum open in a tab in Chrome, I also get the "Legacy Kernel Caller" result.

Curiously, if I right click on the tab in Chrome and select "Mute site" the "Legacy Kernel Caller" vanishes and sleep works again.

Unmuting the site returns the "Legacy Kernel Caller" and sleep won't work.

Muting or unmuting the tab in Firefox doesn't make any difference, the "Legacy Kernel Caller" stays active, preventing sleep.
Is there something keeping a connection open in Firefox to the Unraid Forums, as it's the only site I've noticed with this effect?

 

Share this post


Link to post

I dont know if its that, but the only thing that comes to my mind is that you get notifications e.g. for answers or new pms while browsing (or lets say while you have the forum open) the forum, so there must be some sort of communication- dont know if you can disable that.

Edited by nuhll

Share this post


Link to post

I tried with opening Firefox with add addons disabled, and it still keeps the computer awake if the Unraid forums are open in a tab.

This is what "powercfg.exe -requests" shows when the forums are opened in Firefox:
2078906683_FirefoxUnraidForumsOpen.png.73d5c89368f3f13ab41bcc0e752dcb97.png

 

This is when I close the forums tab:
1317359576_FirefoxUnraidForumsClosed.png.64209bf25a492416c41ccb5c6dcc8a60.png

 

Chrome shows only the "Legacy Kernel Caller" when the forums are open:

1933421027_ChromeUnraidForumOpen.png.7efebf3e229f4227ee0e49b8d7f8e33f.png

 

I have disabled all notifications in the settings in my profile, but it didn't make any difference.
I can have any other webpage or forum open, and going to sleep timeout works.

Just not when the Unraid forums are open in a browser.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.