Jump to content
gmight

UEFI option USB stick removed from unraid

4 posts in this topic Last Reply

Recommended Posts

Hi there. 

I think that I have a relatively easy problem to solve, it's my inexperience that's keeping me from solving it.  I think the larger community might have a quick and easy answer for me to get back on track. 

 

I've got a pretty good setup, and since it doesn't involve any hardware and configuration optioning, i don't think I need to go into that.  I will if someone thinks its needed.  here's my situation; I had a full configuration deployed - array was solid, containers were up, had a win10 vm with a rx580 pass-through + a Mojave VM with the same GPU done and done.  Everything was working soundly.  Then I went and edited my syslinux while in unraid and removed the "permit UEFI" tick and rebooted.  Hands down, in one shot my system wont boot anymore. 

 

I've tried to change the setting on the MB to allow bios booting but it's just not working.  I think that's because when I setup in the boot creator I made it so it would use UEFI to begin with.  I know I can just run the installer again and rebuild the USB drive and again make it go UEFI but I was hoping that there was an simple way of making it do that without reformatting it and rebuilding the OS on the USB.

 

I pulled sandisk USB and dropped into my personal rig, I can browse and see all the files, edit the syslinux, view others.  I just havent been able to find the UEFI option there.  Does someone know where I can go and enable UEFI on the USB stick itself?  If not, I'll burn through the hours it took me to build and get everything dialed in again.  Just thought I'd ask first before I lose a half a day rebuilding my server again.

 

Thanks.

 

As a post script, I'm super impressed with unraid, the meshing of array, vm's and containers all in one... I shut down 2 other systems in my home because of this all in one option.  Love it!

Share this post


Link to post
Posted (edited)

There is a top folder on your flash device called "EFI" or "EFI-".

Rename the folder to EFI if want to use UEFI or rename the folder to EFI- to use legacy.

 

The setting in the "Permit UEFI boot mode" under Main -> Flash device -> Syslinux Configuration will automatically rename this folder accordingly.

 

Edited by bonienl

Share this post


Link to post
15 minutes ago, bonienl said:

There is a top folder on your flash device called "EFI" or "EFI-".

Rename the folder to EFI if want to use UEFI or rename the folder to EFI- to use legacy.

 

The setting in the "Permit UEFI boot mode" under Main -> Flash device -> Syslinux Configuration will automatically rename this folder accordingly.

 

Dude, that work! - system is completely up and running!! The simple things right?

 

Thank you very much bonienl, you're a rock-star! You just saved me quite a bit of work.

Share this post


Link to post

Unraid life is simple 😎 Great you have things working again!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.