Jump to content
TomAsh

[solved] Mulitple problems, docker, community apps, vms, hangs

8 posts in this topic Last Reply

Recommended Posts

Hello,

 

My server is in all sorts of trouble: it freezes, wont shutdown clean, docker containers don't work properly, vms wont install, community applications freeze.

 

When I want to power down or reboot the web gui is still working. 

 

Docker containers start but don't function properly e.g. Plex doesn't show on the network, won't update metadata, crashes later.

Pulling some containers fails as unable to register layers. Despite disabling docker it is still running (can see running containers in terminal), container icons still show on dashboard.

 

Ubuntu server vm wouldn't install - installer crashes at step 12

 

Community applications 2019.09.01e the floating unraid loading logo stays on, I cans scroll the page but none of the buttons work. I have to manually type in servers IP address to get out.

 

I had uncorrectable errors on BTRFS cache so changed to XFS.

 

I have disabled docker and vms, removed docker image, libvirt.img, vm disk images, removed community applications. Run parity check, smart tests, file system tests, docker image scrubs - no errors reported.

 

As soon as I enable or reinstall those features all problems come back. Shares are accessible until the thing crashes.

 

Unraid 6.7.2 (tried nvidia unraid and standard)

 

Ryzen 5 2600

2x corsair 8gb DDR4 3200

Asrock B450m Pro4

2x Seagate 4TB

1x Crucial MX500 1TB

GTX 750Ti

 

Attached are log files.

 

I would be grateful if anyone had a look.

 

tower-diagnostics-20190902-0736.zip tower-syslog-20190902-0736.zip

Share this post


Link to post

I would start with running MemTest from the bootmenu, ideally for 24 hours, but at the very least 2 passes

Share this post


Link to post

Thanks for the tip.

Memtest is already showing errors at 5% pass.

 

Should I continue for a full pass?

Should I stop, remove xmp profile and start again?

Should I replace the ram?

 

Opted for reducing frequency to 2400, so far no errors at 25%.

Will carry on for the next couple of days looking for the optimum ram speed.

 

I'll add this to my list of things I wish I knew before. 

 

 

Edited by TomAsh

Share this post


Link to post

Don't overclock RAM with Ryzen as it's known to corrupt data in some cases, respect the max freq depending on config.

 

2145611877_2ndgen.jpg.60180194d0df546dce4bf0d225581b70.jpg

Share this post


Link to post

On a server, stability is paramount and any overclocking introduces instability.

Sent from my NSA monitored device

Share this post


Link to post

All ok now. Run memtest on 2400MHz with no issues. Server now running like a dream.

Might retest with 2667MHz in the future but happy with what I got now.

 

I put this system together recently as a major upgrade to my ageing server.

In the beginning all was well but it was running in an open case.

Once I closed the case and put it in the corner things started happening.

 

Thanks again

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.